Welcome! Log In Create A New Profile

Advanced

Движение обратно, по оси X

Posted by SmashDream 
Движение обратно, по оси X
November 09, 2014 12:33PM
Здравствуйте. Решил собрать себе принтер. И почти собрал. Но возникла очередная проблема:После установки endstop'cов, двигатель по оси X (по разметке ramps1.4) перестал двигаться назад, то есть в сторону к крайнему положению, где находится endstop. В смысле двигатель крутится только в одну сторону, обратно получаются только легкие потуги, заметные если прислонить палец к двигателю, буд-то силенок не хватает. Смена двигателя или драйвера, удаление endstop-ов ничего не меняет, хотя по остальным осям все нормально. По видимому, где-то короткое замыкание или обрыв. К сожалению из меня неважный доктор Хаус и место болячки определить не могу =/.
На вид Ramps и Arduino mega 2560, без повреждений, однако обилие поджаренного флюса и мелких капель олова у контактов вводит в мандраж. Сам двигатель и драйвер, которые были установлены на ось не повреждены, т.к. после установки их на другую ось работают нормально.
Кто-нибудь сталкивался с подобным?
Вот тут по-подробнее:
arduino mega 2560R3
ramps 1.4
драйвер двигателя pololu a4988 x5
Nema17 x5
Блок питания от ПК 500W
ПО prointerface и прошивка marlin
И на всякий пожарный. Конфигурационный файл прошивки: Configuration.h.
Re: Движение обратно, по оси X
November 09, 2014 03:37PM
попробуй поменять значение:
#define INVERT_X_DIR true


________________________________________________________________________________________________

3D принтеры RUBOT Mini, Protos, BIG; 3D печать. www.rubot.org
Пластик для 3D принтеров: ABS 1200 р./катушка; PLA 1400 р./катушка
________________________________________________________________________________________________
Re: Движение обратно, по оси X
November 09, 2014 08:12PM
Denis, к сожалению мало что поменялось. Направление движения инвертировалось, но осталось таким же хилым, только теперь в другую сторону ( ._.)
Стоит добавить. При таких двигательных потугах, ардуина засчитывает движение(m114), и endstops находятся в состоянии open(m119).
Выяснилась интересная деталь:При первом подключении БП+ардуина+ПК, движение по оси X есть, но очень не продолжительное, при движении на 100мм, продвигается на 3-4см и дальше в эту сторону уже не крутится, обратно - пожалуйста.

Edited 2 time(s). Last edit at 11/09/2014 08:25PM by SmashDream.
Re: Движение обратно, по оси X
November 10, 2014 12:35AM
А откуда на плате появился флюс и капли олова? Вы сами что-то паяли? И после пайки перестало работать?
Если так, то лучше конечно смыть флюс и очистить плату от капель олова.
Re: Движение обратно, по оси X
November 10, 2014 01:48AM
Energoblock, они были, еще до того как я начал что-то паять. Да и паял я совсем не ардуиновские платы D:
Капли очень мелкие, меньше миллиметра в диаметре. И те я удалил механически.
А чем лучше смывать флюс?

Edited 1 time(s). Last edit at 11/10/2014 01:48AM by SmashDream.
Re: Движение обратно, по оси X
November 10, 2014 05:28AM
Quote
SmashDream
А чем лучше смывать флюс?

Я не гуру пайки, специальными средствами типа FluxOff не пользуюсь. Смываю ватной палочкой и спиртом.



Ещё можно попробовать поменять драйвер двигателя на оси Х. Они вроде на ramps съёмные.
Ток настраивали подстроечным резистором по статье, которую я присылал?


А концевиков сколько у вас в комплекте? 3 или 6?
И концевики оптические или механические?
Re: Движение обратно, по оси X
November 10, 2014 08:01AM
Energoblock, смена драйвера ничего не дает, даже если воткнуть питание двигателя задом на перед, то двигатель перестаёт ходить в другую сторону, опыт повторяется на двух драйверах и на двух двигателях, только на оси X, по метке Ramps.
Концевики импровизированные - мышиные кнопки <grinning smiley Замыкаются исправно. С момента выявления глюка, все концевики отключил.
Ток настраивал по статье, которую приводили, ось нигде не клинит, пальчиками проверял =)
Re: Движение обратно, по оси X
November 10, 2014 11:29AM
Так сколько у вас концевиков? 3 или 6?
Судя по настройкам в Configuration.h у вас их должно быть 6. 3 на минимальной позиции и 3 на максимальной.
Re: Движение обратно, по оси X
November 10, 2014 08:18PM
Пока их только 2, больше не настрогал еще eye rolling smiley
Re: Движение обратно, по оси X
November 10, 2014 10:19PM
Quote
SmashDream
Пока их только 2, больше не настрогал еще eye rolling smiley

Они только на оси Х установлены? В минимальном и максимальном положении? Как соединены?
Re: Движение обратно, по оси X
November 11, 2014 02:00AM
Energoblock, первые два установил на ось X и ось Z, опять же по разметке ramps. Установил туда где находится начало координаты каждой оси, то есть в место "парковки".
Сразу после установки каждого endstop-а проверял на работоспособность, с начало установил на ось X, потом на ось Z, все работало как надо. После того решил с эмулировать реальную печать, без экструдера и собственно печатающей головки. Тут-то и выяснилось, что ось X никак не хочет двигаться обратно в место "парковки", там где находится endstop. Поначалу решил, что где-то этот endstop замыкается, но не тут-то было. Прозвон в отключенном виде ничего не дал, сама ардуина рапортует: open. Сейчас все endstop-ы отключены, но ось X больна теми же симптомами.

Edited 1 time(s). Last edit at 11/11/2014 02:02AM by SmashDream.
Re: Движение обратно, по оси X
November 12, 2014 01:23AM
Ладненько. В месте с остатками деталей, заказал новую ардуинку с рапмсом.
Доллар плотным потоком прошелся по финансам, однако D:
Re: Движение обратно, по оси X
November 08, 2015 08:40AM
Получилось решить проблему?
У меня такая же, но только с осью Z, движки крутят только в одно направление, в другое никак не хотят (((((
Re: Движение обратно, по оси X
November 08, 2015 12:34PM
2FastYou, получилось =) Дело было в коротыше, как мне думается. Новая ардуина и новый рампс решили проблему. Все работает до сих пор.
Re: Движение обратно, по оси X
November 08, 2015 05:30PM
Ок, спасибо. Блиин, так не хочется снова заказывать, долго ждать (

Тоже оказался коротыш ) Нашел его на плате ramps, китайцы контакты пайкой замкнули

Edited 1 time(s). Last edit at 11/08/2015 11:14PM by 2FastYou.
Re: Движение обратно, по оси X
July 13, 2016 06:21AM
Ребята так ктонибудь выяснил в чем точно была проблема?
А то у меня аналогичная ситуация...
Тоже думал что-то с эндстопами и тоже движки в другую сторону не хотят крутится...
по началу крутились туго потом вообще перестали причем все 3 оси, звук гудения движков слышно в обратную сторону но движения нет
Знать бы в чем проблема может там какой кондер перепаять или еще че...
У меня в запасе еще лежыт DUE Я думаю поставить но поять же боюсь чтоб не спалить её если проблема в RAMPS
И опять же не хочу ждать месяц Ramps
Re: Движение обратно, по оси X
July 13, 2016 07:00AM
enlan, та ардуина вела себя не адекватно и без рампса. Старый рампс с новой ардуиной не проверял, боязно. На лицо коротыш или сгоревшая емкость какая. Самостоятельно определить не могу.
Sorry, only registered users may post in this forum.

Click here to login