Welcome! Log In Create A New Profile

Advanced

Rectangular bed leveling doesn't start

Posted by trgtylcnky 
Rectangular bed leveling doesn't start
February 12, 2018 11:54PM
Hi,
I am trying rectangular grid leveling but when I send G32, it stops after homing the axes and returns "Limit switch -X was hit ..." error message. This is the output:


Send: N103 G31*25
Recv: Rectangular Grid Probe...
(Here it starts with homing XYZ axes. After that, hotend goes up a little bit. Then it moves back to X- Y- direction until it hits the endstop)
Recv: Limit switch -X was hit - reset or M999 required
Recv: Finding bed failed, check the maxz and initial height settings
Recv: Probe failed to complete, check the initial probe height and/or initial_height settings

My settings are:
zprobe.enable                                true            # set to true to enable a zprobe
zprobe.probe_pin                             1.28^           # pin probe is attached to if NC remove the !  - 1.28!^
zprobe.slow_feedrate                         1               # mm/sec probe feed rate 5
#zprobe.debounce_count                       100             # set if noisy
zprobe.fast_feedrate                         40             # move feedrate mm/sec 100
zprobe.probe_height                          5               # how much above bed to start probe 5
zprobe.z_max                                 200

leveling-strategy.rectangular-grid.enable                   true
leveling-strategy.rectangular-grid.size                     5
leveling-strategy.rectangular-grid.initial_height           20
leveling-strategy.rectangular-grid.y_size                   200
leveling-strategy.rectangular-grid.x_size                   200
leveling-strategy.rectangular-grid.probe_offsets            0,0,0
leveling-strategy.rectangular-grid.home_first               true
Sorry, only registered users may post in this forum.

Click here to login