Welcome! Log In Create A New Profile

Advanced

Hot End Heating Up When Power Turned On

Posted by Kurzaa 
Hot End Heating Up When Power Turned On
March 13, 2016 10:00AM
Finally swapping out my RAMPS board for a Duet 0.85 from Filastruder. Tweaked the system files slightly, but mostly formatted them for my own benefit.

My problem though is that as soon as plugged the board in for testing, the hot end started heating up, which I didn't notice until filament started oozing and popping out (was trying to connect to the web server). Found some Duet documentation recommending checking connectivity between the power input lines, which I didn't have an issue with, but when I checked the hot end leads, there was no resistance between the screws.

Assumed the stranded wire for my hot end was touching, so I tried tinning it (temporarily) and adding heat shrink, but I am still getting the short. Then again, the hot end is just a resistor for generating heat, right? So I shouldn't necessarily see a break (resistance of 1) when checking the terminals.

But, that makes this a firmware issue and now I am lost.

Thanks for the help.
Attachments:
open | download - config.g (4 KB)
open | download - bed.g (1.7 KB)
open | download - homedelta.g (1006 bytes)
Re: Hot End Heating Up When Power Turned On
March 13, 2016 11:07AM
Check that you don't have a short between +3.3V and ground, because that will turn the hot end and bed heaters on. The most common way of shorting +3.3V to ground is to wire the endstop switches incorrectly. If they are normal microswitches, you need to use the two outer pins of the 3-pin connector on the Duet, which is not the same as for RAMPS.


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Full disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet.
Re: Hot End Heating Up When Power Turned On
March 13, 2016 11:11AM
Gonna call it right now, Nailed It.

Noticed the RAMPS signal, positive, and ground wasn't the standard order I am used to with servos, since they are all currently wired with 2-pin connectors, I just went with + and - when plugging them in. I will replace the connectors with 3-pin ends and try it out again.

Thanks David.
Re: Hot End Heating Up When Power Turned On
March 13, 2016 12:26PM
Yep. That definitely appears to be the issue. Rewired the end stops to signal and ground and now when I power on, LEDs power on for each of the end stops which is a really nice feature.

Sadly one of my carriages then broke and won't grab the Y belt. Thankfully I have a back-up already printed.
Re: Hot End Heating Up When Power Turned On
June 21, 2017 06:16AM
Hi David,

My Duet has just developed this issue, but the way it did it was really strange: powered up the printer and from the DuePanel sent the hotend to heat up to 180ºC, to load filament - it went past 180ºC, the temp indicater showed purple (never seen it that color, only yellow and red) - I shut down the printer, powered on a couple of seconds later (to avoid letting heat rise up to the cold side of the hotend), but the printer now kept ON the hotend and kept heating! I powered off, disconnected the hotend resister from the board, and powered on again - the red LED of the hotend is still on - it now does not matter what I do, set temp to 0ºC, etc, the red LED of the power of the hotend stays on.

Although I had just repositioned my 3 extruders into a flying configuration, yesterday I had powered up the machine and moved the head to home, with no signs of the hotend heating up... I am sure I had also heated the hotend yesterday to insert the filament for first time with this new setup,... today I just sent the same order to heat the hotend again, to make sure the filament was fully inserted in the Diamond hotend, and it just kept going up... and now wants to heat up every time I power on..

I have tried disconnecting and reconnecting everything that I had touched during the re-configuration, still no joy, and flashing new FW to Duet and PanelDue... any ideas?

Thanks!
Andy
:-)
Re: Hot End Heating Up When Power Turned On
June 21, 2017 11:41PM
Which Duet version is it, and is it the E0 or E1 output that has the problem?


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Full disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet.
Sorry, only registered users may post in this forum.

Click here to login