Welcome! Log In Create A New Profile

Advanced

IDE error when trying to upgrade

Posted by nkuck 
IDE error when trying to upgrade
February 08, 2018 11:42AM
I had forgotten which Arduino sketch I had installed on my Sanguino/Melzi board printer, so I thought that I would take the opportunity to upgrade from Marlin 1.0 to the latest 1.1. Ran into errors. After correcting a few, I now have the following:

In file included from sketch/ultralcd.cpp:99:0:
ultralcd_impl_HD44780.h:197: error: 'LCD_PINS_RS' was not declared in this scope
LCD_CLASS lcd(LCD_PINS_RS, LCD_PINS_ENABLE, LCD_PINS_D4, LCD_PINS_D5, LCD_PINS_D6, LCD_PINS_D7); //RS,Enable,D4,D5,D6,D7
^
ultralcd_impl_HD44780.h:197: error: 'LCD_PINS_ENABLE' was not declared in this scope
LCD_CLASS lcd(LCD_PINS_RS, LCD_PINS_ENABLE, LCD_PINS_D4, LCD_PINS_D5, LCD_PINS_D6, LCD_PINS_D7); //RS,Enable,D4,D5,D6,D7
^
Multiple libraries were found for "LiquidCrystal.h"
Used: /Users/noelkuck1/Documents/Arduino/libraries/LiquidCrystal
Not used: /Applications/Arduino 1.8.5.app/Contents/Java/libraries/LiquidCrystal
exit status 1
'LCD_PINS_RS' was not declared in this scope

My LCD display is just showing two horizontal bars, but I think that I have the correct one defined. Can anyone help to get me back on track? Thanks.

Also, just found that my Z drives, although move correctly, do so in a veryyyy jerky, noisy manner. Not sure what to look for there.

Edited 1 time(s). Last edit at 02/08/2018 02:28PM by nkuck.
Re: IDE error when trying to upgrade
February 10, 2018 09:29AM
Got it figured out and running. Re-selected the proper lcd and had to reset my Z steps.
Sorry, only registered users may post in this forum.

Click here to login