Welcome! Log In Create A New Profile

Advanced

servo autobed levelling

Posted by rohit939 
servo autobed levelling
May 18, 2017 12:19PM
hello,
i'm trying to use servo
i configured everything like offsets from extruder, probing points,
when i give G29 command
servo extends and then probes to first point, and then it doesnt retract and keeps moving from one point to another
i want to retract my servo at every probing point so i can avoid any crash.
please help,

my servo doesnt retract like it happens in this video [www.youtube.com]

Edited 1 time(s). Last edit at 05/18/2017 12:23PM by rohit939.
Re: servo autobed levelling
May 19, 2017 07:44AM
It depends on which auto bed leveling you are using... But you can usually specify an 'E' option to engage and dis-engage the Z-Probe.

But really... You typically get better measurements if you leave the probe deployed. You are better off setting the various numbers better.

#define Z_CLEARANCE_DEPLOY_PROBE

#define Z_CLEARANCE_BETWEEN_PROBES

Edited 1 time(s). Last edit at 05/19/2017 07:47AM by Roxy.
Re: servo autobed levelling
June 12, 2017 12:33PM
these are not available in latest firmware,
Re: servo autobed levelling
June 12, 2017 04:05PM
Leave it down to probe all the points, its more accurate that way.
Re: servo autobed levelling
June 13, 2017 05:36AM
I had all kinds of challenges with the latest Marlin firmware getting this to work. I then loaded V1.1.0 RC8 and now everything works a charm. Might want to give that a try.

Edited 1 time(s). Last edit at 06/13/2017 05:36AM by RickRap.
Sorry, only registered users may post in this forum.

Click here to login