Welcome! Log In Create A New Profile

Advanced

Enable the Z steppers at startup

Posted by pierrealexb 
Enable the Z steppers at startup
May 11, 2017 02:06AM
I everyone!
First of all I would like to thank the Marlin team for all the work they did on 1.1.0 version!

I have a little issue that I hadn't before updating marlin. My bed is heavy and falls down when steppers are not activated. So I need to keep them enable at any time.
I did this in Configuration_adv.h:

#define DISABLE_INACTIVE_Z false

But this let enable z stepper only after at least one move, but not at startup or after reset.
This is very inconvenient because I'm losing the position all the time...

Do you know how to enable the Z steppers at startup?

Many thanks! spinning smiley sticking its tongue out

Pierrealexb
Re: Enable the Z steppers at startup
May 12, 2017 03:19AM
You could add a pull-down resistor to the enable pin of the z-drivers. That way it is ON all the time.
Sorry, only registered users may post in this forum.

Click here to login