Welcome! Log In Create A New Profile

Advanced

LCD screen on but no data

Posted by Sundowner14 
LCD screen on but no data
March 09, 2016 02:33AM
Newbie would appreciate any advice,I have a new Prusa Steel (Zonestar) printer kit that I built myself.
Carried out initial set up as per instructions no problems. I have made no changes to the program on the unit.
Switched off while I loaded a gcode test file to build a small pillar onto the SD card.
Turned the printer back on LCD is lighting up showing a blank blue screen. The filament cooling fan started up as soon as I switched the printer on and kept running until I switched the machine off.
I pressed the menu button and two rows of greyish rectangles appeared on the screen pulsing every second.
Switched off and tried again with the same results.
Sent email to Zonestar they suggested this website for help.
Hope I'm in the right area for help on this subject.

Thanks
Re: LCD screen on but no data
March 09, 2016 02:34PM
Not much information to go on.
Is the psu power correct?
is there 5 (or 3.3 v) present on the cpu?
Can you talk to the usb port?
Are all the connectors pressed in.
Any leds on the processor board on.
What board are you using?
Re: LCD screen on but no data
March 10, 2016 02:41AM
PSU power is 3.3v
Using Repetiere program I can load a gcode and the xyz motors work. Had to shut down quickly as the x axis motor moved to extreme left of travel
I do not know how to access data off the board thru my computer.
Repetiere program show all axis set at zero ???
I have checked all connectors are pressed right in
No LEDs on board
The board only has Zonestar written on it so I'm thinking clone?
As I said earlier I am on an almost vertical learning curve.
Re: LCD screen on but no data
March 10, 2016 04:21AM
If its the same board as in this video [www.youtube.com]

its a melzi clone by the looks of things [reprap.org]
Re: LCD screen on but no data
March 10, 2016 12:49PM
Thanks for the info.
I have found out the board is a Melzi V2_V3D
dc 12v 20A supplied to the board found an internal break in the + wire - replaced

LCD2004 5 keys keypad

Have removed SD card and tried again
Tried adjusting the screen contrast

Still not displaying on LCD
Only thing I can think is a dry soldered joint or blown component??
Re: LCD screen on but no data
March 10, 2016 05:10PM
The fact that you can talk to the board with Repetier says that the CPU and software are running OK.

Did the LCD screen ever work? Check the connections to your LCD screen and make sure they're OK.

I'm guessing that Zonestar is this, i.e. about the cheapest 3D printer you can buy. At those prices there's probably no quality control... Zonestar will buy in the cheapest (i.e. no QC from their suppliers either) parts and ship them out as kits. Look for solder bridges between tracks on the controller board and LCD board. Place negative feedback on AliExpress until they send you something that works... Chinese companies seem to be very sensitive to this. Be prepared to haggle and don't let them push you around.

I'm not sure exactly what model 3D printer you've got. But maybe you're mistaken the hotend cooling fan for the filament cooling fan? The hotend fan should be on all the time.

OTOH, I wouldn't worry too much about the LCD. I think it's easier to control the printer via Repetier than via the LCD.

Since this is a NZ-only forum, you would probably get more (and, dare I say, better) advice if you posted in the Electronics/Controllers or Prusa i3 forum... a quick search found other mentions of Zonestar there.
Sorry, only registered users may post in this forum.

Click here to login