Welcome! Log In Create A New Profile

Advanced

Start g-code setting for correct nozzle position

Posted by SatorCodex 
Start g-code setting for correct nozzle position
March 17, 2017 03:47PM
Hi.
Ive installed Skynet and E3D with Bowden set up.

But my prints do not start at the center of the bed. Id like it to do so.. smiling smiley
I should be adjusted: x-20 y-10

Ive found out that its possible to do the offset in the start g-code. But, I haven't been able to do so. confused smiley

With skynet, homing is center to the bed.

Here is my code (Cura 2.3.1)

G21 ;metric values
G90 ;absolute positioning
M82 ;set extruder to absolute mode
M107 ;start with the fan off
G28 X0 Y0 ;move X/Y to min endstops
G28 Z0 ;move Z to min endstops'
G29
G1 Z15.0 F9000 ;move the platform down 15mm
G0 X2 Y2 Z2
G92 E0 ;zero the extruded length
G1 F200 E4 ;extrude 3mm of feed stock
G92 E0 ;zero the extruded length again
G1 F9000;Put printing message on LCD screen
M117 Printing...

I have tried to do G28 x-20 y-10 after G29. Not working
Also tried g 90. But not working..

Im sure Ive done something wrong..

A curiosity.
If I click center of bed. In mashinsettings in Cura. It start printing in the corner... spinning smiley sticking its tongue out
I
Re: Start g-code setting for correct nozzle position
March 18, 2017 12:09AM
this should be fixed in firmware.. but if you insist...

G92 set positions

so you need

G28 X0 Y0 ;got to real homes
G92 X-20 Y-10 ;tell printer your really at X -20 Y-10
Re: Start g-code setting for correct nozzle position
March 18, 2017 07:28AM
Ty Dust!

I Agree that it should be set in firmware. But I can only find offset for the probe. Not the nozzle.
Obviously Im missing something?

If I get it sorted in firmware. That would be best.. But I gave up..
Re: Start g-code setting for correct nozzle position
March 18, 2017 07:43AM
In configuration.h you can set the X and Y offset after homing

Quote

// Travel limits after homing
#define X_MAX_POS 220
#define X_MIN_POS -33
#define Y_MAX_POS 220
#define Y_MIN_POS -10
#define Z_MAX_POS 230
#define Z_MIN_POS 0
Re: Start g-code setting for correct nozzle position
March 18, 2017 10:38AM
Quote
obewan
In configuration.h you can set the X and Y offset after homing

Quote

// Travel limits after homing
#define X_MAX_POS 220
#define X_MIN_POS -33
#define Y_MAX_POS 220
#define Y_MIN_POS -10
#define Z_MAX_POS 230
#define Z_MIN_POS 0

I have tried to change those parameters. But, I get compiling error. due to the (fact?) that its out of the boundaries for the inductive sensor.
Im trying to learn.. I'm trying to.. But its going slowly.. smiling bouncing smiley
Re: Start g-code setting for correct nozzle position
March 18, 2017 03:45PM
Quote
SatorCodex
Quote
obewan
In configuration.h you can set the X and Y offset after homing

Quote

// Travel limits after homing
#define X_MAX_POS 220
#define X_MIN_POS -33
#define Y_MAX_POS 220
#define Y_MIN_POS -10
#define Z_MAX_POS 230
#define Z_MIN_POS 0

I have tried to change those parameters. But, I get compiling error. due to the (fact?) that its out of the boundaries for the inductive sensor.
Im trying to learn.. I'm trying to.. But its going slowly.. smiling bouncing smiley



Then maybe you have set the Probing location wrong so that they are not reachable ?
Re: Start g-code setting for correct nozzle position
March 19, 2017 09:37AM
probing location is "correct"
It sitting in the original place. Anet A8.
Its probing where it should be. But. it do not reach the front of the bed.

Hm..
Aso is thinking of the Cura machine setting. You can "tic" a box saying "bed center at 0"
If I, as for now. have it un ticed. it starts in the (almost) middle.
But if I tic the box in Cura. It starts in the front left corner of the bed..

Something is fishy.. smiling smiley
Sorry, only registered users may post in this forum.

Click here to login