Welcome! Log In Create A New Profile

Advanced

Z Axis Slow after Firmware Update

Posted by Vgala9 
Z Axis Slow after Firmware Update
March 10, 2017 03:47PM
I've tried to search the forums but I can't find an answer and I wonder if anyone else is having the issue.

I suppose firstly, how does one decide what the speed of the motors should be? Is it based off of the pitch of the screws somehow?
Re: Z Axis Slow after Firmware Update
March 10, 2017 10:26PM
Vgala9,

Yes, the steps per mm are based on the lead-screws. These are 2mm pitch 4 start threads giving effectively 8mm pitch. The steppers are 1.8 degree full steps, giving 200 full steps per revolution, or with 1/16 micro-stepping (as on the A8) 3200 micro-steps per revolution. The steps per mm are 3200/8 = 400 steps per mm, which is the standard setting for the A8.
Re: Z Axis Slow after Firmware Update
March 10, 2017 11:29PM
The maximum speed for a lead screw axis is determined by the lead and quality of the thread.
Slowest are M5 or M8 screws, followed by trapezoid screws. Ball screws are the fastest IMHO.
It also depends on the stepper torque and the acceleration you've chosen.
I have a Prusa with M5 screw running at 3mm/s and also a CoreXY with 1204 ballscrews that runs 40mm/s (not the final word yet )

You can change the speed and acceleration of the axis with M203 ( speed ) and M201 ( acceleration ) commands

Don't forget to store the best values in Eeprom with M500 at the end of the tests.
Re: Z Axis Slow after Firmware Update
March 11, 2017 05:32AM
Thank you both for responding. I had a catastrophic failure of the extruder and had to replace both the hot end and the board. I didn't have the original firmware (because I forgot to backup), so I loaded the new firmware and now the z axis movement is noticeably slower than prior to the failure. I posted this because I wonder if the z axis movement is not proper, thus is creating the printing problems I'm seeing (see attached photo).

I've checked that my bed is level and it seems that the extruder outputs filament fine when I manually extrude from the screen, so I'm at a bit of a loss. I've noticed that filament bunches around the nozzle, presumably from scraping across the print during the next layer.

Any thoughts would be appreciated.
Attachments:
open | download - IMG_0178.JPG (86.3 KB)
Re: Z Axis Slow after Firmware Update
March 11, 2017 06:38AM
what type of threaded rods do you have on the Z axis, M5 ? M8 ? 8mm 4 start lead screws ?
this will determine what steps/mm you need to set in firmware and will effect the speed of the motors as well.
Re: Z Axis Slow after Firmware Update
March 11, 2017 07:29AM
Vgala9,

I somehow had I it in my mind that you had an A8 when I posted my last reply. However the mechanics of calculating steps per mm are the same, with the relevant figures for your printer.

Slow movement of the Z axis could simply be an incorrect value for Z Axis Maximum feed-rate in the firmware (assuming that the lead-screws turn freely when operated by hand with the steppers off). What value do you have set currently ? The only guidance that I can give you, is that the value for my A8 is 8mm per second, which represents 1 rev per second of the lead-screws. You could also have an incorrect value set in your slicer (the machine settings for Z feed-rate on mine are the default of 100mm per minute).

The nozzle should not be scraping against a previous layer, since it should rise by the layer thickness before starting to print the next one. It sounds very much as though the Z steps per mm setting in firmware is also incorrect. If the value is too small then the control board will not generate enough steps to raise the nozzle the full layer thickness, but it will still extrude the same amount of filament as though the height was correct. You could try using manual controls to raise Z by a specific amount and then measure the actual amount with a ruler, this will give you a check as to whether the Z steps per mm is correct. Also, just double check the filament diameter in you slicer, as some of them default to an odd value.
Re: Z Axis Slow after Firmware Update
March 11, 2017 09:27AM
Really good information, thank you. I will check the firmware settings later this evening. It's really bizarre how this is now happening, as there are many things that have changed due to the failure I had. I KNOW the z axis is moving half the speed it was (at least) so I think I'll start there, perhaps using the suggestion to manually move the axis with screen controls and then physically measure.

This printer is an i3 for reference and the software firmware comes from HICTOP, so I would like to flash it but I'm a noob with the firmware settings. I kick myself for not maintaining a backup of the original firmware that came with he unit, as they cannot apparently give me the previous version of firmware.

He previous print was a raft, but I let it go a little longer this time and the nozzle crashed into the previous layer pretty hardcore.
Re: Z Axis Slow after Firmware Update
March 11, 2017 09:37AM
Quote
obewan
what type of threaded rods do you have on the Z axis, M5 ? M8 ? 8mm 4 start lead screws ?
this will determine what steps/mm you need to set in firmware and will effect the speed of the motors as well.

These are M8 x 300mm screws.
Re: Z Axis Slow after Firmware Update
March 11, 2017 09:44AM
Quote
Supermec
Vgala9,

I somehow had I it in my mind that you had an A8 when I posted my last reply. However the mechanics of calculating steps per mm are the same, with the relevant figures for your printer.

Slow movement of the Z axis could simply be an incorrect value for Z Axis Maximum feed-rate in the firmware (assuming that the lead-screws turn freely when operated by hand with the steppers off). What value do you have set currently ? The only guidance that I can give you, is that the value for my A8 is 8mm per second, which represents 1 rev per second of the lead-screws. You could also have an incorrect value set in your slicer (the machine settings for Z feed-rate on mine are the default of 100mm per minute).

The nozzle should not be scraping against a previous layer, since it should rise by the layer thickness before starting to print the next one. It sounds very much as though the Z steps per mm setting in firmware is also incorrect. If the value is too small then the control board will not generate enough steps to raise the nozzle the full layer thickness, but it will still extrude the same amount of filament as though the height was correct. You could try using manual controls to raise Z by a specific amount and then measure the actual amount with a ruler, this will give you a check as to whether the Z steps per mm is correct. Also, just double check the filament diameter in you slicer, as some of them default to an odd value.

These are the feedrate settings in question, right?
#define DEFAULT_AXIS_STEPS_PER_UNIT   {80,80,398,94.4962144}  // default steps per unit for ultimaker //78.7402, 78.7402,1070,865.88
#define DEFAULT_MAX_FEEDRATE          {500, 500, 5, 25}    // (mm/sec)
#define DEFAULT_MAX_ACCELERATION      {9000,9000,100,10000}    // X, Y, Z, E maximum start speed for accelerated moves. E default values are good for skeinforge 40+, for older versions raise them a lot.

Re: Z Axis Slow after Firmware Update
March 11, 2017 10:38AM
With an M8 screw the z-steps should be 2560. ( 200*16/1.25 )
Try sending M92 Z2560 and do some "dry " moves. If it moves in scale, send M500 to store the value in eeprom
Re: Z Axis Slow after Firmware Update
March 11, 2017 01:02PM
Quote
o_lampe
With an M8 screw the z-steps should be 2560. ( 200*16/1.25 )
Try sending M92 Z2560 and do some "dry " moves. If it moves in scale, send M500 to store the value in eeprom

So that value of 2560 should have been in place of 398, right?
Re: Z Axis Slow after Firmware Update
March 12, 2017 09:55AM
Ok so an update.

Changed settingns per g code commands and that corrected manual operation for a short time. When I tried to initiate a print, the manual control of the printer returned to normal, so I'm wondering if this is a slicr configuration issue. I need to investigate further.
Re: Z Axis Slow after Firmware Update
March 13, 2017 12:26AM
You either haven't sent M500 after the calibration or you haven't enabled Eeprom usage in firmware.

//define this to enable EEPROM support
#define EEPROM_SETTINGS

#if ENABLED(EEPROM_SETTINGS)
  // To disable EEPROM Serial responses and decrease program space by ~1700 byte: comment this out:
  #define EEPROM_CHITCHAT // Please keep turned on if you can.
#endif


You can also put the M92 Z2560 line in your slicers start code, before G28.
Re: Z Axis Slow after Firmware Update
March 17, 2017 06:48PM
Quote
o_lampe
You either haven't sent M500 after the calibration or you haven't enabled Eeprom usage in firmware.

//define this to enable EEPROM support
#define EEPROM_SETTINGS

#if ENABLED(EEPROM_SETTINGS)
  // To disable EEPROM Serial responses and decrease program space by ~1700 byte: comment this out:
  #define EEPROM_CHITCHAT // Please keep turned on if you can.
#endif


You can also put the M92 Z2560 line in your slicers start code, before G28.

So eeprom wasn't enabled, which explains why I saw the motors function properly after sending the g code, but not retain as part of the firmware. I've since discarded the HICTOP firmware and declared it to be garbage. I've flashed with updated marlin and have used a configuration file I've found in a related topic. The new marlin software paired with this configuration file is super sexy and I, very happy with the work someone else has done.

Thanks for all of your help.
Sorry, only registered users may post in this forum.

Click here to login