Welcome! Log In Create A New Profile

Advanced

RepRap Guru i3 Printer Kit (Official Thread)

Posted by REPRAPGURU 
Re: RepRap Guru i3 Printer Kit (Official Thread)
February 22, 2017 10:59AM
Quote

Quote
lsmith1437
I've designed an X-Axis tension block as a drop-in part for the RepRapGuru. Works with the V1 and V2:

[www.thingiverse.com]

It requires some very inexpensive hardware from the likes of Ace Hardware. I'm using it right now, it works like a charm.

I also started a group for RepRapGuru group on Thingiverse:

[www.thingiverse.com]

-L. Smith

I joined your group
Re: RepRap Guru i3 Printer Kit (Official Thread)
February 25, 2017 09:33AM
Did you have it running. I tried the recent version of Marlin and it doesn't work for my printer. Some instruction on what to change would be appreciated.
Re: RepRap Guru i3 Printer Kit (Official Thread)
February 25, 2017 09:43AM
I tried RC8 but it's not working. Trying to home xyz, it gives a buzz sounds. Have to switch back to the original repapguru marlin version. Anything need to be modified to make it work with the RC8? Thanks
Re: RepRap Guru i3 Printer Kit (Official Thread)
February 27, 2017 01:35PM
Hi all,
Ive gotten my RepRap Guru i3 kit up and running and it works great but Im getting 0 volts on the d9 output for a cooling fan. Right now I have the extruder fan wired on the 12v always on pins above and to the right and using the shroud helps with the cooling of the print but no matter the settings or firmware d9 seems to do nothing. It knows the fan should be on via the settings, it will display on the 2004lcd that its on full but it has no volts output. The config shows 33 in the marlin settings, and the fan even when set to be on 100% for testing has 0v output. Am i missing something? If im not and something is blown or bad what options do I have for controlled cooling? Or am I looking at getting a new board?
Lastly has anyone else had issues with the liner rods getting eat up by the bearings? My upper X axis rod had a massive groove that developed over the last week since ive gotten it up and running until I got to the point I had prints failing. Once I got that I pulled the rod sanded it with 600-1500 sandpaper and then wet with 1500 to get that cleaned up and replaced the 2 bearings but it feels like all the rods are starting to develop this and I wasn't sure what is going on. All the bearings are greased and so are the rods so i wouldn't think it should be happening unless I just have terrible luck.

Sorry for my rambling
o7 Turbo
Re: RepRap Guru i3 Printer Kit (Official Thread)
February 28, 2017 02:53PM
Is it possible to share your Marlin RC8 Configure.h? I was told by manually transfer the value of parameters of the REPRAPGURU Marlin code to the RC8 version, it will work. It looks like a daunting task and I would appreciate it very much for a new working code to proceed for my autobed leveling adventure. Thanks in advance.
Re: RepRap Guru i3 Printer Kit (Official Thread)
March 01, 2017 02:23PM
Hey guys, I just got my RepRapGuru kit yesterday, and I assembled it with relatively few problems, but my Z axis will only step in one direction. I've switched between the older Marlin RepRap firmware, and the newest Marlin Bugfix build, and I think it may be a problem with either the end-stop, the RAMPS, or the Arduino, but as far as that, I'm pretty much out of ideas. Also, I can't get my LCD display to work, no matter what firmware settings I try.

EDIT: So I enabled dual Z axis stepping, and moved one of the motors to the second Extruder driver. That motor now moves correctly, both up and down, and the motor I left on the Z driver only moves up. Seems to narrow it down to the Z driver. Also, the endstop is normally open, as it should be, so it's not an endstop issue.

EDIT2: So I fixed the issue by doing some printer hacking. I took apart the 4 pin connectors of the Z motors and wired them together, and now I'm running both motors off of the second extruder driver, which has finally got my printer working correctly. Also, my LCD issue seems to have sorted it self, it came alive after I reconnected it and it's working now

Edited 3 time(s). Last edit at 03/02/2017 01:01AM by Lightfeather10.
Re: RepRap Guru i3 Printer Kit (Official Thread)
March 04, 2017 08:00AM
OK. Got it running after transferring all old version parameter to RC8. Not print it yet though.
Re: RepRap Guru i3 Printer Kit (Official Thread)
March 04, 2017 01:29PM
Hi Nick,

Can you explain me how to adjust the extruder ? With the factory setting I obtain 180mm when I command the printer to extrude 100mm ?
I tried to change this value on lcd panel: Control -> Motion -> Esteps/mm (900) with this formula (100/180) * 900 but it's worst
what can I do, I'm not able to print something ?

best

Reprapguru prusa i3 with PLA
Re: RepRap Guru i3 Printer Kit (Official Thread)
March 05, 2017 09:57AM
Quote
MostTornBrain
Quote
adlammons
I am running REPRAP_GURU_MARLIN_V.2 but it doesn't include auto bed leveling. MARLIN 1.1.0RC8 does have auto bed leveling. However, I can't tell if it would be an issue to use it instead.

Is there a newer version of the Marlin software?
Or, can I just load the Marlin-1.1.0-RC8?

I've switched to the RC8 version of Marlin and it is working well for me, however I have not enabled the bed leveling as I don't have the hardware for it. The RC8 firmware has some new features which are very nice. However, the Marlin firmware configuration files have changed a lot since the REPRAP_GURU version (which was from 2014, I think) so it is a bit tedious having to make sure you bring over all the right settings from configuration.h and configuration_adv.h.

One key thing is they've changed the algorithm for how the jerk and acceleration are calculated, so you may need to adjust the value your were using (I've found cutting it by 50% was needed) otherwise you may notice some worse ringing in the walls of your prints after the nozzle turns a corner.

If you enable and calibrate the LIN_ADVANCE feature, it makes a significant improvement in the quality of the prints. There's a tutorial here for it: [marlinfw.org]


Maybe you could share your copy to help the less experienced of us on getting this setup and working? Im working on getting this all setup and for me ill just have a lot of trial and error. But maybe at the least we will get this going with help as a group.
Re: RepRap Guru i3 Printer Kit (Official Thread)
March 05, 2017 10:35AM
Quote
Turboaddiction
Maybe you could share your copy to help the less experienced of us on getting this setup and working? Im working on getting this all setup and for me ill just have a lot of trial and error. But maybe at the least we will get this going with help as a group.

Here's a link to the configuration.h and configuration_adv.h I am using with RC8 for my Reprap Guru.

[www.stormyprods.com]

Note: you should definitely double-check them using a source code diff tool to make sure all the changes I've made make sense for your setup. For example, I've added a separate print cooling fan on pin 9 (independent of the nozzle heat element cooling fan), enabled the filament change support, Ive enabled LIN_ADVANCE, etc.
Re: RepRap Guru i3 Printer Kit (Official Thread)
March 05, 2017 05:35PM
Im looking into buying one of these printers. One thing that I've noticed with the DIY i3 printers is that a lot of their power supplies are catching fire, sparking, or smoaking... Possibly dangerous stuff. Has that ever been an issue with this printer or is this one safer than the others?
Re: RepRap Guru i3 Printer Kit (Official Thread)
March 08, 2017 07:38PM
My stepper motors crash into ends during manual controll testing and home command. Someone said to flip the stepper controllers wiring - did it work for anyone else. What color wires on the controllers should be oriented down ? Instructions showed RED.

Edited 1 time(s). Last edit at 03/08/2017 07:40PM by pdotterw.
Sorry, only registered users may post in this forum.

Click here to login