Welcome! Log In Create A New Profile

Advanced

"Communication timeout - reset send buffer block" - Repetier-Host V1.6.1 ARGH!

Posted by muntahunta 
"Communication timeout - reset send buffer block" - Repetier-Host V1.6.1 ARGH!
April 29, 2016 10:12AM
This problem seems to be completely random. sometimes it happens within seconds of my print, sometimes the printer doesnt need to have printed and sometimes (most annoyingly) 6 hours into a 6 and a half hour print!

Basically the printer is happy and printing, then I get "Communication timeout - reset send buffer block" in my log on repetier host.

The printer stops moving (but the heaters stay on) and if i click ANYTHING in the repetier software, the software crashes and not even ctrl-alt-delete then end process works. In order to reconnect to my printer, I have to reset my computer, losing all progress on the print and interuppting whatever else I am doing.

I've tried hunting forums and google and there is not an answer that I can find that is effective.
I have tried software reinstall and disconnecting the power supply from RAMPS and putting it back, but nothing.

Any advice?
SO ?

PC, Windows are NOT "real time" computer and OS !

Print from the SD card.
Did you extended the usb cable with an extender ?
Would a rasberry Pi work better?
There is no extender.
It has worked fine using windows and PC for the past 6 month... this just came out of the blue.
Tried new USB cable, no difference
Re: "Communication timeout - reset send buffer block" - Repetier-Host V1.6.1 ARGH!
October 18, 2016 04:42AM
OK, all this time and i'm still getting this problem.
I've tried changing firmware, changing the USB cable taking the printer down and rebuilding it, tried printing from the SD card but it just beeps at me and does nothing.
Nothing is fixing this problem and it is basically restricting my print times to 2-4 hours, and even then it could be just 10 mins.

Has anyone got any idea how I could fix it?
For the first few months of running the printer I never had a problem, it came out of nowhere.
I'm getting the same issue. At one stage, the USB connector on my RAMBo board came loose, so I soldered on a cable. I think the issue is occurring there, after extended use has perhaps worn the soldered connection.
Re: "Communication timeout - reset send buffer block" - Repetier-Host V1.6.1 ARGH!
December 03, 2017 06:37PM
I have the same problem on two machines with two different PCs running Ubuntu 14.04 and 16.04 and two different control boards--an ArduinoMega2560 with RAMPS 1.4 and a Printrboard Rev. F. One machine runs R-H 1.6.2--The Arduino/RAMPS. The other runs R-H 1.6.0. One of the USB cables uses a cable extender. The other--a 6' cable--does not. Both run at 115200 bps.

The problem occurs randomly, sometimes after several successful prints. It can occur after a few minutes, or after hours and hours of printing. Similar to Muntahunta's limiting print time to 2 to 4 hours, I'm mitigating the problem by limiting the number of objects I print at one time.
Re: "Communication timeout - reset send buffer block" - Repetier-Host V1.6.1 ARGH!
December 04, 2017 12:40AM
Last I looked Repetier-Host is a .net application

On Linux this is emulated (badly, being a Microsoft windows thing.)

In my view If you must use Repetier-Host, use windows

Or as others have said, use a SD card. And avoid all the host machine issues
Re: "Communication timeout - reset send buffer block" - Repetier-Host V1.6.1 ARGH!
December 04, 2017 05:27AM
I would advice to run the Repetier server, and print from there, you can then add jobs via Repetier host or via a web based interface.
You can also see the progress, in the host or via web page. With the webserver I didn't see these problems. But they advice to use good quality usb cables.
Also it is smart to post Repetier problems in the Repetier forum,

[forums.reprap.org]


P3steel DXL, with Due/RADDS/Raps128 dual Wade's extruder
Re: "Communication timeout - reset send buffer block" - Repetier-Host V1.6.1 ARGH!
December 04, 2017 04:50PM
I've been running Repetier on Linux for over four years using the 'mono' emulator. Where I did have some issues early on, those seem to have been resolved. Searching the Internet about this problem, it seems unrelated to the OS used.

Thanks for the SD suggestion. I will try the SD card on the Printrbot. The Arduino/RAMPS, though, doesn't have an SD as an option. (I may swap this out for a Megatronics board I have). Thanks again. You helped. I really do want to feel more comfortable doing prints taking several hours.
Re: "Communication timeout - reset send buffer block" - Repetier-Host V1.6.1 ARGH!
December 04, 2017 05:39PM
Thanks for the advice--and the reminder to post to the Repetier forum. You're right. Repetier is quite responsive.
Re: "Communication timeout - reset send buffer block" - Repetier-Host V1.6.1 ARGH!
December 05, 2017 12:00AM
do you have the "12864 LCD Full Graphic Smart Display Controller"

if so you have SD card port , it is on the display as far as I can remember


P3steel DXL, with Due/RADDS/Raps128 dual Wade's extruder
Sorry, only registered users may post in this forum.

Click here to login