Welcome! Log In Create A New Profile

Advanced

Folger Tech 2020 i3 Printer Kit (Official Thread)

Posted by Dan_FolgerTech 
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 11, 2015 11:20PM
After some trouble shooting I confirmed that theres something wrong with my z motors. Ill just repost what I wrote before:

My two z motors vibrate but don't turn. I'm guessing this is because the stepper motor coils are wired to the wrong pair of wires?

(Newbie to electronics here) So after determining which coil goes to which pair, do I just cut off the connector, re-arrange the pair, and attach crimps, and then the connector? Or would there be another way to re-arrange the pair of wires. How do I get the previous wires out of the connector? (Silly question I know)



How would I physically re-arrange the pairs? Any tutorials on this?
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 12, 2015 12:48AM
Quote
watlooazn
After some trouble shooting I confirmed that theres something wrong with my z motors. Ill just repost what I wrote before:

My two z motors vibrate but don't turn. I'm guessing this is because the stepper motor coils are wired to the wrong pair of wires?

(Newbie to electronics here) So after determining which coil goes to which pair, do I just cut off the connector, re-arrange the pair, and attach crimps, and then the connector? Or would there be another way to re-arrange the pair of wires. How do I get the previous wires out of the connector? (Silly question I know)



How would I physically re-arrange the pairs? Any tutorials on this?

Going with Occam's Razor here - it seems unlikely that the two motors you used for the Z-axis have the coils wired to the wrong pair of wires, and your problem lies elsewhere.


Need help? Visit the Folgertech Wikia Page

The latest Marlin firmware with Folgertech Prusa i3 settings merged in, get it here

And check out my designs on Thingiverse, and follow me if you like what you see!
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 12, 2015 06:24AM
Having fun printer Christmas Gifts smiling smiley






Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 12, 2015 08:35AM
Quote
therippa
Quote
watlooazn
After some trouble shooting I confirmed that theres something wrong with my z motors. Ill just repost what I wrote before:

My two z motors vibrate but don't turn. I'm guessing this is because the stepper motor coils are wired to the wrong pair of wires?

(Newbie to electronics here) So after determining which coil goes to which pair, do I just cut off the connector, re-arrange the pair, and attach crimps, and then the connector? Or would there be another way to re-arrange the pair of wires. How do I get the previous wires out of the connector? (Silly question I know)



How would I physically re-arrange the pairs? Any tutorials on this?

Going with Occam's Razor here - it seems unlikely that the two motors you used for the Z-axis have the coils wired to the wrong pair of wires, and your problem lies elsewhere.

What did you find during troubleshooting?

Edited 1 time(s). Last edit at 12/12/2015 01:17PM by Mach.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 12, 2015 03:20PM
Alright guys my bad, I didn't read the previous posts, thanks for your help. Now regarding my Z motors Issues:

I found out that the Z motors work perfectly fine after connecting them to the x and y ports. Also, the reason they were vibrating and not moving before was because my threaded rods weren't installed properly.




But now I have a new issue:

It takes my z axis approx 30 seconds to move approx 1.5 inches. It is noticeably slower than the y and x axises. Im guessing that maybe there is not enough current supplied to them? Voltage? Regardless, I think I have to change some setting in the arduino code. How would I do this? How would I access the code from the IDE? (silly questions, but noob here who wants to learn smiling smiley )
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 12, 2015 03:55PM
Quote
watlooazn
Alright guys my bad, I didn't read the previous posts, thanks for your help. Now regarding my Z motors Issues:

I found out that the Z motors work perfectly fine after connecting them to the x and y ports. Also, the reason they were vibrating and not moving before was because my threaded rods weren't installed properly.




But now I have a new issue:

It takes my z axis approx 30 seconds to move approx 1.5 inches. It is noticeably slower than the y and x axises. Im guessing that maybe there is not enough current supplied to them? Voltage? Regardless, I think I have to change some setting in the arduino code. How would I do this? How would I access the code from the IDE? (silly questions, but noob here who wants to learn smiling smiley )

Open the arduino ide, go file > open, find the folder where you are keeping marlin on your computer, keep double click on you marlin folders until you get to the folder that shows all of the various files that belong to to marlin, double click anyone of them and it will open up all of them up, find the config.h tab in the ide.

Things I would suggest checking are:
1. Does you Z axis move the amount you tell it to
2. Is you Z axis steps per MM at 4000
3. Is your Z axis feedrate in repetier at around 100mm/min

Your Z axis is going to move way slower than your X and Y axis because it is using threaded rods. This is fine. As long as the three things I outlined above checks out, you should be good smiling smiley
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 13, 2015 04:12PM
awesome I will try this, thanks!

Another question is shouldn't the Y endstop be placed near the front of the printer? The manual says to place it at the rear. But from my understanding, if we want the home position of the extruder to be at the back right of the bed, then the y endstop should be at the front so the heatbed can move foward and for the extruder to be at it's back right.

How can I change the direction of my y motor? When I press home, it moves back, I want it to move to the front.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 13, 2015 04:14PM
Anyone order from Folger Tech recently? I placed my order about a week and a half ago and they printed the label the next day but nothing has shipped?
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 13, 2015 04:35PM
(Deleted, double post)

Edited 1 time(s). Last edit at 12/13/2015 04:36PM by animoose.

See my blog at [moosteria.blogspot.com].
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 13, 2015 04:35PM
Quote
marc2912
Anyone order from Folger Tech recently? I placed my order about a week and a half ago and they printed the label the next day but nothing has shipped?

Don't worry, I think they always do that. My order showed as two shipping labels (one for the printer and one for the filament), and it arrived on two different labels.


See my blog at [moosteria.blogspot.com].
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 13, 2015 04:58PM
Quote
animoose
Quote
marc2912
Anyone order from Folger Tech recently? I placed my order about a week and a half ago and they printed the label the next day but nothing has shipped?

Don't worry, I think they always do that. My order showed as two shipping labels (one for the printer and one for the filament), and it arrived on two different labels.

Yeah mine is like that too. The filament tracked right away and already delivered. The printer label is printed but hasn't shipped and is been over a week. I'm trying to get an idea how long their turnaround is.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 13, 2015 05:28PM
Quote
watlooazn
awesome I will try this, thanks!

Another question is shouldn't the Y endstop be placed near the front of the printer? The manual says to place it at the rear. But from my understanding, if we want the home position of the extruder to be at the back right of the bed, then the y endstop should be at the front so the heatbed can move foward and for the extruder to be at it's back right.

How can I change the direction of my y motor? When I press home, it moves back, I want it to move to the front.

Correct, if you want the home position of the bed to be up front, the endstop goes up front. If it moves in the wrong direction only when you when you press the home button, you most likely just have to change your home direction in firmware (#define Y_HOME_DIR xx), otherwise, you can change the direction the motor turns by flipping the motor's connector on the ramps.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 14, 2015 08:29AM
therippa,

What version of firmware do i need for the E3D-v6 HotEnd? I notices there is 3 different firmware for this on your github. I'm running a stock printer with E3D-v6 direct drive hotend upgrade only.



Anyone,

Whats a good way to edit an STL file. I have one that i want to make a small change to but haven't figure out how. I'm using 123d Design with Meshmixer.

thanks for any input.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 14, 2015 08:46AM
Quote
Mopar99

Anyone,

Whats a good way to edit an STL file. I have one that i want to make a small change to but haven't figure out how. I'm using 123d Design with Meshmixer.

thanks for any input.

TinkerCad is about as simple as you can get. Just go over to the right and 'import' it.

Edited 1 time(s). Last edit at 12/14/2015 08:48AM by tjnamtiw.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 14, 2015 09:48AM
Quote
marc2912
Quote
animoose
Quote
marc2912
Anyone order from Folger Tech recently? I placed my order about a week and a half ago and they printed the label the next day but nothing has shipped?

Don't worry, I think they always do that. My order showed as two shipping labels (one for the printer and one for the filament), and it arrived on two different labels.

Yeah mine is like that too. The filament tracked right away and already delivered. The printer label is printed but hasn't shipped and is been over a week. I'm trying to get an idea how long their turnaround is.

Me too - I got a tracking number for the printer (or at least I assume it's the printer) last Tuesday, with no updates yet. If I don't have an update soon, I'll ask what's going on, but I'm not worried yet.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 14, 2015 09:55AM
Quote
Mopar99
therippa,

What version of firmware do i need for the E3D-v6 HotEnd? I notices there is 3 different firmware for this on your github. I'm running a stock printer with E3D-v6 direct drive hotend upgrade only.



Anyone,

Whats a good way to edit an STL file. I have one that i want to make a small change to but haven't figure out how. I'm using 123d Design with Meshmixer.

thanks for any input.

I use designspark mechanical as my go to cad program. It has lots of features including STL import and export.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 14, 2015 10:06AM
Quote
bstern
Quote
marc2912
Quote
animoose
Quote
marc2912
Anyone order from Folger Tech recently? I placed my order about a week and a half ago and they printed the label the next day but nothing has shipped?

Don't worry, I think they always do that. My order showed as two shipping labels (one for the printer and one for the filament), and it arrived on two different labels.

Yeah mine is like that too. The filament tracked right away and already delivered. The printer label is printed but hasn't shipped and is been over a week. I'm trying to get an idea how long their turnaround is.

Me too - I got a tracking number for the printer (or at least I assume it's the printer) last Tuesday, with no updates yet. If I don't have an update soon, I'll ask what's going on, but I'm not worried yet.


They shipped the 2020s this morning. The Kesslers are this afternoon.

M.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 14, 2015 01:23PM
Quote
Mopar99
therippa,

What version of firmware do i need for the E3D-v6 HotEnd? I notices there is 3 different firmware for this on your github. I'm running a stock printer with E3D-v6 direct drive hotend upgrade only.

You should just use the Release branch. The other branches I have there are specific to my setup, and they are just changes to the configuration.h file, but all use the same version of Marlin (except for the E3D_V6-1.10 branch, which is using the latest release candidate of Marlin and has a lot of changes for my very customized printed, use at your own peril)


Need help? Visit the Folgertech Wikia Page

The latest Marlin firmware with Folgertech Prusa i3 settings merged in, get it here

And check out my designs on Thingiverse, and follow me if you like what you see!
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 14, 2015 01:37PM
Quote
therippa
Quote
Mopar99
therippa,

What version of firmware do i need for the E3D-v6 HotEnd? I notices there is 3 different firmware for this on your github. I'm running a stock printer with E3D-v6 direct drive hotend upgrade only.

You should just use the Release branch. The other branches I have there are specific to my setup, and they are just changes to the configuration.h file, but all use the same version of Marlin (except for the E3D_V6-1.10 branch, which is using the latest release candidate of Marlin and has a lot of changes for my very customized printed, use at your own peril)

ok, so basic i can swap the hot end and not have to change anything if i am already running the "release" branch. smiling smiley

Edited 1 time(s). Last edit at 12/14/2015 01:38PM by Mopar99.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 14, 2015 02:43PM
looks like tinkercad will work, was kind hoping for something to install on my mac as i dont have internet at home. life in the stick smiling smiley
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 14, 2015 03:29PM
Quote
Mopar99
looks like tinkercad will work, was kind hoping for something to install on my mac as i dont have internet at home. life in the stick smiling smiley

Ah, you needed something that would work with a mac os. Sketchup works pretty well and it has mac compatibility. Not as good as designspark, but still pretty decent. You will need to install the sketchup stl plugin though since it does not have built in stl import/export functions.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 14, 2015 05:28PM
Quote
Mopar99
therippa,

What version of firmware do i need for the E3D-v6 HotEnd? I notices there is 3 different firmware for this on your github. I'm running a stock printer with E3D-v6 direct drive hotend upgrade only.



Anyone,

Whats a good way to edit an STL file. I have one that i want to make a small change to but haven't figure out how. I'm using 123d Design with Meshmixer.

thanks for any input.

I have been using sketchup.


Newbie with Folgertech 2020 i3.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 14, 2015 09:18PM
Quote
marc2912
Quote
bstern
Quote
marc2912
Quote
animoose
Quote
marc2912
Anyone order from Folger Tech recently? I placed my order about a week and a half ago and they printed the label the next day but nothing has shipped?

Don't worry, I think they always do that. My order showed as two shipping labels (one for the printer and one for the filament), and it arrived on two different labels.

Yeah mine is like that too. The filament tracked right away and already delivered. The printer label is printed but hasn't shipped and is been over a week. I'm trying to get an idea how long their turnaround is.

Me too - I got a tracking number for the printer (or at least I assume it's the printer) last Tuesday, with no updates yet. If I don't have an update soon, I'll ask what's going on, but I'm not worried yet.


They shipped the 2020s this morning. The Kesslers are this afternoon.

M.
Seems par for the course. For me, there was a fairly lengthy wait between creating the shipping label and actually shipping. I'm guessing Mr. Folger makes a trip to the post office once he has enough orders to ship.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 14, 2015 09:38PM
Anyone have any ideas on what I can do to fix me computer getting Firmware unresponsive error messages? I have replaced the USB cable already. Made sure my computer isn't turning the USB off. Really sucks when it dies mid print. Sometimes it will recover but others it just sits there and melts a hole in the print.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 14, 2015 10:13PM
Quote
built350camaro
Anyone have any ideas on what I can do to fix me computer getting Firmware unresponsive error messages? I have replaced the USB cable already. Made sure my computer isn't turning the USB off. Really sucks when it dies mid print. Sometimes it will recover but others it just sits there and melts a hole in the print.

That is the nature of printing via usb, lots of communication errors due to electrical interference. I would suggest getting a lcd controller/sd card reader for your printer asap. I used to print via usb, but was driven crazy by the amount of communication errors I got, so I installed a lcd controller. One of the best additions to my printer.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 14, 2015 10:25PM
Quote
built350camaro
Anyone have any ideas on what I can do to fix me computer getting Firmware unresponsive error messages? I have replaced the USB cable already. Made sure my computer isn't turning the USB off. Really sucks when it dies mid print. Sometimes it will recover but others it just sits there and melts a hole in the print.

Mine worked better on some USB ports than on others. In particular, my monitor has a USB hub built into it, and it was less reliable with that than a USB port directly on the PC.


See my blog at [moosteria.blogspot.com].
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 15, 2015 03:25AM
Quote
animoose
Quote
built350camaro
Anyone have any ideas on what I can do to fix me computer getting Firmware unresponsive error messages? I have replaced the USB cable already. Made sure my computer isn't turning the USB off. Really sucks when it dies mid print. Sometimes it will recover but others it just sits there and melts a hole in the print.

Mine worked better on some USB ports than on others. In particular, my monitor has a USB hub built into it, and it was less reliable with that than a USB port directly on the PC.

A good quality shielded usb cable might really help, I know you said you changed it but I doubt your cables are faulty, just probably cheap.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 15, 2015 06:36AM
Updated my Marlin firmware to 1.1.0 RC2...everything seemed to be working fine. But while running a few calibration prints I got a "HEATER FAILED" fault. Is this a thermistor issue, or has something changed in that release that could be causing it (Thermal Runaway Protection)!?!?

I'm going to put a new thermistor in when I get home today, just wondering what else could cause the fault...

Thanks,
Sonny
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 15, 2015 07:22AM
Quote
sonnylowe
Updated my Marlin firmware to 1.1.0 RC2...everything seemed to be working fine. But while running a few calibration prints I got a "HEATER FAILED" fault. Is this a thermistor issue, or has something changed in that release that could be causing it (Thermal Runaway Protection)!?!?

I'm going to put a new thermistor in when I get home today, just wondering what else could cause the fault...

Thanks,
Sonny
I'm running the same firmware, 1.1.0 RC2. HEATER FAILED is not something I've seen. I did have some problems with thermal runaway protection on the heated bed though. It is enabled on default, and has a fairly narrow deadband that caused it to trip and spoil a few prints. I ended up disabling the heated bed thermal runaway protection. Even if the heaters stayed on 24/7, I doubt the MK2B heated bed would rise above 110. Hardly a dangerous situation, and not worth the ruined prints.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 15, 2015 07:43AM
Quote
elkayem
Quote
sonnylowe
Updated my Marlin firmware to 1.1.0 RC2...everything seemed to be working fine. But while running a few calibration prints I got a "HEATER FAILED" fault. Is this a thermistor issue, or has something changed in that release that could be causing it (Thermal Runaway Protection)!?!?

I'm going to put a new thermistor in when I get home today, just wondering what else could cause the fault...

Thanks,
Sonny
I'm running the same firmware, 1.1.0 RC2. HEATER FAILED is not something I've seen. I did have some problems with thermal runaway protection on the heated bed though. It is enabled on default, and has a fairly narrow deadband that caused it to trip and spoil a few prints. I ended up disabling the heated bed thermal runaway protection. Even if the heaters stayed on 24/7, I doubt the MK2B heated bed would rise above 110. Hardly a dangerous situation, and not worth the ruined prints.

Thanks for the info. With that said I'll assume it's a hardware issue for now...I'll change the thermistor and go from there...
Sorry, only registered users may post in this forum.

Click here to login