Welcome! Log In Create A New Profile

Advanced

Folger Tech 2020 i3 Printer Kit (Official Thread)

Posted by Dan_FolgerTech 
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 01, 2015 07:12PM
Hey guys, just finished the mech+electrical build, about to start the config guide and really need any help I can get.

Any tips on any configuration settings?
What should I watch out for?
Any specific settings I should set?
Safety Tips?
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 01, 2015 07:22PM
X-Carriage Update:

Since my Proximity Sensor decided to take a dump, I in turn decided to start the X-Carriage install. I can honestly say, this install went in much easier and with far less "ut oh" moments. So far everything has fit well, although I have found many alignment issues with my old Z-Axis setup. I think I have corrected them all and will complete the assembly once I receive my new Lead Screw Nuts and new Sensor.

Here are a couple photo, and here's a link to the X-Carriage album







I decided to go out on a limb and do a magnetic Hotend mount (remix of this ONE), I really like this mount, it will allow easy maintenance and switching of the Hotends (I have a E3D Light-6 and E3D Cyclops), and it will also allow for a future upgrade I have planned ;-)





Sonny

Edited 1 time(s). Last edit at 12/01/2015 07:47PM by sonnylowe.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 01, 2015 09:01PM
Quote
watlooazn
Hey guys, just finished the mech+electrical build, about to start the config guide and really need any help I can get.

Any tips on any configuration settings?
What should I watch out for?
Any specific settings I should set?
Safety Tips?
Yeah, here's an important tip: don't adjust your end stops while your ramps board is powered! Two weeks ago I did just that. My Allen wrench slipped and I shorted 5v to ground. It blew the voltage regulator on my arduino.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 01, 2015 09:38PM
Quote
watlooazn
Hey guys, just finished the mech+electrical build, about to start the config guide and really need any help I can get.

Any tips on any configuration settings?
What should I watch out for?
Any specific settings I should set?
Safety Tips?

1. Make sure everything polarity sensitive is not backwards before you plug the machine in (stepper drivers, endstops, power supply to ramps wires)
2. If you are going to measure your stepper driver voltages, use the driver's potentiometer as a positive connection, and one of the ground connections on the ramps' terminal block that goes to the power supply as your ground connection. This will help prevent you from shorting your stepper drivers, which is a common mishap that happens way to easily. Also be careful not to let the positive lead slip.
3. This is probably not a suggested way to fine tune your steppers, but I just adjusted my X, Y and Z stepper drivers to where the stepper motor did not make to much noise, and the motor was moving freely. My extruder motor was adjusted the same way, but with some tweeking until the printer was printing and not skipping steps.
4. Avoid slic3r, use cura smiling smiley
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 01, 2015 09:45PM
Quote
sonnylowe
X-Carriage Update:

Since my Proximity Sensor decided to take a dump, I in turn decided to start the X-Carriage install. I can honestly say, this install went in much easier and with far less "ut oh" moments. So far everything has fit well, although I have found many alignment issues with my old Z-Axis setup. I think I have corrected them all and will complete the assembly once I receive my new Lead Screw Nuts and new Sensor.

Here are a couple photo, and here's a link to the X-Carriage album







I decided to go out on a limb and do a magnetic Hotend mount (remix of this ONE), I really like this mount, it will allow easy maintenance and switching of the Hotends (I have a E3D Light-6 and E3D Cyclops), and it will also allow for a future upgrade I have planned ;-)





Sonny

I was thinking about doing something very similar with changing the x axis over to use extruded aluminum instead of rods, but decided against it because I did not see issues with the stock setup. Though looking at how sweet your printer looks with both the x and y axis mods, I might just change my mind.... winking smiley
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 02, 2015 06:17AM
Quote
Mach
Quote
sonnylowe
X-Carriage Update:

Since my Proximity Sensor decided to take a dump, I in turn decided to start the X-Carriage install. I can honestly say, this install went in much easier and with far less "ut oh" moments. So far everything has fit well, although I have found many alignment issues with my old Z-Axis setup. I think I have corrected them all and will complete the assembly once I receive my new Lead Screw Nuts and new Sensor.

Here are a couple photo, and here's a link to the X-Carriage album







I decided to go out on a limb and do a magnetic Hotend mount (remix of this ONE), I really like this mount, it will allow easy maintenance and switching of the Hotends (I have a E3D Light-6 and E3D Cyclops), and it will also allow for a future upgrade I have planned ;-)





Sonny

I was thinking about doing something very similar with changing the x axis over to use extruded aluminum instead of rods, but decided against it because I did not see issues with the stock setup. Though looking at how sweet your printer looks with both the x and y axis mods, I might just change my mind.... winking smiley

Thanks, I really like the setup so far, I haven't run the actual X-Axis yet (I'm waiting on parts), but hope to by the end of the week.

The bad thing about upgrades are that they fix the weak links, then expose more. I did Y, then X wasn't good enough, I'm now working on X and realize that Z will need work as well.

Good thing I love to tinker ;-)
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 02, 2015 08:27AM
I will try it tonight. Thank you!

I assume I go through the same loading process and choose the Marlin.ino that is in the Marlin Folder....
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 02, 2015 09:58AM
Quote
Mach

. My extruder motor was adjusted the same way, but with some tweeking until the printer was printing and not skipping steps.

Probably a silly question, Mach, but how can you tell if your printer is skipping steps?
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 02, 2015 10:14AM
Holy Cow. This thread is now 85 pages long. Perhaps it's time to make it into a wiki or an email list? I'm trying to keep up as I build my FolgerTech, but this is really unwieldy.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 02, 2015 10:32AM
Quote
lemgandi
Holy Cow. This thread is now 85 pages long. Perhaps it's time to make it into a wiki or an email list? I'm trying to keep up as I build my FolgerTech, but this is really unwieldy.

Agreed! Or Maybe it's own sub-forum. With stickies?
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 02, 2015 10:40AM
Quote
tjnamtiw
Quote
Mach

. My extruder motor was adjusted the same way, but with some tweeking until the printer was printing and not skipping steps.

Probably a silly question, Mach, but how can you tell if your printer is skipping steps?

You can hear the motor make a knock sound when it skips as it tries to move. If it happens to the X or Y axis during printing, you will see the print become inconsistent due to the printer not knowing that the motor has skipped a step, so it continues business as usual. If it happens often on the extruder, you will notice gaps in the filament layer where the filament did not get layed down properly. Here is a pretty good video by Tom on stepper motors
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 02, 2015 12:17PM
Quote
lemgandi
Holy Cow. This thread is now 85 pages long. Perhaps it's time to make it into a wiki or an email list? I'm trying to keep up as I build my FolgerTech, but this is really unwieldy.

Someone (sorry can't remember who) created this CUSTOM SEARCH for the thread...works really well.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 02, 2015 12:20PM
I finally printed something in Ninjaflex using my new extruder last night (a GoPro holder I designed for my quadcopter), very happy with the results:





Need help? Visit the Folgertech Wikia Page

The latest Marlin firmware with Folgertech Prusa i3 settings merged in, get it here

And check out my designs on Thingiverse, and follow me if you like what you see!
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 02, 2015 12:51PM
Try this Search.....The FT2020 i3 Forum Only Search Engine

Edited 1 time(s). Last edit at 12/02/2015 12:52PM by bruceleroy.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 02, 2015 11:10PM
Just got around to printing a separate fan holder so I can have a print fan separate of the extruder fan and now I need to know how to make it work. I want it controllable by the ramps board so I can turn it off when printing ABS. Do I wire it above the heater block on the ramps board? I think that is where it is on my buddies folger tech i3. If that is where it goes do I have to change anything in the firmware to make it work?
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 03, 2015 01:04AM
Quote
therippa
I finally printed something in Ninjaflex using my new extruder last night (a GoPro holder I designed for my quadcopter), very happy with the results:



Nice work!!
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 03, 2015 07:15PM
Help!!!

I ordered a new Proximity Sensor, I got the orange one because I read it did not have to be modified like the blue one. However, when I measured the output voltage while triggered I got 12VDC instead of the recommended 5VDC. I did the Tom's modification (two resistors - 10K/15K, just like my old blue one) but the output voltage remained at 12VDC...WTF!?!?

I checked and rechecked the wiring and it seems fine...not sure why the resistors are not dropping the voltage??
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 03, 2015 07:18PM
Quote
sonnylowe
Help!!!

I ordered a new Proximity Sensor, I got the orange one because I read it did not have to be modified like the blue one. However, when I measured the output voltage while triggered I got 12VDC instead of the recommended 5VDC. I did the Tom's modification (two resistors - 10K/15K, just like my old blue one) but the output voltage remained at 12VDC...WTF!?!?

I checked and rechecked the wiring and it seems fine...not sure why the resistors are not dropping the voltage??

well not dropping the voltage after a voltage divider is strange. can you take a picture? also is your signal coming from the black wire?
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 03, 2015 08:17PM
Quote
Uncertainty
Quote
sonnylowe
Help!!!

I ordered a new Proximity Sensor, I got the orange one because I read it did not have to be modified like the blue one. However, when I measured the output voltage while triggered I got 12VDC instead of the recommended 5VDC. I did the Tom's modification (two resistors - 10K/15K, just like my old blue one) but the output voltage remained at 12VDC...WTF!?!?

I checked and rechecked the wiring and it seems fine...not sure why the resistors are not dropping the voltage??

well not dropping the voltage after a voltage divider is strange. can you take a picture? also is your signal coming from the black wire?

As far as I can tell, the signal is coming from the black wire!?!?

Sensor diagram:



Actual wiring:



Thanks for the help...
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 03, 2015 08:26PM
Quote
sonnylowe
Quote
Uncertainty
Quote
sonnylowe
Help!!!

I ordered a new Proximity Sensor, I got the orange one because I read it did not have to be modified like the blue one. However, when I measured the output voltage while triggered I got 12VDC instead of the recommended 5VDC. I did the Tom's modification (two resistors - 10K/15K, just like my old blue one) but the output voltage remained at 12VDC...WTF!?!?

I checked and rechecked the wiring and it seems fine...not sure why the resistors are not dropping the voltage??

well not dropping the voltage after a voltage divider is strange. can you take a picture? also is your signal coming from the black wire?

As far as I can tell, the signal is coming from the black wire!?!?

Sensor diagram:



Actual wiring:



Thanks for the help...

AHA! You're voltage divider isn't dividing the voltage!
Your 15k resistor needs to come before the junction.

You have (0 is the junction with the 10k going to the blue (gnd)):
Black -----0---/\/\/\/\-----

You want:
Black -/\/\/\/\-0--------

**just connect the 10k resistor to the other side of the 15k.

(sorry for all the edits, the formating kept messing my "circuits")

Edited 3 time(s). Last edit at 12/03/2015 08:40PM by Uncertainty.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 03, 2015 09:03PM
Quote
Uncertainty
Quote
sonnylowe
Quote
Uncertainty
Quote
sonnylowe
Help!!!

I ordered a new Proximity Sensor, I got the orange one because I read it did not have to be modified like the blue one. However, when I measured the output voltage while triggered I got 12VDC instead of the recommended 5VDC. I did the Tom's modification (two resistors - 10K/15K, just like my old blue one) but the output voltage remained at 12VDC...WTF!?!?

I checked and rechecked the wiring and it seems fine...not sure why the resistors are not dropping the voltage??

well not dropping the voltage after a voltage divider is strange. can you take a picture? also is your signal coming from the black wire?

As far as I can tell, the signal is coming from the black wire!?!?

Sensor diagram:



Actual wiring:



Thanks for the help...

AHA! You're voltage divider isn't dividing the voltage!
Your 15k resistor needs to come before the junction.

You have (0 is the junction with the 10k going to the blue (gnd)):
Black -----0---/\/\/\/\-----

You want:
Black -/\/\/\/\-0--------

**just connect the 10k resistor to the other side of the 15k.

(sorry for all the edits, the formating kept messing my "circuits")

Perfect, I just changed the wiring and now I'm getting 7.4VDC, hopefully that's low enough to work properly...

Thanks so much for the help!!!
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 03, 2015 09:06PM
Quote
sonnylowe

Perfect, I just changed the wiring and now I'm getting 7.4VDC, hopefully that's low enough to work properly...

Thanks so much for the help!!!

You're welcome, I'm glad that was it.
Having 7.4volts leads me to believe that your 10k and 15k are swapped, from your original picture they looked fine.
Double check that your 10k is the one connecting the blue and black. Use your multimeter if need be.

12volts * 15 / (10+15) = 7.2v ... so that would make sense.

Edited 1 time(s). Last edit at 12/03/2015 09:10PM by Uncertainty.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 03, 2015 09:14PM
Having homing issues...

When I run G28 the X gantry moves to X/Y0, then to X/Y100 (center of the bed) but instead of Z-ing down, Z goes up!?!?

This came out of nowhere, no changes to firmware, no hardware changes, just happened when I tried to run a print.

I rebooted the printer, rebooted the Raspberry Pie, and reinstalled the firmware, no luck.

Ran it from Repetier, from Octoprint, from the LCD controller, still no luck!!

I thought it might be a faulty Proximity Sensor (PS) so I replaced it...still have the same issue!!!

If I remove the PS and install the Z endstop it homes fine...

Any ideas!?!?
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 03, 2015 09:18PM
deleted

Edited 1 time(s). Last edit at 12/03/2015 09:24PM by therippa.

Need help? Visit the Folgertech Wikia Page

The latest Marlin firmware with Folgertech Prusa i3 settings merged in, get it here

And check out my designs on Thingiverse, and follow me if you like what you see!
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 03, 2015 09:19PM
Quote
Uncertainty
Quote
sonnylowe

Perfect, I just changed the wiring and now I'm getting 7.4VDC, hopefully that's low enough to work properly...

Thanks so much for the help!!!

You're welcome, I'm glad that was it.
Having 7.4volts leads me to believe that your 10k and 15k are swapped, from your original picture they looked fine.
Double check that your 10k is the one connecting the blue and black. Use your multimeter if need be.

12volts * 15 / (10+15) = 7.2v ... so that would make sense.

Okay, I'll check that tomorrow, it's way too late to deal with this tonight...thanks again!!
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 03, 2015 09:21PM
What's the Z-raise before homing in the conf file set at?
Good luck.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 04, 2015 01:20AM
Quote
Uncertainty
What's the Z-raise before homing in the conf file set at?
Good luck.

I can't find that in my config-h file!?!?

I did find these settings that are related to "home", but they all seem correct...

// ENDSTOP SETTINGS:
// Sets direction of endstops when homing; 1=MAX, -1=MIN
#define X_HOME_DIR -1
#define Y_HOME_DIR -1
#define Z_HOME_DIR -1


//Manual homing switch locations:
// For deltabots this means top and center of the Cartesian print volume.
#define MANUAL_X_HOME_POS 0
#define MANUAL_Y_HOME_POS 0
#define MANUAL_Z_HOME_POS 0
//#define MANUAL_Z_HOME_POS 402 // For delta: Distance between nozzle and print surface after homing.
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 04, 2015 03:49AM
Quote
sonnylowe
Quote
Uncertainty
Quote
sonnylowe

Perfect, I just changed the wiring and now I'm getting 7.4VDC, hopefully that's low enough to work properly...

Thanks so much for the help!!!

You're welcome, I'm glad that was it.
Having 7.4volts leads me to believe that your 10k and 15k are swapped, from your original picture they looked fine.
Double check that your 10k is the one connecting the blue and black. Use your multimeter if need be.

12volts * 15 / (10+15) = 7.2v ... so that would make sense.

Okay, I'll check that tomorrow, it's way too late to deal with this tonight...thanks again!!

I corrected the wiring and now I get ~5VDC...Thanks again!!!
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 04, 2015 10:28AM
Quote
Uncertainty
What's the Z-raise before homing in the conf file set at?
Good luck.

okay, I was looking through config-h again and I found this. It is and has always been set at the following:

#define Z_RAISE_BEFORE_HOMING 1 // (in mm) Raise Z before homing (G28) for Probe Clearance.
// Be sure you have this distance over your Z_MAX_POS in case

#define XY_TRAVEL_SPEED 8000 // X and Y axis travel speed between probes, in mm/min

#define Z_RAISE_BEFORE_PROBING 1 //How much the extruder will be raised before traveling to the first probing point.
#define Z_RAISE_BETWEEN_PROBINGS 1 //How much the extruder will be raised when traveling from between next probing points

I don't believe this is the issue as the homing process starts with no problem, it's not until the Z0 step that things go wrong...
Re: Folger Tech 2020 i3 Printer Kit (Official Thread)
December 04, 2015 10:47AM
You may be inverting your z axis or you may have forgotten to disable your max endstops. Can you upload your conf?
Sorry, only registered users may post in this forum.

Click here to login