Welcome! Log In Create A New Profile

Advanced

No negative z-axis using console

Posted by OttoChri3k 
No negative z-axis using console
August 09, 2015 08:42PM
I recently finished building a Folgertech Kossel Delta 3D printer (http://folgertech.com/products/folger-tech-kossel-2020-full-3d-printer-kit), and am on to the setup phase. Following the instructions, I used the pronterface console command: G1 X50 F4000. This was supposed to lower the extruder nozzle to where it thought 50 mm above the bed is. The nozzle being far too high, I tried to steadily lower the X value in the command until the extruder was just touching the bed, as per the instructions (negative values were supposedly ok). However, I ran into a problem: the nozzle would not descend past where pronterface thought that X0 was, even with a negative X value. This is a massive hindrance to configuration. Does anybody know how to make the nozzle X value negative? Thanks!

TLgrinning smileyR:
The console command G1 XA F4000 will not lower past A=0. Does anyone know how to make A a negative number?
Re: No negative z-axis using console
August 18, 2015 09:05PM
I'm building the Kossel 2020 too. I was also stumped by the "can't get it past Z0 even with negative numbers". I guess Pronterface doesn't like negative numbers. I realized that the firmware has 253.9 as the default value (line 346). I just changed it to 265, saved and uploaded. Now I don't have to use negative numbers to calibrate.
Re: No negative z-axis using console
August 28, 2015 04:48AM
Settings -> options and untick "clamp manual moves".

Also if your printer thinks it's at 0 already then the firmware itself might not let you move in negative values.
Sorry, only registered users may post in this forum.

Click here to login