Welcome! Log In Create A New Profile

Advanced

The screen is off when the limit switch is pressed

Posted by Rasyoni 
The screen is off when the limit switch is pressed
July 03, 2017 08:33AM
I asembled a new rep rap prusa i3 i wired it perfectly.
Managed to download the marlin firmware from the git hub "Marlin_Prusai3_reprap_pt" and successfully install it to the printer.
Now the problem happens:
when i go to 'auto home' in the control the z axis moves and presses the limit switch and it's off.
Second the x axis seems struggling to rotate and makes a sound but i checked the belt its fine when i do manually move 100mm it moves w/o any sound.
So i use repeater host to print a test and the printer moves the z axis and its off.

Please i need help on this i didn't know whether its a firmware or a hardware.
Re: The screen is off when the limit switch is pressed
July 03, 2017 08:55AM
If you are saying that the LCD display goes blank/dark when the limit switch is pressed, you've wired the limit switch to short the 5V supply to ground. That's not right!


Son of MegaMax 3D printer: [www.instructables.com]
Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Re: The screen is off when the limit switch is pressed
July 04, 2017 02:04AM
I tried to wire it on the opposite side but the thing is still switch off the display.
I even replace the switch still the same.
what else could be the problem. If its from the firmware is there any settings to check. I have a RepRap Prusa i3 Rework.

Edited 1 time(s). Last edit at 07/04/2017 02:23AM by Rasyoni.
Re: The screen is off when the limit switch is pressed
July 04, 2017 02:07AM
The other end of the switch at the controller end is wrong

The 2 pins should be across Signal and GND, not +5v and GND
Re: The screen is off when the limit switch is pressed
July 04, 2017 02:36AM
Thanks I noticed that i wire it wrongly on the board now it works fine.thumbs up
z axis motors rotate opposite
July 05, 2017 03:26PM
After assembling my new prusa reprap printer with your help guys i still couldnt figur out some problems፡
well when i select auto home or jog the z axis motors rotate individually to the opposite direction and my x axis it making loud noice and vibrating i check the belt no change. Finally my z axis motor is heated up fast is that normal while the others dont heat.
Is it the firmware configuration b/c i download it from this site modified for prusa and i follow the instruction document.
Thanks all for usual quick help
Re: z axis motors rotate opposite
July 05, 2017 04:10PM
sounds like you haven't set you vref on the stepper drivers at all

If its to high stepper drivers and steppers can over heat

re Z axis, you could have one of the motors plugged into the controller backwards. or its the vref...

The vref is either a hardware variable resistor on the driver modules eg controller boards like ramps, or its a gcode software setting.

Edited 1 time(s). Last edit at 07/05/2017 04:11PM by Dust.
Re: z axis motors rotate opposite
July 07, 2017 04:13AM
Thanks all Now it seems rotating well. But my other problem is that how to print:
I adjust the leveling measuring both z-axis the height equal
I also adjust the bed equally
But when i tell it to Auto home the axis move in different angle and move beyond the limit so it jumps the gears and belts.
Is there a way or a simple guideline for manual prusa i3 reprap to configure it and adjust the leveling .
I have used pronterface to adjust the axis but nothing even when i tell it Auto home all axis the z axis goes up to the top y axis goes all the way back x axis is grinding and pauses in the middle .
As Always Thanks
Re: z axis motors rotate opposite
July 07, 2017 07:25AM
see [www.youtube.com]

You need to tell your firmware where your endstops are and which direction to move is the correct direction

If you have firmware provided by a supplier that should match your machine. Then you have the stepper plugs in backwards on the controller.


eg you say it homes up on Z, so (while everything is off!) pull out the Z stepper plugs on motherboard, turn them around 180 degrees (presuming they don’t have any keys to stop this) and plug them back in again. This will make the stepper motors move in the opposite direction. So now the will home downwards.

BUT before you start pounding that home button, you really need to test that your endstops are working. Or your going to drive your hot end threw the headed bed followed shortly there after by throwing the printer into a wall.

Connect your printer to a computer
start up pronterface
hit the connect button
when it says printer on line send it the command M119
It will reply with the current status of the endstops

Move all axis away from the endstops so none are triggered
Send the printer a M119, it should tell you all endstops are open
Manually hold down the X axis endstop with a finger, (if optical, put a it of cardboard in the detector) Send another M119, now the X axis should now say triggered
no do this with the Y axis endstop and then the Z axis endstop. (if Z is a probe, you may need to hold a bit of metal under it to trigger it, depends on what type of probe it is)

Only when all of these work as expected should you go anywhere near the home buttons

Edited 2 time(s). Last edit at 07/07/2017 07:41AM by Dust.
Re: z axis motors rotate opposite
July 09, 2017 10:59PM
Thanks Dust;
I have reverse the plug from the board and now it goes down but it wont stop even it touches the limit switch.
I also send an M119 command and it works well i check for each switch and it works but the z axis when i home it it wants to go down crushing down the motherboard and ignores the limit switch.
Any idea?
Thanks a lot .
Re: z axis motors rotate opposite
July 10, 2017 01:09AM
what exactly does M119 say

ie does it say Z Min or Z max triggered when you hold the Z switch down?

It is should say Z min on a I3 type machine

Also what firmware are you running, is there a configuration.h you can show us?

Edited 1 time(s). Last edit at 07/10/2017 01:49AM by Dust.
Re: z axis motors rotate opposite
July 10, 2017 07:12AM
I have attached the configuration file.
It says "Zmax triggered"
Attachments:
open | download - Configuration.h (30.8 KB)
Re: z axis motors rotate opposite
July 10, 2017 05:39PM
ok thats not right... It should be Zmin

Move the Z endstop on the controller board to the Z min endstop (Ie one pin towards the power supply end)
re test with M119.

Edited 1 time(s). Last edit at 07/10/2017 05:40PM by Dust.
Re: z axis motors rotate opposite
July 11, 2017 10:06PM
Thanks Dust!
Yup now it stops the z axis but my happiness ends very shortly.
Again another problem occurred I adjust the leveling and finally try to print a cube.
So I use pronterface to print :
All the sudden the heat bed light blinks and the lcd screen flickers like its short with power and all the display txts gone and it gives me an "Err:MINTEMP' in the pronterface.
I tried to reset it by pushing the button on the board nothing displays
I reupload the firmware nothing changes but the display works well with the USB port connected only not power on.
I attached the pictures for reference .
Thanks for understanding.
Attachments:
open | download - IMG_20170711_194540.jpg (41.2 KB)
open | download - IMG_20170711_200236.jpg (211.7 KB)
open | download - IMG_20170711_195131.jpg (31.6 KB)
open | download - IMG_20170711_200248.jpg (40.9 KB)
Re: z axis motors rotate opposite
July 11, 2017 10:51PM
Sounds like your thermistor on the hotend has died.
Could be a broken cable, most likely at the thermistor end (as its quite delicate)

Do you have a multimeter? Can you use it to check resistance? (I have no idea of your level of electronics knowledge)

Remove the hot end thermistor plug from the controller (while everything is off) and measure the resistance at the cable plug. Ie threw the cable and threw the thermistor, it should read 100k at about 25c (it changes depends on temperature)

"but the display works well with the USB port connected only not power on."
That is a bigger concern... that sounds like a dead voltage regulator...

You have never mentioned what controller you have, its it a RAMPS?
ie one of these?

Re: z axis motors rotate opposite
July 12, 2017 02:16AM
I don't know about electricity that much.
I tried my best: So I turn on the meter and set it to 200k and i get the measurement of 135.4 when I connect the measurement at the 2 ends of the thermistor, Hope am correct.
Other than that yes i have the exact board.
Re: The screen is off when the limit switch is pressed
July 12, 2017 06:20PM
It sounds like the thermistor is fine

"but the display works well with the USB port connected only not power on."
But you have destroyed the voltage regulator on the mega (this is very common for anyone that plugs in and end stop in backwards)

Your going to need a new mega2560 (the bottom board under the ramps)
Search for "MEGA 2560 R3" on your favourite shopping site ebay.com, aliexpress.com, dx.com, banggood.com etc

You just need a board, none of the extra things they tack on.

Edited 1 time(s). Last edit at 07/12/2017 06:23PM by Dust.
Re: z axis motors rotate opposite
July 12, 2017 11:15PM
Thanks Dust! will order but if I keep the same settings will it destroy the second one, Just asking if i need to change some thing.
Ok in the mean time I have a new tronxy and the board was toasted before i assemble it but now i get yesterday a new board but it comes with different firmware.
My previous one is Marlin V1.1 now the one i brought is P802M_8_V1.7.
Problem:
When i set x to home it rotates ignoring the endstop.
when i home z it goes to the corner where it misses the bed and the proximity sensor wants to go down beyond the bed.
Any idea pls!
Thanks
Re: z axis motors rotate opposite
July 13, 2017 12:05AM
same firmware.. same settings

It died due to being over stressed when you plugged in the endstops backwards (well that my opinion)

I would start a new thread for the tronxy, or it going to get really confusing when you do get the new mega.

Edited 1 time(s). Last edit at 07/13/2017 12:06AM by Dust.
Re: z axis motors rotate opposite
July 13, 2017 12:36AM
Gat u. But in the mean time help me out with the tronxy. Till i get the board needed. Waiting your response. Thanks a lot
Re: z axis motors rotate opposite
July 13, 2017 01:01AM
M119 is still your Friend... test out the endstop on the x axis

Endstop seem to be on the left, so it should say X_min triggered when the switch is held down.
Re: z axis motors rotate opposite
July 13, 2017 06:21AM
Gat U but my pronterface is not working because of the USB cable driver is not working and i tried FTDrivers but it cant connect it.
I use windows 10. Also there is one PIn for x limit.
Re: z axis motors rotate opposite
July 13, 2017 03:00PM
Looks like (from the images google shows me) that the tronxy melzi uses a ch340 usb serial converter

Try this driver [sparks.gogo.co.nz]
Sorry, only registered users may post in this forum.

Click here to login