Welcome! Log In Create A New Profile

Advanced

Non trovo una soluzione , Temperatura hot end instabile

Posted by claustro 
Non trovo una soluzione , Temperatura hot end instabile
September 17, 2017 04:05PM
Sto letteralmente impazzendo con un problema.
La temperatura dell'hotend è totalmente instabile, raggiungendo valori ( per lo meno indicati ) di 250 e quindi l'arresto della stampa . In un caso la temperatura ha raggiunto valori elevatissimi nonostante fosse indicato 240 .
Ho ricablato tutta la stampante sostituendo i cavi del termistore , sostituito termistore e hotend, sostituito tutta l'elettronica ramp e arduino , sostituito e aggiornato il firmware , effettuato pid tuning com se non ci fosse un domani.
tutto senza successo , anzi dopo la sostituzione dell'elettronica il problema è se mai piu' evidente


Un cosa che non capisco ricaricando il firmware con dei valori specifici di pid se poi gli richiamo , una volta caricati con
faccio il pid tune con M503 , sono sempre gli stessi che avevo ottenuto precedentemente , in pratica non sembra che il "firmware sovrascriva " i valori
Ad esempio da m503 ottengo

READ: Configtongue sticking out smileyID settings:
READ: Config:  M301 H0 P20.22 I2.76 D36.97



quando invece nel configuration .overall.h del firmware appena caricato c'è scritto

#define DEFAULT_Kp {39.78,40,40,40}
#define DEFAULT_Ki {7.08,7,7,7}
#define DEFAULT_Kd {55.88,60,60,60}
#define DEFAULT_Kc {100,100,100,100}


Il pid tuning l'ho fatto con il comando

M303 S200 C6 U1


salvando poi con M500 ( la scrittura eeprom è abilitata)

Impostando manualmente i PID con M301 vengono memorizzati.

Ecco non so più davvero dove andare a sbattere la testa.

Edited 4 time(s). Last edit at 09/18/2017 02:11AM by claustro.
Attachments:
open | download - Configuration_Overall.h (39.7 KB)
Re: Non trovo una soluzione , Temperatura hot end instabile
September 17, 2017 11:37PM
Ma è normale se usi la eeprom i valori usati sono sempre quelli in eeprom. Se vuoi usare quelli nel firmware (TUTTI), devi ricaricare i valori di default con il comando M502, a questo punto hai i valori scritti nel firmware che poi puoi memorizzare con M500.
Ora a parte questo dopo aver fatto il pid hai instabilità nella temperatura?? Che versione hai?


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Prusa I3 Rework R2 (By NicolaP) & Kossel K2
My Blog - My Thingiverse
Re: Non trovo una soluzione , Temperatura hot end instabile
September 18, 2017 02:19AM
Ok in tanto ho capito una cosa nuova ,io credevo che i valori del firmware venissero caricati in eeprom sempre . e fosse solo un opzione il poterli modificarli e salvarli , invece se ho letto bene l' uso della eeprom é una opzione facoltativa di memorizzazione delle impostazioni che bypassano quelle impostate nel firmware stesso.

Riguardo al mio problema me lo porto dietro da diverso tempo , ecco il motivo di tutte le sostituzioni , quinidi lo avevo sia con il 4.1.2 rev1 ufficiale EVO che con l' ultimo caricato 4.3.2

Ieri sera, dopo aver scritto il messaggio , ho fatto un ' altra prova, sostituendo il gruppo hotend con un terzo appena assemblato e pare andasse bene. La speranza e' che il problema risieda nel termistore e ne abbia provati due danneggiati.
Altrimenti lúnica cosa mai sostituita sono i due alimentatori ma potrebbero entrarci qualcosa?

Edited 1 time(s). Last edit at 09/18/2017 02:21AM by claustro.
Re: Non trovo una soluzione , Temperatura hot end instabile
October 11, 2017 02:35AM
Ciao, il termistore l'hai provato col tester?
di solito sono da 100KOhm, così vedi subito se funziona, basta scaldarlo un po ed il valore in ohm dovrebbe subito cambiare.
Potrebbe anche essere il cavo del termistore che capta interferenze, l'alimentatore switching ne genera
molte, prova a spostare i fili del sensore dagli altri e twistarli (intrecciarli tra loro).


Prusa I3 R2 di Nicola P - Arduino Mega2560 - Ramps 1.4 - Estrusore 1.75mm - nozzle 0.35 - Display 128x64
Sorry, only registered users may post in this forum.

Click here to login