Welcome! Log In Create A New Profile

Advanced

Can not calibrate Ormerod

Posted by Daanc 
Can not calibrate Ormerod
May 16, 2017 04:43AM
Dear Reprap experts,

I have some problems calibrating my ormerod. I did all the steps as in the manual. i let the head down till its almost on the plate and i save the Z value. I do this for all points and at the end i put all these files in Setbed.g.
Before i start printing i load the setbed file like its a normal print. Then i want to print the Snowman, the printer goes to all 4 points but the hight is not the same as the one i saved. Then when he starts printing, there is almost no fillament coming out of the nozzle. I calibrated the feed of the extruder. but still there is no PLA coming from the head.

Settings for Setbed:

G30 P0 X60 Y20 Z0.5

G30 P1 X60 Y180 Z-0.3

G30 P2 X180 Y180 Z1.2

G30 P3 X180 Y20 Z1.0 S

Thanks in advance!

Greetings

Daan
Re: Can not calibrate Ormerod
May 16, 2017 08:36AM
You have 2 separate issues, one with the Z zero height, and the other with the extruder.

Does the extruder motor turn when you are trying to print? If not, does it seem to be stalled (vibrates or jerks)? Are you using the latest firmware and web interface, or something else?

Dave
Re: Can not calibrate Ormerod
May 16, 2017 10:37AM
Hello dave thanks for your response! When i command my device to extrude the wheel extrudes like it should. But when i start a print i see the extruder turning the right way and then back and so on. So it feeds and then takes it back.
I installed the latest filmware for my device and i use the web interface. What methode of calibration for the bed is best for my device?
Re: Can not calibrate Ormerod
May 17, 2017 04:15AM
It sounds like you have the Duet set up for absolute extrusion but the G-code is sending relative extruder commands. This is strange because the "snowman" G-code that was originally included by RRP definitely has the correct command to switch to relative extrusion (M83)

I have attached the original snowman G-code to this post. If you are slicing your own G-code, ensure that you have the "M83" command in the start code, and that the slicer is set up to produce relative extruder moves. You can examine the G-code with any text editor to see the commands sent at the start of the file. As you have homing issues, I commented out the homing command in the G-code attached, as it would cause you problems. Instead, home the X & Y axis, then set the Z zero height by hand before printing instead of homing the Z axis automatically. Don't worry about setting up bed compensation - just ensure the Z zero was set at the centre of the bed, the snowman is small enough that there should not be any great variation in bed height within its area (if there is, your bed is way out of adjustment and needs to be levelled mechanically).

I never put a homing command in the G-code file, I always home manually before the first print job (it only takes a few seconds and there is no need to home for subsequent jobs unless you power cycle or reset the printer).

Again, for more complete answers you will need to say specifically what firmware version you are using.

Dave

Edited 1 time(s). Last edit at 05/17/2017 04:17AM by dmould.
Attachments:
open | download - snowman.g (218.9 KB)
Re: Can not calibrate Ormerod
May 19, 2017 03:25AM
The problem is solved ! there was a piece of filament stuck in the tube and it blocked the extruder. I manually changed the bed hight and i made the 1ste print and it has pretty good quality!

Thanks for the support Dave!
Sorry, only registered users may post in this forum.

Click here to login