Welcome! Log In Create A New Profile

Advanced

Duet Stopped Working after update 1.14 > 1.17e

Posted by atheimer 
Duet Stopped Working after update 1.14 > 1.17e
March 07, 2017 02:47PM
My Duet version 0.6 -based I3 has been running great for years but I needed to change the E3D v6 nozzle this afternoon and have run into issues and now the Duet won't boot.

1. I tried to increase my hotend temp to 285 to change the nozzle, Duet 1.14 reported hotend error ... started reading and it lead me to try and upgrade the firmware as there have been
lots of improvements to the auto-tune etc..

2. I tried the Web-Based file upload, uploaded the dc42 fork firmware from here: [github.com]
3. The web-update seems to crash/hang/ or otherwise go unresponsive.
4. Reboot machine, PanelDue just sits at "Connecting" never fully boots.
5. I used Bossac to erase/update the firmware manually and that works just fine but the problem persists
6. I updated the /sys/ files on the SD card nothing
7. updated the www/ files on the SD card to latest from [github.com]

I've re-flashed the firmware several times without any luck so now the printers out of commission. I'm not quite sure what to try in the past it is typically a combination of having the right web files, the SD card files, and the firmware but as far as I can tell they are all updated to the latest.

I'd be grateful for anything else to check,

Thanks in advance.
Re: Duet Stopped Working after update 1.14 > 1.17e
March 08, 2017 01:18AM
It looks like I have had a similar problem with my Duet 0.6.
After I updated to Firmware 1.17e and web 1.14e, I would get heater-faults and the web-interface would not update. Otherwise the machine seemed to work fine.
I did the firmware update manually via bossard/USB, and put the SD-card in my computer for WEB-update, as I have always done.

After going back-and forth between various combinations of firmware and web-interface, I got my printer working with firmware 1.15e and WEB 1.14e.
Upgrading to firmware 1.16 or later will trigger the problem.
I found one old thread with a question, that sounded like this problem, but I don't think there was a conclusion.

Right now I'm using firmware 1.15e and WEB 1.14e, which has been running without problems for a couple of weeks now.

Best regards,

Carsten
Re: Duet Stopped Working after update 1.14 > 1.17e
March 08, 2017 04:41AM
I am running RRF 1.18alpha1 and DWC 1.14a on my Duet 0.6 + DueX4-powered Ormerod.

When upgrading firmware, see [github.com]. In particular, you are likely to see heater faults if you don't auto-tune the heaters.


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet [www.duet3d.com].
Re: Duet Stopped Working after update 1.14 > 1.17e
March 08, 2017 07:39AM
I have 1.17e running ok... updated configs etc....but the autotune of the hotend keeps failing.

I send: M303 H1 S260

The tune process starts but then I get:

Auto tune of heater 1 with P=0.50 S=260.0 cancelled because temperature limit exceeded. Use lower P or higher S in m303 command.

I tried sending M143 S280 thinking there is some hidden safety limit that I can't find but really have no clue what to try here. I am using the stock PID settings from the 1.17e release config files at the moment.

EDIT:
I've continued to read the forums both here and at Duet3D. Finally got it to complete but I get the "fire risk" warning. Not using anything fancy here, std E3D 12v from 3 years ago + the typical 12v chinese p/s.

M303 H1 P0.2 S240=
Heater 1 model: gain 829.8, time constant 190.2, dead time 3.4, max PWM 1.00, mode: PID
Setpoint change: P12.1, I0.063, D28.6
Load change: P12.1, I1.141, D28.6

I'll pump this into my config and see what happens...

Edited 1 time(s). Last edit at 03/08/2017 12:10PM by atheimer.
Re: Duet Stopped Working after update 1.14 > 1.17e
March 08, 2017 01:44PM
Your heater gain is high for an E3Dv6. Did you perhaps turn up the voltage on your 12V PSU?

Firmware 1.18beta1 has a new tuning algorithm that is easier to use.

Edited 1 time(s). Last edit at 03/08/2017 01:45PM by dc42.

Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet [www.duet3d.com].
Re: Duet Stopped Working after update 1.14 > 1.17e
March 09, 2017 06:06AM
For the numbers I have seen in the forums it appeared that way to me as well. It has been so long, I'm pretty sure I never touched that "dial" but that p/s is going on 5 years now and is the fan is quite loud these days so probably due for a check-up. I have never had any power issues on the printer so is it correct to set the PS to where it is outputting 12v and then tweak it up based on performance?

I looked at the release notes for 1.18 and it doesn't look too disruptive so I will upgrade to that this weekend and post the results.

Thanks,
Re: Duet Stopped Working after update 1.14 > 1.17e
March 09, 2017 07:51AM
It could just be that your hot end heater cartridge is more powerful than the average. I have 3 in all and there is quite a lot of variation in their resistance. One of mine measured 2.8 ohms, which is around 51W @ 12V.

People sometimes turn up the PSU voltage in order to get the bed to heat faster or to a higher temperature, that's why I asked.


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet [www.duet3d.com].
Re: Duet Stopped Working after update 1.14 > 1.17e
March 09, 2017 10:46PM
Just for information - this is my parameters for the E3D V6:

M301 H1 I0.5 P30 S1.2; E3D V6 extruder PID

They have been hand-tuned.

Any ideas why the web-interface seems to stop updating in 1.16 and 1.17?

Thank you.

Best regards,

Carsten
Re: Duet Stopped Working after update 1.14 > 1.17e
March 09, 2017 10:55PM
If the web interface stops updating, press control-shift-J to open the browser debugging console and see if there is an exception message.


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet [www.duet3d.com].
Re: Duet Stopped Working after update 1.14 > 1.17e
March 11, 2017 09:20AM
I updated to the 1.18beta firmware this morning and re-ran the autotune -this seems to be much less fussy than 1.17e. Here are the results:

Warning: Heater 1 appears to be over-powered and a fire risk! If left on at full power, its temperature is predicted to reach 982C.
Auto tune heater 1 completed in 275 sec
Use M307 H1 to see the result, or M500 to save the result in config-override.g

From Which:

M307 H1
Heater 1 model: gain 962.1, time constant 229.2, dead time 4.5, max PWM 1.00, mode: PID
Computed PID parameters for setpoint change: P9.4, I0.041, D29.8
Computed PID parameters for load change: P9.4, I0.689, D29.8

Which Gives me an configuration file entry of:

M307 H1 A962.1 C229.2 D4.5 B0


Any issues with that?

I added the above to the config file, commenting out the old 301 lines. Now I run

M143 H1 S285 # allow higher temp heatup... where is this value stored? Is it editable at the machine level?

G10 P0 S280

The heater heated to 280, stayed there long enough for me to remove the old nozzle and start to screw on the new one before causing a fault and shutting down. Now I cannot get back to 280, I get
Error: heating fault on heater 1, temperature rising much more slowly than the expected 2.2°C/sec

I'm not really sure what to do, try the manual PID setup? Is there something really wrong with my power chain?

Edited 1 time(s). Last edit at 03/11/2017 09:44AM by atheimer.
Re: Duet Stopped Working after update 1.14 > 1.17e
March 11, 2017 10:34AM
Have you changed something that has caused the gain to change, for example removing a silicone sock from the heater block?


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet [www.duet3d.com].
Re: Duet Stopped Working after update 1.14 > 1.17e
April 11, 2017 10:42AM
Quote
dc42
If the web interface stops updating, press control-shift-J to open the browser debugging console and see if there is an exception message.

I finally got the time to investigate my web-interface-freeze-problem.

It turns out, that I was missing a "macro" directory that caused an exception.
Thanks for your suggestion, DC42.

Firmware 1.18.1 is now running fine together with web 1.15 - except for some heater-faults as discussed previously in this thread....trying autotune.

Best regards,

Carsten
Re: Duet Stopped Working after update 1.14 > 1.17e
April 16, 2017 04:13AM
Quote
dc42
If the web interface stops updating, press control-shift-J to open the browser debugging console and see if there is an exception message.

This just happend to me, ctrl shift J gives this

Uncaught TypeError: Cannot read property 'sort' of undefined
at Object.success (dwc.js:2686)
at i (dwc.js:2)
at Object.fireWith [as resolveWith] (dwc.js:2)
at A (dwc.js:4)
at XMLHttpRequest. (dwc.js:4)

For the meantime, I went back to 1.08 web interface, It works normally.

Also the Y motor is loud, its never been so loud.

EDIT:
The web interface 1.15a works, but the chrome doesnt read the glyphicons (woff, woff2 and ttf). It seems they are wrongly named. I have changed glyphicons-halflings-regular to glyphicons for all three extensions and everything is ok.

Edited 2 time(s). Last edit at 04/16/2017 05:18AM by Sardi.
Re: Duet Stopped Working after update 1.14 > 1.17e
April 16, 2017 08:00AM
Quote
Sardi
The web interface 1.15a works, but the chrome doesn't read the glyphicons (woff, woff2 and ttf). It seems they are wrongly named. I have changed glyphicons-halflings-regular to glyphicons for all three extensions and everything is ok.

I don't have that problem, however the font files were renamed one or two versions ago. It may be that you have a mixture of old and new files on your system, which happens easily because the new files are mostly gzipped. I suggest you delete or rename your /www folder, create a new one, and extract the contents of the DWV 1.15 zip file to it.


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet [www.duet3d.com].
Re: Duet Stopped Working after update 1.14 > 1.17e
April 16, 2017 08:21AM
I have fixed that, renamed the files, now It works.

Any ideas on the loud Y motor? I mean, it is really loud, It wasnt before. Maybe the board has something to do with it?
Re: Duet Stopped Working after update 1.14 > 1.17e
April 16, 2017 09:53AM
I can't think of any reason why the Y motor would be loud. My Ormerod is (for the time being) running firmware 1.18.1 on a Duet 0.6 and it isn't especially loud. Could it be that you have changed the Y motor current in config.g?

If you suspect a driver issue, then with the power off swap the X and Y motor connections, also put M584 X1 Y0 in config.g to swap them in firmware (make sure this is before the M906 command). Then see whether it is still Y that is loud, or X.

Edited 1 time(s). Last edit at 04/16/2017 09:54AM by dc42.

Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet [www.duet3d.com].
Re: Duet Stopped Working after update 1.14 > 1.17e
April 20, 2017 02:16AM
Tested it all arround, the noise just stopped. have no idea what caused it tbh. But its all ok now.
Sorry, only registered users may post in this forum.

Click here to login