Welcome! Log In Create A New Profile

Advanced

Rendering error after difference function

Posted by Replace 
Rendering error after difference function
June 27, 2016 01:31PM
I am trying to difference 2 objects from each other.

The f5 will do ok, but the f6 will error:

Compiling design (CSG Tree generation)...
Rendering Polygon Mesh using CGAL...
ERROR: CGAL error in CGAL_Nef_polyhedron3(): CGAL ERROR: assertion violation! Expr: pe_prev->is_border() || !internal:tongue sticking out smileylane_constructor::get_plane(pe_prev->facet(),pe_prev->facet()->plane()).is_degenerate() File: /Users/kintel/code/OpenSCAD/openscad-2015.03/../libraries/install/include/CGAL/Nef_3/polyhedron_3_to_nef_3.h Line: 251
Geometries in cache: 12
Geometry cache size in bytes: 14020224
CGAL Polyhedrons in cache: 2
CGAL cache size in bytes: 95693744
Total rendering time: 0 hours, 0 minutes, 24 seconds
Top level object is a 3D object:
Simple: yes
Vertices: 19267
Halfedges: 113836
Edges: 56918
Halffacets: 75304
Facets: 37652
Volumes: 2
Rendering finished.



Than the first object will appear and the second object will not, also the diference has not been done.
any idea what might have hapened ?
Be advised that I have run both objects through NetFabb before.

advise appreciated
Thomas

Edited 1 time(s). Last edit at 06/27/2016 01:32PM by Replace.

www.3daybreaker.blogspot.com

Orca V4.4 rebuild to Ramps with Mk8 and E3D, as well as a Rostock Delta Mini and an OLO in backorder :-)
Re: Rendering error after difference function
June 28, 2016 01:52AM
Did you repair your object(s) in Netfabb before making the difference in Openscad?

If yes, Meshlab should be preferred for repairs as it shows errors that Netfabb doesn't. Process in Meshlab is a little long:

1- Show non Manif Edges & non Manif Vertices in Render menu
2- Select non Manif Edges and/or non Manif Vertices in Filters > Selection menu, then apply selection(s)
3- Button in tools bars: "Delete the current set of selected vertices [etc.]"
4- Button in tools bars: "Fill Holes", select holes ans fill it if needed
5- Export the new Mesh

Sometime, not very often, the process must be repeated, particulary for holes: re-opening the fixed STL in Meshlab searching for errors is always good.


François
Re: Rendering error after difference function
June 28, 2016 01:56AM
But why a pre-moderated forum? That makes things longer… If really needed it could be post-moderated.


François
Re: Rendering error after difference function
June 29, 2016 02:04PM
Quote
François Delègue
But why a pre-moderated forum? That makes things longer… If really needed it could be post-moderated.


I do not understand this comment. Please elaborate .

I will try to get a Mashlab, to act on your other tips.
Thnks Thoms


www.3daybreaker.blogspot.com

Orca V4.4 rebuild to Ramps with Mk8 and E3D, as well as a Rostock Delta Mini and an OLO in backorder :-)
Re: Rendering error after difference function
June 30, 2016 01:20AM
When I replied two days ago the forum system indicated that replies were moderated (approved, or not, before publication). It is not the case today, probably a temporary setting…

[Edit] Meshlab: my previous post repairing "howto" is
https://en.wikibooks.org/wiki/OpenSCAD_User_Manual/STL_Import_and_Export

Edited 1 time(s). Last edit at 06/30/2016 02:01AM by François Delègue.

François
Re: Rendering error after difference function
June 30, 2016 03:02AM
Quote
François Delègue
When I replied two days ago the forum system indicated that replies were moderated (approved, or not, before publication). It is not the case today, probably a temporary setting…

[Edit] Meshlab: my previous post repairing "howto" is
https://en.wikibooks.org/wiki/OpenSCAD_User_Manual/STL_Import_and_Export

A different forum that I posted to a couple of days ago also suddenly came up with the "awaiting moderation" message. I think an error in the settings must have been applied to the forums for a short period. It seems to be OK now.

Dave
Sorry, only registered users may post in this forum.

Click here to login