Welcome! Log In Create A New Profile

Advanced

PID Autotune failed! timeout

Posted by conG 
PID Autotune failed! timeout
January 28, 2016 08:38AM
Bonjour,

Je rencontre un petit soucis après le montage de ma foldarap 2.5.

Il semblerait après quelques tests qu'il me soit impossible d'atteindre la température souhaitée sur Pronterface lorsque j'effectue le PID tuning.
Ceci dis, une fois le ventilateur (qui est monté sur le radiateur, pas celui du fan cooling) débranché, la température se stabilise et je ne rencontre plus aucun soucis.

Comment régler ce problème ?
- Faire un PID tuning sans ventilateur (avec le risque que la chaleur remonte dans la cold-end ?!)
- Régler la puissance du ventilateur (possible sur une minitronics ?)

Bien à vous,
Guillaume Constant


Feel free to chat with me and the reprap community on IRC here : [webchat.freenode.net]
Guillaume,
Re: PID Autotune failed! timeout
January 29, 2016 06:20AM
Bonjour,

Je n'imagine pas que le ventilateur puisse être la vraie cause.
Il y a probablement un problème de chauffe ou de mesure de température.
Il faut passer toute la chaîne en revue méthodiquement et être créatif pour valider chaque étape.
C'est souvent plus simple que ce qu'on imagine winking smiley
Je chercherais d'abord du côté de la thermistance: défectueuse, mal montée (mauvais contact) ou mal configurée (mauvais profil dans Marlin) il a plein de pistes.

Est-ce que tu arrives à avoir une température au repos cohérente avec la température de la pièce dans laquelle se trouve l'imprimante ?
Avec un thermomètre domestique, et en réglant dans la tête à une température raisonnable pour ne pas l'exploser, est-ce que tu peux confirmer les relevés ?

Bon courage
TD
Re: PID Autotune failed! timeout
January 29, 2016 07:22AM
Hello,

Pour te répondre, ma cartouche chauffante et ma thermistance viennent de chez OpenEdge et ont été acheté neuf cette semaine, et j'ai pris le marlin déjà configuré distribué par Emmanuel sur GitHub.

- [openedge.cc]
- [openedge.cc]

Je viens de revérifier et le marlin est bien configuré pour ma thermistance.

Concernant ma carte, elle était opérationnelle avant rangement dans une armoire et ici je viens de la ressortir après un an pour mettre à jour ma foldarap en 2.5, et pour alim, j'utilise une alim atx de 15A en 12V (Emmanuel conseille 10A grand max avec un plateau chauffant). Par curiosité, j'ai testé plusieurs alims et il n'y a pas d'amélioration.

PS : Aucune valeur étrange au repos (20-25°C)


Feel free to chat with me and the reprap community on IRC here : [webchat.freenode.net]
Guillaume,
Re: PID Autotune failed! timeout
March 01, 2016 11:01PM
Bonjour,
As tu une erreur quand tu fais ton PID tunning ?
De mémoire pour faire le PID tunning sur ma Foldarap j'avais été obligé de limiter la puissance de chauffe de la cartouche pour que la callibration passe car la cartouche chauffe fort.
Dans le fichier de configuration j'ai baissé la valeur du BANG_MAX
#define BANG_MAX 255 // limits current to nozzle while in bang-bang mode; 255=full current

A+
Pascal
Sorry, only registered users may post in this forum.

Click here to login