Welcome! Log In Create A New Profile

Advanced

Le hotend monte très (trop ?) en température

Posted by gege2b 
Le hotend monte très (trop ?) en température
November 27, 2014 06:10AM
Bonjour à tous,

Folda #200, avec ma collègue nous avons presque terminé, mais on se trouve confronté à un soucis (qu'on suppose à l'origine du claquage de la cartouche chauffante d'origine, qui a été remplacée depuis)

Lorsqu'on règle la température de la hotend a, disons 180°, celle ci grimpe jusqu'a plus de 210 avant de redescendre et se stabiliser doucement. +20° d'overshoot c'est quand même pas mal...
Le problème c'est que du coup, il est impossible de faire un PID Tune... j'obtiens l'erreur "temperature too high"

Je précise que tout est d'origine (même la cartouche chauffante de remplacement, qui a été rachetée sur openedge)

Une idée?

Je pense modifier le firmware pour augmenter le PID_FUNCTIONAL_RANGE a 30 au lieu de 10, mais s'il y a une autre façon de faire je veux bien ^_^


Gege
[innocuousprototypes.gege2b.info]
Re: Le hotend monte très (trop ?) en température
November 30, 2014 02:57PM
Pour ma part une différence de +20 avant une stabilisation ce n'est pas rare mais si tu veux faire plus fin je crois que c 'est plus les variable : BANG_MAX et PID_MAX que vous devez modifier. Enfin à ce que j'ai cru comprendre mais cela demande confirmation.

Sinon vérifie - dans le cas ou l'eeprom est activée qu'au niveau de celle-ci se trouve les bonnes valeurs... parfois j'oublie le fonctionnement de marlin avec l'eeprom.

Al44
Re: Le hotend monte très (trop ?) en température
November 30, 2014 03:59PM
j'avoue que moi ça m'a etonné, car j'ai comme référence ma hotend (une budaschnozzle) sur laquelle je n'ai pas plus de 3 degrés d'overshoot pendant la montée en température (et +/- 1° en fonctionnement par la suite), mais il est vrai qu'elle utilise une bête résistance et pas une cartouche chauffante

C'est pour ça que j'ai tout de suite pensé à l'autotune PID, mais du coup ça ne veut pas fonctionner

Pour l'Eeprom, si je me base sur le conf du github, elle n'est pas active (confirmé après des essais)

dès que je peux je teste, mais si d'autres avis arrivent je suis preneur smiling smiley


Gege
[innocuousprototypes.gege2b.info]
Re: Le hotend monte très (trop ?) en température
December 01, 2014 04:47AM
BANG_MAX et PID_MAX Ces deux variables interviennent justement lors du PID ( BANG c'est au démarrage et ensuite PID c'est pour le réglage)....

Edited 1 time(s). Last edit at 12/01/2014 04:48AM by al44.
[Résolu] Re: Le hotend monte très (trop ?) en température
January 15, 2015 09:34AM
Bonjour,

Voila, après les fêtes, on a plus de temps pour bricoler winking smiley
Donc je confirme, le fait de mettre BANG_MAX et PID_MAX a 128 est suffisant pour que le problème disparaisse, au prix d'une montée en température à peine plus lente...

Du coup je me demande si ça ne serait pas plus pratique de fournir les machines avec le firmware déjà modifié plutôt que d'être obligé de le modifier après coup ? Surtout si - comme moi - on crame la cartouche par excès de confiance ^^

Bonne fin de journée !

Edited 1 time(s). Last edit at 01/15/2015 09:35AM by gege2b.

Gege
[innocuousprototypes.gege2b.info]
Sorry, only registered users may post in this forum.

Click here to login