Welcome! Log In Create A New Profile

Advanced

No aparece activa la sd en LCD RepRapDiscount Smart Controller confused smiley

Posted by cloxx78 
No aparece activa la sd en LCD RepRapDiscount Smart Controller confused smiley
April 28, 2018 01:18PM
hola saludos comunidad.

consulta arme una impresora 3d con y todo perfecto la detecta se ve la temperatura y entro a las configuraciones de menu del lcd pero veo que no me aparece activo en el menu el SD para colocar las targeta la pantalla es de las tipica una RepRapDiscount Smart Controller, alguien sabe por que es esto ?? gracias
Re: No aparece activa la sd en LCD RepRapDiscount Smart Controller confused smiley
May 22, 2018 06:30AM
Bueno, yo estaba por abrir un post con el mismo problema así que me sumo.
No puedo hacer funcionar la sd de una full graphic smart controller.
Ya he probado de todo. Y siempre el display marca lo mismo No SD card.

Las líneas
#define SDSUPPORT
#define SDSLOW // Use slower SD transfer mode (not normally needed - uncomment if you're getting volume init error)
#define SD_CHECK_AND_RETRY .
Están descomentadas.
El display y el lector andan ya que lo probé en otra impresora y funciona.
Ya probé con varias versiones de U8glib.
Ya aumente el número de spi de 5 a 6.
Ya le agregué delay a la lectura de la sd.
Ya probé, con otros cables, otra ramps, y por último otro arduino.
Probé con 3 sd distintas, 512mb, 2gb, 32 gb. Formateadas de distintas maneras, fat16, fat32, ntfs......
Y no va.
Desde repetier al conectar me marca echo: SD init fail

Si a alguno se le ocurre algo....thumbs up

Gracias, saludos.
Sorry, only registered users may post in this forum.

Click here to login