Welcome! Log In Create A New Profile

Advanced

Prusa edition problem - solved.

Posted by DjDemonD 
Prusa edition problem - solved.
March 05, 2017 01:52PM
So I downloaded this as its a new windows version of slic3r. Some nice new features.

Question - I cannot save any presets? Is this because I am not a prusa mkII owner?

Edited 1 time(s). Last edit at 03/05/2017 11:02PM by DjDemonD.

[www.precisionpiezo.co.uk] Accurate, repeatable, versatile z-probe.
[www.facebook.com] Post an image of your setup, give us a like/share


[www.thingiverse.com] DemonDeltaMicro - Micro Delta Printer & Things I've made/remixed.
Re: Prusa edition problem - solved.
March 05, 2017 11:03PM
Most of the image files from the /vor folder were missing in the version I downloaded from prusa research,so I downloaded them from git and now everything works normally again.


[www.precisionpiezo.co.uk] Accurate, repeatable, versatile z-probe.
[www.facebook.com] Post an image of your setup, give us a like/share


[www.thingiverse.com] DemonDeltaMicro - Micro Delta Printer & Things I've made/remixed.
Re: Prusa edition problem - solved.
March 05, 2017 11:07PM
Just one thing to say, its much faster and more stable than 1.2.9 - big thank you to the prusa team for making slic3r usable again. smiling smiley

Edited 1 time(s). Last edit at 03/06/2017 12:16AM by DjDemonD.

[www.precisionpiezo.co.uk] Accurate, repeatable, versatile z-probe.
[www.facebook.com] Post an image of your setup, give us a like/share


[www.thingiverse.com] DemonDeltaMicro - Micro Delta Printer & Things I've made/remixed.
Re: Prusa edition problem - solved.
March 05, 2017 11:41PM
Did they solve the "gap fill" problem? Do you have a link to the github?
Re: Prusa edition problem - solved.
March 05, 2017 11:58PM
I believe so. They certainly claim to have.

[www.prusaprinters.org]

You can download it there.


[www.precisionpiezo.co.uk] Accurate, repeatable, versatile z-probe.
[www.facebook.com] Post an image of your setup, give us a like/share


[www.thingiverse.com] DemonDeltaMicro - Micro Delta Printer & Things I've made/remixed.
Re: Prusa edition problem - solved.
March 06, 2017 01:42PM
So thought I'd do a test between slic3r 1.2.9 and Slic3r Prusa Edition 1.33.8.


The prusa version is the one on the left, these are cheap abs at 0.15mm layers on kossel XL.

I'd say looking very closely at them the old slic3r one is better, but there not much in it, and the new version loads models and slices them about 5 times faster and crashes about 100 times less (it still crashes but only once per hour not 10 times).


[www.precisionpiezo.co.uk] Accurate, repeatable, versatile z-probe.
[www.facebook.com] Post an image of your setup, give us a like/share


[www.thingiverse.com] DemonDeltaMicro - Micro Delta Printer & Things I've made/remixed.

Re: Prusa edition problem - solved.
March 07, 2017 09:36AM
I've played with it today, but didn't print anything yet. It seems the infill cubic looks the same as triangle? Definitely running smoother than honeycomb.

PS: Got it: Cubic changes between layers and creates a 3D mesh. Clever!!

Edited 1 time(s). Last edit at 03/07/2017 09:39AM by o_lampe.
Re: Prusa edition problem - solved.
March 07, 2017 11:32AM
Yeah cubic sounds good I made a 15% infilled abs cylinder with 3 perimeters about 50mm long and couldn't break it. If I had time I might try a slightly more scientific test. Fast low %, strong infill is a great thing.


[www.precisionpiezo.co.uk] Accurate, repeatable, versatile z-probe.
[www.facebook.com] Post an image of your setup, give us a like/share


[www.thingiverse.com] DemonDeltaMicro - Micro Delta Printer & Things I've made/remixed.
Re: Prusa edition problem - solved.
March 08, 2017 03:36AM
I've noticed that the first of three top infill layers is printing very slow, like 60 times slower than normal. Can you confirm that?
Maybe "solid infill speed" parameter has to be set in mm/min??

FYI: I found a Marlin parameter: Vmin, which was set to zero. After changing it to 25mm/s, the first solid infill print was faster.

I checked the gcode and found lots of G92 E0 in the file. I've never seen that before and was wondering, if this command also resets the last_used G1 Fnnnn.nnn parameter?
Next on my list is to look for a Vmin parameter in RepRapFirmware... sad smiley

Edited 3 time(s). Last edit at 03/08/2017 08:20AM by o_lampe.
Re: Prusa edition problem - solved.
March 08, 2017 08:34AM
G92 E0 just resets the indexing of the extruder to zero. You're slicing in absolute extrusion coordinates. I've never seen any compelling reason to do so.

What is the F parameter of the last G1 command that has one up to the infill in question?
Re: Prusa edition problem - solved.
March 08, 2017 11:00AM
Slicer allows both options: absolute or relative E-values. So it should work with both.
Maybe I use absolute values, because I'm used to it from Cura...

The F parameter is the print speed. Usually you have to set it once and all other lines get printed in that speed. But for some reason this seems to be overwritten or ignored for the first solid top layer.
I've also seen three different types of F values:
F4800.000
F4800.00000
F4800

Why that?
Re: Prusa edition problem - solved.
March 10, 2017 12:03PM
As for absolute/relative extrusion isn't it basically the same, whichever one you select as long as the firmware expects it, you get the same result.
As for the speed/feedrate/F values I presume it will accept a few decimal places I just wonder if its ever necessary to that precise about how quickly you want something to happen.


[www.precisionpiezo.co.uk] Accurate, repeatable, versatile z-probe.
[www.facebook.com] Post an image of your setup, give us a like/share


[www.thingiverse.com] DemonDeltaMicro - Micro Delta Printer & Things I've made/remixed.
Sorry, only registered users may post in this forum.

Click here to login