Welcome! Log In Create A New Profile

Advanced

Making Slic3r use M140 instead of M190

Posted by harlandraka 
Making Slic3r use M140 instead of M190
January 08, 2017 05:19AM
Hi all!

I'm using Slic3r for my prints, and it does pretty good.

I use 225°C hotend temperature and 40°C bed temperature for the first layer, and when I export the gcode it shows like this:

; generated by Slic3r 1.2.9 on 2017-01-08 at 13:57:54

; external perimeters extrusion width = 0.30mm
; perimeters extrusion width = 0.30mm
; infill extrusion width = 0.30mm
; solid infill extrusion width = 0.30mm
; top infill extrusion width = 0.30mm

M107
M190 S40 ; set bed temperature
M104 S225 ; set temperature

As you can see, Slic3r uses M190 for setting the bed temperature, which is the gcode for "set temperature and wait". I noticed that my printer takes approximately the same time to reach 40°C for bed and 225°C for hotend, so I'd like to tell Slic3r not to wait for bed temperature but to wait just for the hotend to reach the right temperature. So, it should use M140 instead of M190. Is there a way to tell Slic3r to use M140 or do I have to edit the gcode later as I'm doing now?

Thank you
Re: Making Slic3r use M140 instead of M190
January 08, 2017 01:50PM
You can put M140 S[first_layer_bed_temperature] in the start gcode where you want it to start heating. You will ultimately need to pass an M190 to keep Slic3r from prepending its own M190 command and overriding what you're trying to do.

Note that, if your machine is near its power limits, it may not be desirable to have both heaters in the initial heating phase (when they'll be drawing their most power) at the same time. This may be the case if the time to reach 40C is significant.

Another benefit of the default sequencing I forgot to mention...The hot end will never sit around at print temperature, oozing and doing who knows what else, waiting for the bed to heat.

Edited 1 time(s). Last edit at 01/08/2017 01:52PM by IMBoring25.
Re: Making Slic3r use M140 instead of M190
January 09, 2017 01:21AM
Hi IMBoring25, thank you for your reply!

I think power isn't an issue, as I kept heating both at the same time for months by manually editing GCODE after generation... This never caused issues.

Regarding the hotend having to wait the bed to reach the temperature, it's impossible, or at least it doesn't happen on my printer. Heating the bed to 60°C takes 5 seconds less than heating the extruder to 225°C, and since I'm heating it to 40°C it will always take less time than the extruder to reach the desired temperature. I'll try the tweak you suggested! Thank you!

Edited 1 time(s). Last edit at 01/09/2017 01:36AM by harlandraka.
Re: Making Slic3r use M140 instead of M190
January 09, 2017 04:43AM
As soon as you use one of the place-holders in your custom G-code (e.g. "[first_layer_bed_temperature]"), Slic3r will no longer add its own command for that parameter.

Dave
Re: Making Slic3r use M140 instead of M190
January 21, 2017 08:36PM
Quote
dmould
As soon as you use one of the place-holders in your custom G-code (e.g. "[first_layer_bed_temperature]"), Slic3r will no longer add its own command for that parameter.

Dave

Hi,

Dave is right. I used to have the same problem.

I wrote the M140 command in the Custom G-Code option under the Printer setting tab. I saw that once you add M140, the slic3r did not add its own M190.

Yashu
Sorry, only registered users may post in this forum.

Click here to login