Welcome! Log In Create A New Profile

Advanced

extruder steps/mm around 0.8 for direct drive when 145 is expected

Posted by fc2se 
extruder steps/mm around 0.8 for direct drive when 145 is expected
January 13, 2018 05:21PM
Okay, I inherited a non-functional 3D printer that was supposed to be a Prusa type. It has an acrylic frame with Borlee cut into it. It has a Melzi V2 control board. It did not work correctly, so the first thing I did was download the latest Marlin firmware and get it working. There were a number of fixes required including some hybrid of settings between the Mendel and Huxley. Otherwise, the bed would not heat, because its transistor was wired to a different pin on the microcontroller.

Early prints were a mess with way too much extrusion. I calibrated the steps/mm and ended up at 0.8 which is crazy since it has a direct drive extruder which should have worked out to around 145 steps/mm. Even if the stepper is not microstepping, I cannot explain why this works unless there is some hidden scale factor in the code. Even so, anything I print still appears to over extrude. As it gets to higher to layers, the hot end appears to dig into the plastic, and lots of plastic blobs are in the infill areas by the time it makes it to the top layer.

I did set the steps/mm way low to 0.6 just to get a print to finish, but it had lots of gaps and still some plastic blobs.

I did check the reference voltages for all the steppers and set the extruder to 0.7 V and other steppers for motion to 0.8 V. I did run with the extruder at 0.8 V originally, and it did basically the same thing.

Can the microstepping be disabled on this board? Why would the steps/mm be so low? Does this imply that the driver chip or stepper is broken and cannot make small steps?

I'm just wondering if there are any debug steps I can take here to know if the board is Melzi board is bad or what is going on. I'm not new to electronics. I'm pretty familiar with Arduino, raspberry pi, etc. However, this is my first experience with 3D printing and its associated electronics and mechanical bits.

Any help will be greatly appreciated!
Re: extruder steps/mm around 0.8 for direct drive when 145 is expected
January 17, 2018 05:40PM
Not sure how you calibrated the extruder or changed steps/mm. The Melzi board may be 1/16 microstepping you need to review those specs. So more info would help.
Re: extruder steps/mm around 0.8 for direct drive when 145 is expected
January 19, 2018 09:40AM
My best guess would be that the slicer is set to absolute extrusion but the board is expecting relative extrusion. Look through the gcode file and see if the G1.....Ennn values keep increasing throughout. If they do, then they are absolute. If your configuration file has an M83 in it then, the board is expecting relative moves. M82 will change it to expect absolute values. It doesn't really matter what they are set to as long as both the slicer and the board use the same configuration.

0.6 steps per mm is just crazy - even if they were full steps and not 1/16 micro steps, it's still crazy low - even for a direct drive extruder.


[somei3deas.wordpress.com]
Sorry, only registered users may post in this forum.

Click here to login