Welcome! Log In Create A New Profile

Advanced

G29 in start code doesn't seem to activate Mesh Bed Leveling

Posted by Hatmpatn 
G29 in start code doesn't seem to activate Mesh Bed Leveling
January 02, 2018 02:26AM
Hello!

I have manually probed my bed and come to this Mesh Bed Leveling grid.

0 1 2 3 4
0 -1.20000 -1.20000 -1.10000 -1.20000 -1.00000
1 -1.40000 -1.40000 -1.60000 -1.60000 -1.30000
2 -1.40000 -1.70000 -1.80000 -1.80000 -1.70000
3 -1.70000 -1.90000 -1.90000 -1.70000 -1.20000

I store it in EEPROM with M500

In Marlin 1.1.7 I have done the following in Configuration.h

//#define AUTO_BED_LEVELING_3POINT
//#define AUTO_BED_LEVELING_LINEAR
//#define AUTO_BED_LEVELING_BILINEAR
//#define AUTO_BED_LEVELING_UBL
#define MESH_BED_LEVELING

#define PROBE_MANUALLY

When I perform a G26(a test grid pattern) everything works fine. The Z axis motors rotate during print. That leads me to believe that my Start Code in Cura does not active the Mesh Bed Leveling system.

When I print an object THE Z-AXIS MOTORS DOES NOT MOVE. They just stand still. What could be the cause of this?

My start code in Cura:

M107 ;start with the fan off
G28 X0 Y0;move X/Y to min endstops
G28 Z0; Move Z to min endstop
G29 ;Enable Mesh Bed Leveling
G92 E0 ;zero the extruded length
G1 Z15.0 F9000 ;move the platform down 15mm

The Gcode in the file that Cura exports:

;FLAVOR:Marlin
;TIME:41268
;Filament used: 63.7258m
;Layer height: 0.2
;Generated with Cura_SteamEngine 3.0.4
M190 S60
M104 S210
M109 S210
M82 ; absolute extrusion mode
M107 ;start with the fan off
G28 X0 Y0;move X/Y to min endstops
G28 Z0; Move Z to min endstop
G29 ;Enable Mesh Bed Leveling
G92 E0 ;zero the extruded length
G1 Z15.0 F9000 ;move the platform down 15mm


;LAYER_COUNT:295
;LAYER:0
M107
G0 F2400 X90.597 Y129.179 Z0.2
;TYPEconfused smileyKIRT
G1 F1800 X91.343 Y128.702 E0.02945
G1 X92.129 Y128.295 E0.05889
G1 X92.949 Y127.961 E0.08834
G1 X93.795 Y127.702 E0.11777
G1 X94.662 Y127.52 E0.14723
G1 X95.541 Y127.417 E0.17667
G1 X96.229 Y127.392 E0.19956
G1 X144.411 Y127.341 E1.80211
G1 X149.507 Y127.052 E1.97187
G1 X154.566 Y126.478 E2.14121....

And so on...
Re: G29 in start code doesn't seem to activate Mesh Bed Leveling
January 02, 2018 02:49AM
Ok solved it myself, but I will share the solution.

The issue was that State of the G29 was set to Off

I added a line: M420 S1 ;Enable Mesh Grid after the G29 and now everything works!
Re: G29 in start code doesn't seem to activate Mesh Bed Leveling
January 02, 2018 06:42AM
Hello;

I had posted on this previously read below

[forums.reprap.org]
Sorry, only registered users may post in this forum.

Click here to login