Welcome! Log In Create A New Profile

Advanced

Bed PID tuning "Bad extruder number"

Posted by Brotherhood 
Bed PID tuning "Bad extruder number"
March 12, 2017 02:06PM
Hi, so I have been trying to do the PID tuning which came out without trouble with extruder.
When I tried it with my heated bed it threw out :
PID Autotune failed! Bad extruder number
This is what I sent to my printer through Pronterface
M303 E-1 C8 S110

I am using Marlin 1.1.0-RC8
Re: Bed PID tuning "Bad extruder number"
March 13, 2017 12:14AM
Which motherboard is defined? E.g. RAMPS1.4_EFF wouldn't have a bed heater.
Re: Bed PID tuning "Bad extruder number"
March 13, 2017 12:44AM
Double sent by mistake

Edited 1 time(s). Last edit at 03/13/2017 02:50AM by Brotherhood.
Re: Bed PID tuning "Bad extruder number"
March 13, 2017 12:44AM
I have big Rambo
#define MOTHERBOARD 301
The thing is I can turn the heated bed on via PC or LCD controller without problem, I just cant run autotuning
Re: Bed PID tuning "Bad extruder number"
March 13, 2017 08:07AM
bad post smiling smiley

Edited 1 time(s). Last edit at 03/13/2017 04:03PM by obewan.
Re: Bed PID tuning "Bad extruder number"
March 13, 2017 01:15PM
Wouldnt I kind of mess up my pins (voltage etc.) configuration? (Just dont want to damage the MB )

Edited 1 time(s). Last edit at 03/13/2017 01:16PM by Brotherhood.
Re: Bed PID tuning "Bad extruder number"
March 13, 2017 04:02PM
Quote
Brotherhood
Wouldnt I kind of mess up my pins (voltage etc.) configuration? (Just dont want to damage the MB )

ooops, my mistake, i see that board 301 is a rambo, so try

#define BOARD_RAMBO
Re: Bed PID tuning "Bad extruder number"
March 14, 2017 05:35AM
Tried that already.When the heating (usual, not PID) stopped because of
Error:Heating failed, system stopped! Heater_ID: bed
Errortongue sticking out smileyrinter halted. kill() called!
Entering this turned the extruder heater even though by ID I would expect turning the bed on
M303 bed s110 c8
Sorry, only registered users may post in this forum.

Click here to login