Welcome! Log In Create A New Profile

Advanced

Control PSU & use BLtouch on one single RAMPS board?

Posted by oscar7601 
Control PSU & use BLtouch on one single RAMPS board?
July 13, 2017 03:21PM
Hello everyone,

I would like to ask you a question.
Is it possible to both :
  • control my ATX PSU from the RAMPS board using M80 and M81 from OctoPrint
  • Use a BLtouch sensor which "requires" to bridge the VCC pin to the +5V

I just made the electrical connections from this tutorial : [github.com]

But I have not made any connection from the +5V pin of the Ramps board to the VCC pin. Would it be safe to do this although I'm feeding the +5V power from the +5Vsb wire of my ATX PSU? I'm a bit scared of frying the whole thing!
The Geeetech wiring tutorial for the BLtouch does state that I should bridge the VCC and the +5V pins of the RAMPS board... But I don't know what are the effects of doing/not doing this.

I tried powering up the hole thing but when I connect to the Ramps board with Octoprint I instantly get the following message :
Quote
OctoPrint
Error : STOP called because of BLTouch error. Restart with M999

Could this error message come from the fact I have not yet bridged the +5V to the VCC on the RAMPS board?

Thank you very much in advance.

Oscar

Edited 1 time(s). Last edit at 07/13/2017 03:27PM by oscar7601.
Re: Control PSU & use BLtouch on one single RAMPS board?
July 13, 2017 04:15PM
Yes they both work fine together, Leave the +5v connected to your power supply 5v. Don't use the standby 5v, its also low current. Also it only powers the 4 servo plugs on the ramps, nothing on there needs to be on all the time.
Don't try connecting both at once... although they are both 5v... any fractional differences in voltage will cause issues with the two power supplies fighting each other (the power supply will win, way more current)

From the page you linked

"Powering servos from the +5V from the ATX PSU

Your RAMPS 1.4 board has connectors for and can control up to 4 servos. However, you'll notice that the +5V trace that powers the servos on the RAMPS board is by default not connected to any power source. It just connects to the +5V input pin next to the PS_ON input pin. Using a jumper it is possible to connect it to the Vcc pin right next to it, but this will impose an additional load on the Arduino Mega 2560 power regulator, so imho it is better to connect it to the regular +5V from the ATX power supply."

Edited 1 time(s). Last edit at 07/13/2017 04:24PM by Dust.
Re: Control PSU & use BLtouch on one single RAMPS board?
July 13, 2017 04:29PM
Thank you Dust for answering so quickly!

So... sorry my english is far from perfect. So my understanding of this is that, the other day, when my Mega 2560 voltage regulator blew up, it might have been caused by the jumper I put between the VCC and the 5V pins on the RAMPS? (At that time, I was not powering the board from an ATX PSU, just a regular Chinese one).

Could the dead voltage regulator :
  1. Have fried my BLtouch?!
  2. Be the cause of the BLtouch error Octoprint is monitoring?
Sorry, only registered users may post in this forum.

Click here to login