Welcome! Log In Create A New Profile

Advanced

[Solved] Can't get Marlin 1.1.x to compile FolgerTech I3 2020confused smiley

Posted by Fpeebles 
[Solved] Can't get Marlin 1.1.x to compile FolgerTech I3 2020confused smiley
July 03, 2017 01:37PM
Everyone,
I can't get Marlin to compile. I've tried both Arduino IDE 1.6.8 and 1.8.3. I've downloaded a clean copy of Marlin 1.1.x Release version and the only modifications I've made to it where my stepper motor values since I upgraded to DRV8825's when I bought it.

I keep getting the following error when I try to compile and validate:
==================================================================================================================
Marlin:1: error: expected unqualified-id before '.' token

.

^

In file included from sketch\MarlinConfig.h:26:0,

from C:\Users\XXXXXX\Desktop\3d Printer\Release Firmware\Marlin-1.1.x\Marlin\Marlin.ino:32:

fastio.h:139: error: 'WaveGenMode' does not name a type

} WaveGenMode;

^

exit status 1
expected unqualified-id before '.' token

==================================================================================================================

Thanks!

Edited 1 time(s). Last edit at 07/05/2017 10:27PM by NewPerfection.
Re: Can't get Marlin 1.1.x to compile FolgerTech I3 2020confused smiley
July 04, 2017 09:56PM
There is no "WaveGenMode" mentioned in marlin on the official git hub. Are you using the official marlin github?

[github.com]

The configuration.h you provided in another post is quite different from the shipped configuration.h

I was not able to reproduce this error.

I also could not get your configuration.h to compile, but with min endstop definition errors.

I suggest you get a new copy of marlin. Make no changes and check you can compile it. there may be something wrong with your build environment.
Re: Can't get Marlin 1.1.x to compile FolgerTech I3 2020confused smiley
July 05, 2017 09:19PM
Thank you, that was it. I started over and reinstalled the IDE and then used a fresh copy of Marlin. Compiled with no changes, it worked, copied the folgertech config from the example configurations and compiled with no problems. Made the changes needed for my upgraded stepper drivers and it worked as well.

The only difference I can tell from previous attempts at starting over was I edited in the IDE vs doing it in Notepad++.

Thank you for taking the time to help. Much appreciated.
Sorry, only registered users may post in this forum.

Click here to login