Welcome! Log In Create A New Profile

Advanced

Changing pin configuration - y-axis to extruder 2

Posted by bishupz1 
Changing pin configuration - y-axis to extruder 2
April 20, 2014 06:39PM
So my arduino 1.4 ramp burnt out the mosfet, and I have an azteeg x3 with the Y-axis stepper (aspect of the board) not working (it pulses). I do have a new power supply from the atx to a more suitable power supply for 3d printers. I do wonder if that might have need the problem, but at this point I am more than willing to change the pin configuration of the Marlin firmware.

From my understanding of posts and the marlin firmware the code to be changed is only within the pins.config file. I think azteeg x3 is mother board 67 (I would have to look up), so i searched for that and read over the config settings. It was unclear to me the separation between the pin settings for the extruders, and wanted to see if someone more skilled at changing these settings knew the best way to accomplish this.

I was wondering if anyone has don this or knows how to easily do this. I am not the best at electronics, so i wanted to start with some good advice and see where it goes...

Edited 1 time(s). Last edit at 04/20/2014 07:12PM by bishupz1.
Re: Changing pin configuration - y-axis to extruder 2
May 03, 2014 10:58PM
Hi,

I just changed my x axis with my second extruder on a ramps 1.4. It was quite easy in fact. I looked in the pins.h for my motherboard. Then I just switched the 3 pins allocation.
#define X_STEP_PIN 36//54
#define X_DIR_PIN 34//55
#define X_ENABLE_PIN 30//38

I detached the motor from the frame to test them and when I was sure about the motor and direction then I assembled it back.

That's it.

Good luck
Re: Changing pin configuration - y-axis to extruder 2
January 26, 2018 11:04AM
it workes smileys with beerthumbs up
Sorry, only registered users may post in this forum.

Click here to login