Welcome! Log In Create A New Profile

Advanced

Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface

Posted by pikelo 
Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 01, 2011 01:56PM
Hello,

I bought a RAMPs 1.4 and now I started to build my Prusa. Well, I wanted to try the NEMA 17 motors and I connected them to the RAMPs in this order

2A = red
2B = blue
1B = green
1A = black

They don't move. I changed the option (board selection) on Sprinter firmware and I choose 33 to chose the RAMPs 1.3 (1.4 is not availabe for selection). I also tried disconnecting my endstop from board and nothing. I really don't know what I can do else. I connect the printer with my computer trough Pronterface and pressing "Connect" botton, it's fine and it gives a message that printer is now online. I also tried the test code downloaded from wiki and I just get the two leds lighting green and red, but no any movement. I'm using a power supply with 12V and 20A ATX, wich I tested it with a multimeter and it gives 11.85V.


I hope you could help me with this. It's getting really upset.

Miguel
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 01, 2011 02:05PM
This is my power supply [www.latiendadelordenador.com]
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 01, 2011 06:38PM
To make sure your motor is correctly wired to the RAMPS, check the motor wires resistance with an ohmmeter.

On a 4 wire motor, one pair of wires should read around 2 ohms, and the other pair 2 ohms also. Any other measure should read "open".

Wire one pair to 2A and 2B, and the other pair to 1A and 1B.

Then, turn the little potentiometer on the stepper driver bord to full counterclockwise, then clockwise to 25%. This is the current limit adjustment of the driver.

Then try the test code, it should work.

If it doesn't, change the endstop section to this:

//// Endstop Settings
#define ENDSTOPPULLUPS // Comment this out (using // at the start of the line) to disable the endstop pullup resistors
// The pullups are needed if you directly connect a mechanical endswitch between the signal and ground pins.
//If your axes are only moving in one direction, make sure the endstops are connected properly.
//If your axes move in one direction ONLY when the endstops are triggered, set [XYZ]_ENDSTOP_INVERT to true here:
const bool X_ENDSTOP_INVERT = false;
const bool Y_ENDSTOP_INVERT = false;
const bool Z_ENDSTOP_INVERT = false;

This is what I use, with NC switches wired in, so put a jumper on the ramps endstop pins if you don't have actual switches mounted on the machine. If it is not jumped, the motor should still be able to run in one direction only.

Hope it works. I had problems to to make my motors turn the first time. I finally had to check the website where I bought them and they specified which wire color for each pin.

Good luck!

Edited 1 time(s). Last edit at 12/01/2011 06:39PM by Kabory.

Don't force it, it will break. Stop. Think.
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 02, 2011 01:04AM
If the test code doesn't run correctly then something is either shorting or is broken.

Disconnect everything then run the test code again. If all 4 LED's don't flash then its the board itself.

If they all flash with the test code then one by one attach each part until something doesn't work (make sure its powered off when your connecting or removing parts).


My Reprap blog

jds-reprap.blogspot.com
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 02, 2011 02:24AM
Hello everyone,

Thousand of thanks for your help, I found and solved the problem, it was a electrical problem with power supply.

Well, now I got the motors connected and with Pronterface I send the order to move i.e. Z motors +10 or -10, the motors make the noise like they are moving but they don't. I thought it could be a low power was comming in to them and I turned right a little more the trim pot from pololu, the noise increased a little higher but they still don't move.. anyone got this trouble too?

Thanks again to all of you


LOVING THIS FORUM smiling smiley
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 02, 2011 02:37AM
Check there are no solder bridges on the RAMPS board.
I had a similar issue on my Z-axis a hair sized piece of solder was bridging one of the headers.

If you can't find any its worth double checking the colours -> pin setup is correct for your stepper motors as they can vary make to make.


My Reprap blog

jds-reprap.blogspot.com
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 02, 2011 02:55AM
Should I increase a little more the pololu current?
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 02, 2011 03:55AM
If they have no load (well pressure) they shouldn't require much current to turn.

Are all the motors doing the same or just one?


My Reprap blog

jds-reprap.blogspot.com
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 02, 2011 04:14AM
I gave a little more current from pololu pot and it turn a little but it turns untill a limited angle. This happens with all the motors. I don't know what it can be.. Could I try to disconnect from RAMPs the three endstop and it could work? or it won't work any motor without endstop plugged on RAMP? Just for testing..
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 02, 2011 06:08AM
Sorry for this long post but I would like to attach all the "important" starting configuration and see if someone see why my motors make the noise like they are moving but they don't move:

// BASIC SETTINGS: select your board type, thermistor type, axis scaling, and endstop configuration

//// The following define selects which electronics board you have. Please choose the one that matches your setup
// MEGA/RAMPS up to 1.2 = 3,
// RAMPS 1.3 = 33
// Gen6 = 5,
// Sanguinololu up to 1.1 = 6
// Sanguinololu 1.2 and above = 62
// Teensylu (at90usb) = 8
// Gen 3 Plus = 21
// gen 3 Monolithic Electronics = 22
// Gen3 PLUS for TechZone Gen3 Remix Motherboard = 23
#define MOTHERBOARD 33

//// Thermistor settings:
// 1 is 100k thermistor
// 2 is 200k thermistor
// 3 is mendel-parts thermistor
// 4 is 10k thermistor
// 5 is ParCan supplied 104GT-2 100K
// 6 is EPCOS 100k
// 7 is 100k Honeywell thermistor 135-104LAG-J01
#define THERMISTORHEATER 1
#define THERMISTORBED 1

//// Calibration variables
// X, Y, Z, E steps per unit - Metric Prusa Mendel with Wade extruder:
float axis_steps_per_unit[] = {80, 80, 3200/1.25,700};
// Metric Prusa Mendel with Makergear geared stepper extruder:
//float axis_steps_per_unit[] = {80,80,3200/1.25,1380};
// MakerGear Hybrid Prusa Mendel:
// Z axis value is for .9 stepper(if you have 1.8 steppers for Z, you need to use 2272.7272)
//float axis_steps_per_unit[] = {104.987, 104.987, 4545.4544, 1487};

//// Endstop Settings
#define ENDSTOPPULLUPS // Comment this out (using // at the start of the line) to disable the endstop pullup resistors
// The pullups are needed if you directly connect a mechanical endswitch between the signal and ground pins.
//If your axes are only moving in one direction, make sure the endstops are connected properly.
//If your axes move in one direction ONLY when the endstops are triggered, set [XYZ]_ENDSTOP_INVERT to true here:
const bool X_ENDSTOP_INVERT = false;
const bool Y_ENDSTOP_INVERT = false;
const bool Z_ENDSTOP_INVERT = false;

// This determines the communication speed of the printer
#define BAUDRATE 115200

// Comment out (using // at the start of the line) to disable SD support:
// #define SDSUPPORT


//// ADVANCED SETTINGS - to tweak parameters

#include "thermistortables.h"

// For Inverting Stepper Enable Pins (Active Low) use 0, Non Inverting (Active High) use 1
#define X_ENABLE_ON 0
#define Y_ENABLE_ON 0
#define Z_ENABLE_ON 0
#define E_ENABLE_ON 0

// Disables axis when it's not being used.
const bool DISABLE_X = false;
const bool DISABLE_Y = false;
const bool DISABLE_Z = true;
const bool DISABLE_E = false;

// Inverting axis direction
const bool INVERT_X_DIR = false;
const bool INVERT_Y_DIR = false;
const bool INVERT_Z_DIR = true;
const bool INVERT_E_DIR = false;

//// ENDSTOP SETTINGS:
// Sets direction of endstops when homing; 1=MAX, -1=MIN
#define X_HOME_DIR -1
#define Y_HOME_DIR -1
#define Z_HOME_DIR -1

const bool min_software_endstops = false; //If true, axis won't move to coordinates less than zero.
const bool max_software_endstops = true; //If true, axis won't move to coordinates greater than the defined lengths below.
const int X_MAX_LENGTH = 200;
const int Y_MAX_LENGTH = 200;
const int Z_MAX_LENGTH = 100;

//// MOVEMENT SETTINGS
const int NUM_AXIS = 4; // The axis order in all axis related arrays is X, Y, Z, E
float max_feedrate[] = {200000, 200000, 240, 500000};
float homing_feedrate[] = {1500,1500,120};
bool axis_relative_modes[] = {false, false, false, false};

// Min step delay in microseconds. If you are experiencing missing steps, try to raise the delay microseconds, but be aware this
// If you enable this, make sure STEP_DELAY_RATIO is disabled.
//#define STEP_DELAY_MICROS 1

// Step delay over interval ratio. If you are still experiencing missing steps, try to uncomment the following line, but be aware this
// If you enable this, make sure STEP_DELAY_MICROS is disabled. (except for Gen6: both need to be enabled.)
//#define STEP_DELAY_RATIO 0.25


Thanks in advance.
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 02, 2011 08:24AM
I used the test firmware and X motor is turning but others no, just making the noise like they are moving and a little vibrating and the leds blinking.

then I tried again with pronterface and the motor X get same stay than others, not moving.
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 04, 2011 10:03AM
Well, I still can't move my motors. Just vibrating. I have tried all what I could think it could be wrong. Motors wiring, firmware (I tried some differents with same issue), change stepsticks for new ones, tested with Martinj testcode and nothing new.

Lost in this case, if someone could help it will be very wellcome. Thank you to everyone.
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 05, 2011 12:48PM
Pikelo, as you mention motor X is moving ok, you can then use that socket to check all the other steppers connected to it. Once you know all the motors are wired ok, you can try moving this X-axis pololu known good to the other sockets to see whether they work ok or not. Once motors and sockets are known to be ok, you can replace x-axis pololu for each one of the others to double check each one.

misan
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 06, 2011 01:06AM
As a summarize and after 3 days just trying trying and trying, 3 of my 4 pololu are gonne compleatly. After change them by new ones, problem didn't finish and still motors didn't move. To get them moving, I just had to divide by 16 the step_per_unit value and after that, just try it and calculate the correct value with the Josef online calculator. For now just a problem, X,Y and extruder motor are moving, I couldn't find a correct value for the Z motors. For now I'm on

float axis_steps_per_unit[] = {4.9, 4.819, 200, 42};
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 06, 2011 02:28AM
Please remember the jumpers below each pololu socket allow you to select the microstepping level you want. The three jumpers on mean 16 microstepping (1 full step = 16 microsteps). It seems to me you have no jumpers on, so you have to divide by 16 to get the right distances compared to others. But not using microstepping on X and Y axis may lead to a noisy machine and to a low resolution one too.

Z- axis uses two motors, there are two ways of wired them right: series and parallel. I am using the series one, and it works ok for me. Have you tried each Z-axis motor by itself? Are you sure they are connected together the right way?
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 06, 2011 10:26AM
First of all, thank you very much Misan. Yes, you're right, I don't have jumpers and that's way I divide the values by 16, I'm waiting my jumpers by post because the shop forgot to provide them when I bought the RAMPs, and belive me that's a really noisy machine! :O

On picture is shown how I connected the Z motors, do you think I'll get the controll of the Z motors with the jumpers?? They are right connected because they get current, they "tried" to move but they don't..
Attachments:
open | download - Z motor.jpg (35.9 KB)
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 06, 2011 10:41AM
In my prusa, Z-axis and extruder steppers need more torque than X and Y axis (I have ball bearings in all axis). From your picture I can see the two Z-axis motors are in parallel connection. Many people have it this way and it works.

Mine are in series, like in the second post of this thread: [www.mendel-parts.com]

I think it is better this way (though the recommended way is the one you have: [rusa_Mendel" target="_blank" >reprap.org] )

But before doing any changes, you need to be sure that both motors work. One problem here: if the X carriage is already suspended from Z-axis steppers you do not want to rotate just one stepper as you will lose the horizontal leveling of the axis and extra force will be needed for the stepper to keep on rotating.

I hope this helps.

misan
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 06, 2011 02:02PM
Hello Misan,

How do I connect the motors on series if I'm using RAMPs 1.4 and my wires colour code is:

2A = red
2B = blue
1B = green
1A = black

??

On the link that you sent, Dnaman solved the (maybe and very probably) same problem than mine just activating the Acceleration on Software. Do you know how I could try this option before wire the motors on series, if I use Pronterface?

I appreciate your help smiling smiley thank you very much
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 06, 2011 02:43PM
Make sure this is not commented in configuration.h of Sprinter to enable acceleration code (line 98 in my configuration.h):

// Comment this to disable ramp acceleration
#define RAMP_ACCELERATION

You can connect motors in series as:

2A = red1
2B = blue2
1B = green1
1A = black2

plus wiring:

blue1 to red2
black1 to green2

where red1 is red wire of motor1 (left) and blue2 is blue of motor2 (right).

You are welcome,

misan
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 07, 2011 10:32AM
Sorry, In my last post I wrote wront the pin's colour code:

2B = red
2A = blue
1A = green
1B = black

I attached a picture where I show how I would connect the Z motors in series, maybe NISAN could check it and say if it's totally correct or not, I'm quite scared to connect them in series. I wouldn't like to brake them..
Attachments:
open | download - Ramp's series Z motors.jpg (41.8 KB)
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 07, 2011 11:06AM
You certainly don't want to brake your steppers 'cause they won't turn (sorry the pun).

Your drawing is correct. Being connected in series they will represent a lighter load (double the resistance on each coil) so it will draw half of the current, which is safer for the pololu driver. Fear not.

Of course, make sure connections are well isolated (electric tape?).

Good luck,

misan
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 08, 2011 04:23AM
Tried with motors connected in series, and getting same result.. just Z-motors buzzing when press any displacement button on Pronterface.

Getting so upset because I can't see where is the problem. Also I tried to swap the z-axis pololu with x-axis pololu and still doing the same. I still don't have connected the jumpers under the pololu but I didn't get them yet but I divided the steep per mm by 16 values.

Possible problems list:

- RAMPs 1.4 defective just in Z axis?
- No jumps plugged (but all the other motors are moving)
- Pronterface
- Sprinter

I would like to try new firmware and software, does anyone recommend any?
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 08, 2011 04:48AM
You are probably trying to move the Z-axis too fast.
Try setting 1 mm/sec (or 60 mm/min) as your maximum Z speed!


Bob Morrison
Wörth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 08, 2011 04:57AM
I can only think of three reasons why they would buzz:

Trying to go too fast or accelerating too quickly.
Not enough current for the torque needed to turn the screws.
The coils wired incorrectly.

Have you tried lowering the Z feed rate?

Have you tried running just the motor without the screws attached? If it spins then you just don't have enough torque. If it doesn't the step rate is too fast or the wiring wrong.

Have you tried connecting the Z motors to the X-axis driver. That will be configured to spin much slower.

Does the Z axis move freely and the screws turn easily with the power off? If the bars are not parallel or the screws bent it will bind.


[www.hydraraptor.blogspot.com]
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 08, 2011 04:58AM
I do agree with Bob, please note your configure.h states 200 for Z axis steps/mm but as you are not using microstepping you'd have to divide that by 16.

However, when swithing Z-axis mototor to X-axis drive should work ... !?

misan
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 08, 2011 05:03AM
How do I change it? Do you mean I edit the firmware?

//// Calibration variables
// X, Y, Z, E steps per unit - Metric Prusa Mendel with Wade extruder:
float axis_steps_per_unit[] = {4.9, 4.819, 60, 42};
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 08, 2011 05:05AM
Yes, but first double check each one of nophead's answer.

In my prusa Z-axis required most of the torque, it is a good idea to first try steppers can move without load, if they can, they rattle because the load is too high and they are just missing steps.

misan
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 08, 2011 06:03AM
I decreased to 60, I greased the threaded rod again with spry, check horinzontality of the x axis bars and tried.

Z-Axis moves!!! I got it, but my right z-coupling has slided down with the z-axis threaded rod and I've to install it again. I'm using the Nophead z coupling and maybe because of the not enough preasure between the coupling and the motor's spin plastic.

Thought I need to check the config about the 60 and calibrate it.

If I got the manage of all the axis without the jumpers, what do they do exactly? Does it let you controll the machine better, softer??
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 08, 2011 06:52AM
You need to squeeze the coupling up tight. Also if there is any oil or grease on the motor shaft it will slide down very slowly. I clean the motor shaft with methylated spirit first.

The jumpers enable micro stepping making each step is 1/16 of a motor step. It then takes 3200 steps for one revolution instead of 200. The machine is then much smoother and quieter.


[www.hydraraptor.blogspot.com]
Re: Motors don't move RAMPs 1.4 + Arduino Mega 2560 + Sprinter Kliment + Pronterface
December 08, 2011 12:43PM
Yes, I tried with methylated spirit cleaning and now it seems it's working fine.

Currently I've installed a Greg's extruder and I have been surfing and checking how to press the filament to the hobbed bolt. Do you think it's better to use a spring or anything else? I tried before with my Wade's extruder with springs and I couldn't find the preasure enough and it didn't push the filament down.
I bought ABS filament from different suppliers who one says hot end temp. must be 265ºC and other 235º.. is that normal?

Nophead, wich is your combo (firmware+host software)? what temperature do you extrude the ABS?

thank you to everyone who helped
Sorry, only registered users may post in this forum.

Click here to login