Welcome! Log In Create A New Profile

Advanced

Repsnapper on ubuntu 11.04 - missing tabs?

Posted by Nudel 
Repsnapper on ubuntu 11.04 - missing tabs?
May 11, 2011 04:47AM
I got repsnapper installed (https://github.com/timschmidt/repsnapper) on my ubuntu 11.04 (clean install), but I have some problems with it.

The first is there is no longer a tab for "printer definition", which is easily circumvented by "gedit ~/.config/repsnapper/repsnapper.conf" - so no big deal. You can also edit the start and end gcodes in the same file. Edit: It's there, just moved to the menu. Thanks jcabrer!

I connect to the printer fine (thanks to this: [forums.reprap.org] ), and I can control the different axis, home, heat the nozzle and purge. "Monitor temperature" is enabled but where do I read it? There is no "current temp" value to be seen? This could probably be fixed by setting temperatures in skeinforge, but I like to keep an eye on the temp while printing (yes, I've damaged a few hot ends before), and experiment with different temperatures.

I can load gcode (proven to print well) but when I hit "print" it moves to the starting position and stalls.

The "comms" windows are all empty as well.


Thank you for your time! Because you took your time to read my post, I have attached a picture for your enjoyment. We all like pictures of prints, no?

Edited 1 time(s). Last edit at 05/11/2011 09:39AM by Nudel.

--
-Nudel
Blog with RepRap Comic
Attachments:
open | download - IMG_7912s.JPG (583.4 KB)
Re: Repsnapper on ubuntu 11.04 - missing tabs?
May 11, 2011 09:24AM
All of those tabs were consolidated and moved into menus.
Re: Repsnapper on ubuntu 11.04 - missing tabs?
May 11, 2011 09:40AM
I don't know whether I should laugh or cry. I'll do both and blame the new unity-look for hiding alle the menus. Haha! Thanks for saving me jcabrer smiling smiley

Now on to more testing to see if I can get the comms to work.

EDIT: The communication works. But I get "Serial Error:Recieved a LineNr code without a Checksum code or Checksum without LineNr" once the prints start.

Edited 1 time(s). Last edit at 05/11/2011 10:37AM by Nudel.
Re: Repsnapper on ubuntu 11.04 - missing tabs?
May 11, 2011 03:20PM
Are you running RAMPS with a new MEGA?
Re: Repsnapper on ubuntu 11.04 - missing tabs?
May 11, 2011 03:32PM
Sorry, kind of important information. I run tech zone gen3 remix, with the firmware from "firmware reprap 64bit-mendel-20100719".

I've tried newer ones, but I can't get them to speak to the electronics. And afaik the arduino firmwares doesn't support a separate extruder controller. Firmware suggestions are welcome btw.
Re: Repsnapper on ubuntu 11.04 - missing tabs?
May 11, 2011 07:45PM
I added the option '-b gtk2' on the end of my git checkout and had to add a few libraries and such, I can't remember off the top of my head what they were but it's in the README. It got me menus but for some reason it wouldn't drive my z axis.
Re: Repsnapper on ubuntu 11.04 - missing tabs?
May 12, 2011 01:07AM
Well, the program runs nicely.
I can jog all the axis, heat and purge.
The gcode I've been testing is proven to work with the electronics from my win7 box.
Also tried slicing in repsnapper with same results.

So it seems it's the serial communication, or repsnappers interpretation of the communication with certain gcodes that doesn't work?
Re: Repsnapper on ubuntu 11.04 - missing tabs?
August 15, 2011 07:47PM
Hi,

I just compiled Repsnapper on my Ubuntu 10.04 and also noticed missing tabs. I can't seem to find "menus" section where everything is "hidden" either.

Attached are some screenshots:

repsnapper_01.jpg - shows the standard tabs. Where can I find the "menus" section which shows me my Tip Temperature, etcetc?

repsnapper_02.jpg - shows some errors dumped on my bash console. Should I be concerned about these errors?

repsnapper_03.jpg - I loaded the [reprap.org] 10mm cube STL file and nothing shows up. The same file shows a cube fine using Blender. Am I missing something?

Thanks
Jack
Attachments:
open | download - repsnapper_01.jpg (65.8 KB)
open | download - repsnapper_02.jpg (59.5 KB)
open | download - repsnapper_03.jpg (65.8 KB)
Re: Repsnapper on ubuntu 11.04 - missing tabs?
August 15, 2011 08:04PM
I do have the same problem.

The 3d rendering is not working... Except if you load a STL file first then convert to gcode. In this case the 3d rendering will show up and you can load any gcode file.

But I compiled repsnapper Yesterday I had no problem with 3d rendering but I do not have the temperature menu.
Re: Repsnapper on ubuntu 11.04 - missing tabs?
August 15, 2011 09:54PM
So confirmed that hitting the "convert to gcode" button renders the cube.

Can anyone help with the missing temperature reading / menu?

Thanks
Re: Repsnapper on ubuntu 11.04 - missing tabs?
August 16, 2011 12:09AM
Edit: Disregard this, I misread 10.04 for 11.04, so this only applies to Ubuntu 11.04 with Unity.

The menus are there, you just have to hover your cursor on the title bar, and they show up next to the close/min/max buttons.

May I suggest you also take a look at printrun, which is getting a lot of good press these days. smiling smiley

Edited 1 time(s). Last edit at 08/16/2011 08:31AM by Nudel.

--
-Nudel
Blog with RepRap Comic
Re: Repsnapper on ubuntu 11.04 - missing tabs?
August 16, 2011 07:02AM
Hi Nudel,

Sorry for seeming dense but check out my attached screenshot... I don't see the close/min/max buttons you are talking about, much less hidden "menus".

(I'll take a look at printrun)

Thanks
Jack
Attachments:
open | download - repsnapper_01.jpg (65.8 KB)
Re: Repsnapper on ubuntu 11.04 - missing tabs?
August 16, 2011 07:19AM
If you look at the first screenshot here: [www.webupd8.org] you see the top menu/tool bar containing some elusive menu items not present in the window itself. My problem was I didn't see those, don't know if that's what you're looking for.

The reference to the window control buttons (top left in your screenshot) might be my memory playing tricks with me, or because I run the program full screen. My ubuntu box is in being moved at the moment so I can't check it right now unfortunately.


--
-Nudel
Blog with RepRap Comic
Re: Repsnapper on ubuntu 11.04 - missing tabs?
August 16, 2011 07:22AM
eye rolling smiley The TOP LEFT of your window are the CLOSE, MIN and MAX buttons visible ABOVE the MENU.


Bob Morrison
W├Ârth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Repsnapper on ubuntu 11.04 - missing tabs?
August 16, 2011 07:50AM
My ubuntu looks like this:

And I'm positive the "Music - Edit - View" etc menu options was not visible until I hovered over them. At least that was my problem, don't know if that's what jack is looking for though. smiling smiley


--
-Nudel
Blog with RepRap Comic
Re: Repsnapper on ubuntu 11.04 - missing tabs?
August 16, 2011 08:25AM
Thats a feature of Unity the new desktop environment of Ubuntu.

It's not the same with gnome, so hovering over the title bar doesn't do anything for me.
Re: Repsnapper on ubuntu 11.04 - missing tabs?
August 16, 2011 08:29AM
My sincere apologies! I misread 10.04 for 11.04, and though the problem was related to unity. Please disregard my rampant ramblings.


--
-Nudel
Blog with RepRap Comic
Re: Repsnapper on ubuntu 11.04 - missing tabs?
August 16, 2011 08:33AM
Oh i see now!
Yes we have some menu :
File - Edit - Help
And the under layer menu such as Preferences.

But I have no idea where the temperature is supposed to appear.
Re: Repsnapper on ubuntu 11.04 - missing tabs?
August 16, 2011 11:36AM
For me (Ubuntu 10.04) the current temperature is on repsnaper's interactive tab, on the nozzle - heat on/off - current - target temperature line - vertically near the middle of the right panel.
Re: Repsnapper on ubuntu 11.04 - missing tabs?
August 16, 2011 12:20PM
@DeuxVis Do you have the latest version of Repsnapper? Because with the latest one there is a "Printer Controls" tab that used to be the interactive tab, you can see it here: [forums.reprap.org]

But there is no temperature.
Re: Repsnapper on ubuntu 11.04 - missing tabs?
August 16, 2011 02:52PM
Hi DeuxVis,

I'm using 10.04 too. As depicted by the JPG link in @zzarbi's reply, I don't see an interactive tab.

When did you git clone your repsnapper / which commit # are you using? I'm using head - specfically:

$ git clone [github.com]

$ cd repsnapper

$ git log | head
commit 849ec77449b245080bf4f4f8bc7ff0811ae8e06f
Author: Michael Meeks 
Date:   Mon Jul 11 10:15:42 2011 +0100

    cleanup the docs a bit

Tangentially, do the project contributors monitor this board at all? I'm looking at the src.. there is a declaration for model.h::void EnableTempReading(bool on); but there isn't a definition for that routine???!

Jack
Re: Repsnapper on ubuntu 11.04 - missing tabs?
August 16, 2011 09:23PM
Oh yes sorry, forgot about that, wasn't able to have the last version build. Here's what I got :

~/src/repsnapper$ git log
commit e4b22ec6e9edde94eefd7b683256031796c9421a
Author: Elmom 
Date:   Sun Apr 17 09:56:40 2011 +0300

    Fixed the docs of V1 to clone the proper branch
Re: Repsnapper on ubuntu 11.04 - missing tabs?
August 17, 2011 01:37PM
Thanks @DeuxVis, your commit hash has temp readings (check out attached screenshot).

On to putting out the next fire...

Jack
Attachments:
open | download - repsnapper_04.jpg (169.3 KB)
Re: Repsnapper on ubuntu 11.04 - missing tabs?
August 17, 2011 02:43PM
I think that this version is version 1 of repsnapper it's not the version 2... But I'm not sure.
Sorry, only registered users may post in this forum.

Click here to login