Welcome! Log In Create A New Profile


Anycubic Kossel - Manual Leveling Issue ??

Posted by moon47usaco 
Anycubic Kossel - Manual Leveling Issue ??
December 19, 2017 04:20PM
I have just built my Anycubic Kossel and everything went perfectly except I found some strange issues when leveling the bed.

I was able to get all three points near the towers to zero as well as the center.

Printed my test Benchy and that came out almost flawless. The problem became apparent when I tried to print a larger model.

The filament and nozzle started to scratch into the build tack bed near the front.

I found another issue that is similar but was not rresolved in the post.
3DHUBS - Problems with leveling my first printer

I decided to test some more points, namely the ones between the towers at a similar radius as the tower test points.

Here are my results in the attached image:

In the front the nozzel grabs a piece of paper without too much resistance 0.04mm above all the tower and center point.

The point on the Left is low causing poor adhesion and the one on the Right slightly high but less noticeable in the print.

I have gone through guides like the one below and did not find any build issues (I will triple check this weekend in case I missed something).

What could be causing the difference in the points between the towers.

Everything seems to be printing fine if I avoid those areas for the first few layers.

With the exception of some dimensional offset.
IE printing a 10x10x10 (XxYxZ) cube will come out about 10.05, 9.95, 10.15
I do not want to get into that much but I though I should mention in-case it is related.

I will update as I proceed testing and adjusting.

Edited 6 time(s). Last edit at 12/19/2017 04:40PM by moon47usaco.
Re: Anycubic Kossel - Manual Leveling Issue ??
December 19, 2017 05:21PM
I, too, own an Anycubic Kossel, although mine is a Plus. I had the same problem, and ended up buying enough upgraded parts to build the thing a second time over, but what will ultimately save you the most time is learning that this is 80% a problem with your controller board. The Trigorilla is garbage, and doesn't really have the horsepower to prevent Effector Swing, which is creating that virtual wave effect on your bed. Some people can get it out by changing the rod length or Delta Radius parameters, but I couldn't, myself. I was forced into getting a 32-bit board, and haven't been happier.

I thought it was a problem with my rods not being the same length. I resized them all, and even bought a set of magnetic ball rods, but the uneven concave was still there. Then I played with parameters, which only got me to the point where I had about a 40mm radius that I could print on with proper bed adhesion. Doing this also took several hours. Finally, I gave up and bought a RADDS/Due/PanelDue, and I'm now confident that I can get the problem to go away, as delta movement is much better supported on the faster and bigger processor.

The best thing you can do right now is print out a Z-Probe, and try to fix it with auto bed leveling. Your mileage may vary, I never got it to work. Alternatively, you can play with all of the parameters that make up Delta Radius, or Delta Radius itself. With the Trigorilla RAMPS clone, you have to recompile every time you change those parameters, so it really just tests your patience to do it that way. My suggestion is to move on from 8-Bit computing, and use one of the options available to you in 32-Bit. I've learned a lot from the experience, so if you do go that route, feel free to PM me any further questions, or browse the forum.

I'll also try and sell you the upgrade with this. You no longer need to recompile your firmware every single time you change something. You can do it from a file on your sd card, and it takes 1/10th the time.

Edited 3 time(s). Last edit at 12/19/2017 05:25PM by Lobotomy.
Re: Anycubic Kossel - Manual Leveling Issue ??
December 19, 2017 05:43PM
Thanks for the info. The reason I got this printer was price to size so I will not be spending any more on this for now.

My thoughts are this is really not much of a concave/convex problem as that is usually the same distance at each corner/tower relative to the center.
(Assuming end stops and offset screws are adjusted properly)

What I have is a convex between x and y towers, a slight convex between y and z and a slight concave between x and z.

I think it must be a build issue of some sort but I can not find it.

I will try to post a graphic if I can.

Probably looks something like this in reverse (the nozzle height not the actual bed):

Edited 2 time(s). Last edit at 12/19/2017 05:57PM by moon47usaco.
Re: Anycubic Kossel - Manual Leveling Issue ??
December 20, 2017 02:11AM
This is probably due to the fact that the towers are not 100% at 120° from each other; you need to calibrate your tower angle corrections to correct this (and then re-adjust end-stops and delta radius)
Re: Anycubic Kossel - Manual Leveling Issue ??
December 21, 2017 07:46PM
So I am using marlin 1.1 that came with the printer and I am not sure how to edit the tower angle.

I went through this wiki doc below and made some adjustments, namely the distance between each tower at the top and bottom.

wiki link

I also added spacers to the carriage as I had originally added some to the pulleys because the screws that came with the machine bottomed out before tightening.

These things only shifted the problem to other areas as my values are now as shown.

At least I am not scraping the bed in the front but I have poor adhesion between the other two towers especially the left.

Edited 1 time(s). Last edit at 12/21/2017 07:47PM by moon47usaco.
Re: Anycubic Kossel - Manual Leveling Issue ??
December 21, 2017 10:06PM
If you're not fully up to date on the Marlin Firmware, then you may not even have tower correction. I remember that the version I started with did not. The Anycubic Kossel Thingiverse group has a couple of newer download links.

If you spend money on anything, buy some machined aluminum vertices for ~$35-50, depending on where you look. I know you wanted it for the budget factor, but there's really no getting around having to spend money on these horrid things. What those metal corners will do, is eliminate any question as to whether or not your corners are at 120 degrees. You put them on, measure the angle once, tighten them, and forget about it. That one piece, and an electronics upgrade down the line, is basically the difference between an awful printer that doesn't work, and a rigid one that works every time and produces beautiful prints. There isn't much to these robots, but every tiny improvement you make has an unreal impact on your print quality.

If it is the towers that are off-kilter, you'll want to at least correct that, and save yourself the trouble of ripping your hair out.

Edited 1 time(s). Last edit at 12/21/2017 10:09PM by Lobotomy.
Re: Anycubic Kossel - Manual Leveling Issue ??
December 22, 2017 03:33PM
In the document there is mention of G32 in RepRap FW; the Marlin equivalent is G33 (at least if you have a somewhat up to date Marlin FW)
Re: Anycubic Kossel - Manual Leveling Issue ??
January 10, 2018 07:30PM
On my Anycubic Kossel Plus, the aluminum effector baseplate was not symmetric. You can check this by measuring the distance of adjacent bolt heads (those fixing the diagonal rods). I had two times 14, one time 16 mm.

I printed a new plate, all leveling and dimensional calibration problems are gone now smiling smiley


Caution: This one is a bit smaller than the original. Your printable diameter will decrease, I am at 210 mm now. Of course the delta radius and probably arm length needs to be recalibrated (anyhow).

Good luck


Edited 1 time(s). Last edit at 01/10/2018 07:30PM by GER776.
Re: Anycubic Kossel - Manual Leveling Issue ??
January 10, 2018 11:06PM
I made a probe with this:

It is decent enough and sufficient to get G33 working, that fixed the major warpage and everything is within 0.1 now... =]

I was not able to get G29 auto leveling to work though. When enabled it crashed into the bed after my nozzle priming start g-code.
When I get time I will figure out what is wrong with that.

I plan on getting a FSR sensor or something similar to replace the getto removable probe.

I will check the effector plate as well though.
From the removable probe I know that it is not the same thickness on all three sides as the probe fits tighter on one side.

Edited 1 time(s). Last edit at 01/10/2018 11:07PM by moon47usaco.
Sorry, only registered users may post in this forum.

Click here to login