Welcome! Log In Create A New Profile

Advanced

Custom Delta Build, problem with accuracy

Posted by Nerveasy 
Custom Delta Build, problem with accuracy
June 01, 2017 12:19AM
So, I'm new to this forum but here it goes:

I build a custom delta with the following specs:

  • 200mm circular build platform
  • 207mm long diagonal rods
  • 700mm high - buildheight +-250mm
  • Distance between 2 diagonal rods: 60mm
  • 10mm dia. magnetic ball with custom machined cups as connections
  • piezo based auto bed leveling
  • 8mm smooth rods and brass linear bearings
  • alu extrusion rigid risers for structural stability
  • Atmega 2560 based motherboard with Marlin 1.1.0
  • T2.5 1350mm long rubber (no PU) belt with polyester string (no steel wire) embedded (5mm wide) now glued together but closed belt is ordered.
  • T2.5 pulley with 22 teeth on motor and a 625 bearing as idler on top (they have the same outer diameter)

Geometry is as good as I can get it (most parts are CNC'ed) and marlins calibration routines work and are followed diligently.

The printer is printing, and as long as I don't need anything dimensional (like ornamental stuff) it prints beautifully. But then the problems start...

When printing small circles or hexagonal pieces with dimensions I know (so I can check them afterwards) it's very wrong... the general dimensions are OK but: circles are not circular and thin walls where the nozzle went in one direction for one side and in the other direction for the other side they are not parallel:



When printing small thin rectangles that are parallel with the separate towers this happens (as explained before):




So in the center the prints are acceptable but at the extremities the problems get worse, especially when the object is in line with one of the towers. Hence this print:



I first thought this was a firmware problem but I not sure it is as I changed every value pertaining to the geometry slightly to see if the problem would get worse or improve. No dice sad smiley

I checked the play on the pulley and belt (videos):

[1drv.ms]
[1drv.ms]

There is a lot of play in my opinion. So I printed pulleys on my cartesian 3D printer and the problem improved slightly (ever so slightly...)
Now I'm looking into "zero backlash" T2.5 pulleys. Anybody knows these type of pulleys??

So after the pulleys I'm questioning the belt i'm using, Since it rubber and open ended I quess there will be a bit of stretch. Do you think this is a big factor?

And finally the smooth rods being 8mm they can flex a bit (being 700mm).

So my question: Does anybody recognize this printing behavior? Is this a telltale sign of a known problem?
In short: help!
Re: Custom Delta Build, problem with accuracy
June 02, 2017 12:49PM
Non circular circles is a tell tale sign of slack belts or improperly tightened belts.

How much adjustment do you have on them? Try tightening them and trying again.

With Delta style printers the centre is the most 'forgiving' zone. Any issues there are with the printer due to firmware or mechanical discrepancies will be magnified at the edges.
Re: Custom Delta Build, problem with accuracy
June 02, 2017 02:13PM
3 of the 4 image links in your post have the same URL, so I can't tell what you mean.


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet [www.duet3d.com].
Re: Custom Delta Build, problem with accuracy
June 04, 2017 11:20AM
Thx for belt tightening tip. I did not have any tightening possibility then (I pulled them tight and then bolted the idler), I redesigned that part and testing as i'm writing this. I have about 15mm of tensioning travel from "hand-tight" now using a bolt the pulls the idler up when tightening. I use about 4-5mm now and the belt is quite tight now.

The images ar indeed wrong these are the other ones:






Re: Custom Delta Build, problem with accuracy
June 04, 2017 12:10PM
No dice, the belts are reaaaally tight now but the problem is only marginally better, if that...:



Can flexing rods, open ended belt, or the play in the pulleys mentioned earlier create this problem??

sincerely
Re: Custom Delta Build, problem with accuracy
June 14, 2017 05:24AM
I changed the magnet balls, with different ones (smoother) and changed the idler to just 3 bearing together without flanges.

No longer able to tighten de idlers but doesn't seem necessary...

Beter prints now. Finally....
Sorry, only registered users may post in this forum.

Click here to login