Welcome! Log In Create A New Profile

Advanced

Any Tevo Little monster users around?

Posted by TheZombi122 
Any Tevo Little monster users around?
March 24, 2017 09:22AM
Hello all, Newbie here. I've ordered a Tevo Little Monster 370mmx500mm and am wondering if there are any users around?

I would like to ask about the Build and any issues I should expect getting this thing set up?

Is it worth getting the TL Smoother modules on order before it even arrives?

Regards

Mike
Re: Any Tevo Little monster users around?
May 22, 2017 09:47AM
yep. but I'm having a few problems... the x and y motors are not working now... grrrr.
Re: Any Tevo Little monster users around?
May 22, 2017 06:57PM
I have one but I've had to do a few replacements
- Replaced clone Titan with real E3D Titan
- Replaced clone Volcano with real E3D Volcano
- Had PETG stick too well to the build surfaced tore it

Have not found a suitable replacement for the build surface since Tevo does not have any spares available at this time.

Overall I like it but lack of replacement build surface has been a pain as I've had to resort to hairspray on glass and the associated mess and cleanup from that.
Re: Any Tevo Little monster users around?
May 25, 2017 10:52PM
A Little Monster user who was having problems with the electronics converted it to use a Duet Ethernet, and posted about it at [www.duet3d.com].


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet [www.duet3d.com].
Re: Any Tevo Little monster users around?
May 29, 2017 05:58PM
Well so far for mine I've had a BL Touch fail, the power leads in the cable from the power supply and back to the heated bed were miswired from factory and blew up the MKS Sbase 1.3 board and the power supply itself. the replacement MKS Sbase 1.3 card will not read the thermistors and doesnt seem to like the NTC ones from Fleabay. A 3rd MKS Sbase card has the same issue with the thermistors but is able to go part way through a calibration before the steppers go wild and it tries to drag its print head across the print bed.

I tried a MKS Base 1.4 ( Marlin ) board but i'm not at a high enough level to create a working delta setup for it so I plan to keep working at it so I've basically had a $1000 paperweight for the last 3 months.

anyone running a marlin config out there?
Sorry, only registered users may post in this forum.

Click here to login