Welcome! Log In Create A New Profile

Advanced

Z probe issue

Posted by Nate523 
Z probe issue
March 05, 2017 06:03PM
Ramps 1,4, 24V PSU, modified the D1 diode and changed polyfuse to work with 24V,

Z probe is a NPN inductive sensor, wired the brown to 24V, the blue to ground, and added a diode to the black and attached tothe S on the endstop pins.

Was working fine, then randomly it started always triggering high.

The problem I am facing is that I have switched ramps boards, switche npn sensors, and still no trigger. I get a led light on and off when I am close to the bed, but Repetier host does not recognize it as a trigger m119 returns Z-Probe_State : High always. Pulling my hair out because it was working just fine and was easy to install, now for some reason I cant get it to work at all.

EDIT: Just changed #define Z_PROBE_PULLUP 0 to #define Z_PROBE_PULLUP 1 and I get a constant Low signal, wont trigger to high.

Edited 1 time(s). Last edit at 03/05/2017 06:07PM by Nate523.
Re: Z probe issue
March 05, 2017 06:47PM
#define Z_PROBE_Z_OFFSET 0
#define Z_PROBE_Z_OFFSET_MODE 0
#define UI_BED_COATING 1
#define FEATURE_Z_PROBE 1
#define EXTRUDER_IS_Z_PROBE 0
#define Z_PROBE_BED_DISTANCE 10
#define Z_PROBE_PIN ORIG_Z_MIN_PIN
#define Z_PROBE_PULLUP 1

I have these settings on and if I use a typical endstop switch, it says high when it is not triggered, then says low when it is triggered. When I use the inductive sensor, it stays Low
Re: Z probe issue
March 05, 2017 07:21PM
NM, header was broken, works now with pullup = 1.
Re: Z probe issue
March 05, 2017 07:44PM
Good to see you got it sorted smiling smiley

Edited 1 time(s). Last edit at 03/05/2017 07:45PM by nebbian.
Re: Z probe issue
March 05, 2017 07:59PM
I'm not so sure, I am currently trying to figure out another issue on another thread, maybe it is as simple, but so far I haven't figured it out yet smiling smiley
Sorry, only registered users may post in this forum.

Click here to login