Welcome! Log In Create A New Profile


Z Axis Resets 15mm Above Bed

Posted by dolon 
Z Axis Resets 15mm Above Bed
August 12, 2017 12:25AM
Finally assembled my Flsun i3 Kit and after lot of false ends have got Repetier Host connecting to it.
Also corrected problem with a blank controller screen and Z axis going the wrong way.
Both were the result of wrong firmware. The supplier emailed a new version of Marlin.
The problem now is that at the start of a print the Z axis moves 15mm above the zero limit switch and begins printing in mid air!
I have checked Cura and Slic3r for any weird offsets but found nothing.
Is this a firmware issue or is it normal? What do I need to do to get it printing properly?
Have exchanged several emails with Flsun, who have always responded quickly, but I do not want to wait till Mon for next reply!
Re: Z Axis Resets 15mm Above Bed
August 14, 2017 12:07PM
When you home the Z axis does it moves towards the Z limit switch, press it and stop? After you home it send M119 and see where it thinks it is at.
Re: Z Axis Resets 15mm Above Bed
August 14, 2017 10:54PM
This has been the problem. It seemed to move up 15mm, every time it was started.
I think firmware was causing the weird moves. It is the Auto Level version and I was trying to rely on a Z limit switch.
But I think I have got it all working now. Printed my first part and it went well.
(The part is actually a bracket to hold the sensor as the supplied acrylic needed much modification.)
I changed over to Auto Bed levelling. Then use G28 to home the X & Y axes.
Then use G29 to Auto level. Then manual jog the Z down so nozzle is a paper thickness from bed and use that positon as Z offset.
I was also using M114 to get readout of the axes positions, but don't think I need it now with the above procedure.
Sorry, only registered users may post in this forum.

Click here to login