Welcome! Log In Create A New Profile

Advanced

3d printer- STEPPER - HELP

Posted by !v!ana 
3d printer- STEPPER - HELP
August 28, 2017 01:59AM
hi
I tried to build a 3d printer by MARLIN firmware , but I have some problem. I'm in the first step I just connect 1 stepper to a ramp1.4 with a driver ( also i configured marlin ) but when I want to control the stepper in the first time, it doesn't move and just trembled but after 30 second it work while if I restart it or it stops for more than 1 min , again it doesnt work and I have to wait for some second which means that after any stop it doesnot run some first commend.
Re: 3d printer- STEPPER - HELP
August 28, 2017 04:38PM
It appears you need to adjust the Stepper motor Current
Watch this Video

[www.youtube.com]

If you still have problems Post again we " the Forum " will help.
Re: 3d printer- STEPPER - HELP
August 29, 2017 10:50PM
You could flash the RAMPS_test program instead of Marlin to make sure hardware and wiring is working.
Then take the next step and test with Marlin. Use low acceleration and max. speed parameters first and go on from there.
Attachments:
open | download - _Ramps_test.ino (3.2 KB)
Re: 3d printer- STEPPER - HELP
September 09, 2017 02:34AM
thank you smiling smiley
Re: 3d printer- STEPPER - HELP
September 09, 2017 04:59AM
5 main causes.

marlin needs endstops plugged in. Make sure these are working. Use M119 to check endstop status.
make sure that you have the micro stepping jumpers installed under the stepper driver modules.
stepper motors wired incorrectly. remove the stepper plug from the controller. Check there is continuity from pins 1 and 2, and there is continuity from 3 and 4 on the 4 pin stepper plug.
Stepper motors have to be suitable for the stepper drivers.
vref has to be set on the stepper drivers.

Edited 1 time(s). Last edit at 09/09/2017 06:48AM by Dust.
Sorry, only registered users may post in this forum.

Click here to login