Welcome! Log In Create A New Profile

Advanced

Z Series Motors

Posted by lyro 
Z Series Motors
March 01, 2017 01:03AM
Hi there, I'm trying to build a 3d printer and I've completed the physical part, I wired my x,y, 2z and extruder steppers and tried them all. all worked fine but the z ones. I'm using ramps 1.4 so I had 2 sets of pins on the card, first I connected my motors that way. They didn't work whatever I did, so I decided to wire my motors in series, made them work, I tried to adjust the pot on the stepper driver but did no good and whenever I command them to move in one direction there's like 10% chance that one of the steppers will go in reverse direction, whether I give + or - direction, there's a chance that they'll just do whatever it is on their mind. Here are some config lines I hope may be causing the problem.

const bool X_MIN_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Y_MIN_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Z_MIN_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool X_MAX_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Y_MAX_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Z_MAX_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.
const bool Z_MIN_PROBE_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.



#define HOMING_FEEDRATE {50*60, 50*60, 4*60, 0} // set the homing speeds (mm/min)

// default settings

#define DEFAULT_AXIS_STEPS_PER_UNIT {80.477,80.315,2531.96,758.7} // default steps per unit for Ultimaker
#define DEFAULT_MAX_FEEDRATE {300, 300, 5, 25} // (mm/sec)
#define DEFAULT_MAX_ACCELERATION {3000,3000,100,10000} // X, Y, Z, E maximum start speed for accelerated moves. E default values are good for Skeinforge 40+, for older versions raise them a lot.

#define DEFAULT_ACCELERATION 3000 // X, Y, Z and E acceleration in mm/s^2 for printing moves
#define DEFAULT_RETRACT_ACCELERATION 3000 // E acceleration in mm/s^2 for retracts
#define DEFAULT_TRAVEL_ACCELERATION 3000 // X, Y, Z acceleration in mm/s^2 for travel (non printing) moves

// The speed change that does not require acceleration (i.e. the software might assume it can be done instantaneously)
#define DEFAULT_XYJERK 20.0 // (mm/sec)
#define DEFAULT_ZJERK 0.4 // (mm/sec)
#define DEFAULT_EJERK 5.0 // (mm/sec)

It's the first time I'm building a printer so thanks so there's a big chance I've missed something on config. Thanks on advance

Edited 1 time(s). Last edit at 03/01/2017 01:05AM by lyro.
Re: Z Series Motors
March 01, 2017 03:38AM
if your z motors are connected to m5 rods

#define DEFAULT_MAX_FEEDRATE {300, 300, 5, 25} // (mm/sec)

is two fast for them

change to

#define DEFAULT_MAX_FEEDRATE {300, 300, 2, 25} // (mm/sec)

some can get away with 3.
Re: Z Series Motors
March 01, 2017 04:21AM
Normally they are connected to m8 threaded rods, but I'm experimenting without connecting them to rods to avoid breaking the carrier of extruder
Re: Z Series Motors
March 02, 2017 12:53AM
If you are using the latest Marlin ( RC8 AFAIK ) then there is a setting in configuration_adv.h ( line 268 ff. ) to use two stepper drivers.

// A single Z stepper driver is usually used to drive 2 stepper motors.
// Uncomment this option to use a separate stepper driver for each Z axis motor.
// The next unused E driver will be assigned to the second Z stepper.
#define Z_DUAL_STEPPER_DRIVERS

This is the safest variant if you don't need the second extruder.
Re: Z Series Motors
March 05, 2017 09:48PM
Usually 2 Z steppers in series work fine, no need to change anything in firmware or driver voltage. How exactly did you wire them? In the mendel90 build manual the correct wiring is shown.
Sorry, only registered users may post in this forum.

Click here to login