Welcome! Log In Create A New Profile

Advanced

Sanguinololu 1.3a Huxley connection problem

Posted by Dam 
Dam
Sanguinololu 1.3a Huxley connection problem
June 26, 2016 02:29AM
Hi all,

I posted this in the Huxley section but figured it should maybe be in the Sanguinololu section. I apologize if I shouldn't do that.

I recently was given a Huxley 3d printer - the one from the original kickstarter.

I am trying to connect it to the computer. But windows simply does not pick it up. It doesn't recognize that anything is connected via the USB. The red light does come on, on the Sanguinololu 1.3a board.

I really don't know what I am doing to be honest, but I assume that there is probably something wrong with the board? I have tried to install all the drivers that I can find but no luck.

Any ideas would be greatly appreciated!

Thanks,

Damian
Re: Sanguinololu 1.3a Huxley connection problem
June 26, 2016 03:16AM
Does the device manager show a new usb device (even an unknown one) when you plug the controller in?

If it does what Vendor and Product ID does it show?

If 0000, google ftdi gate

If vender id is 0403, you just need ftdi drivers
from [www.ftdichip.com]

If the computer doesn’t notice the board at all, most probably the FTDI chip on the bottom of the board is dead

Edited 1 time(s). Last edit at 06/26/2016 03:18AM by Dust.
Dam
Re: Sanguinololu 1.3a Huxley connection problem
June 26, 2016 03:24AM
Thanks for the reply!

Unfortunately nothing happens at all. :/
Re: Sanguinololu 1.3a Huxley connection problem
June 26, 2016 03:34AM
Well unfortunately the usb plug of the board goes directly to the ftdi chip...

as you can see at the top of [reprap.org]

And since you have power, as the red LED is on

It could also be a bad solder on the usb connector...

Either way, its a hardware issue

I would check the soldering on the USB plug as a start...
Dam
Re: Sanguinololu 1.3a Huxley connection problem
June 26, 2016 07:25AM
I checked the soldering and the connection looks good. I will probably get a new board, but need to make sure that I am buying the right thing.

This looks to be the same thing, but I have no idea if it has that FTDI chip on the back. Any thoughts? Hoping I can source it locally (Cape Town, South Africa)

[www.communica.co.za]

Thank you for all the help!
Re: Sanguinololu 1.3a Huxley connection problem
June 26, 2016 08:31PM
Image 3 shows the ftdi chip.

Once you get his board you will have two options

1) attempt to configure the firmware from scratch, basically having to work out the machine specific details
(this is something I think everyone should know how to do, or how are you ever going to upgrade your firmware, but is quite daunting for the new user)

2) you could try removing the 40 pin chip from your current board and put it into the new board, both should be in sockets
Dam
Re: Sanguinololu 1.3a Huxley connection problem
August 06, 2016 03:59AM
Hey there,

I eventually got around to getting a new Sanguinololu board. Probably a very stupid question. Will I need to get a programmer to get a bootloader onto the board and then do firmware? I haven't touched it yet but I assume this can only be established if the a computer recognizes it or not?

Or should I replace the long black 40 pin chip from the old one. My only worry is seeing there was something wrong with the previous board, I don't want to damage the new one by changing components. (that is if it is possible to damage it by swapping that chip, I can only assume it would be possible)

Much thanks!

Damian
Sorry, only registered users may post in this forum.

Click here to login