Welcome! Log In Create A New Profile

Advanced

`.text' will not fit in region `text' during compile of firmware

Posted by graybeardtx 
`.text' will not fit in region `text' during compile of firmware
June 15, 2016 05:57PM
I am trying to write the bootloader and firmware to the Sanguino controller board on my reprap printer. I got an SD card with the package that supposedly had all the software for the system. After many false starts, I think I am on the right track but unable to reach the finish line. There are two tracks I have tried:
1. Assume that the hex file included in the firmware directory of the SD card is actually the combined bootloader and firmware saved as a hex file. I am trying to contact the manufacturer to verify this assumption. The first phase of the "burn bootloader" process is successful. The second step, actually uploading the hex data to flash memory goes through the write stage but hangs part way into the read stage where it is trying too verify the written data to the source data. Maybe the assumption is wrong but does this description pique any memories?

2. The firmware on the original board I am replacing was based on the Repetier firmware. I used the Repetier Firmware Configurator to build a new firmware profile using what I remember from the original. It compiles OK but when trying to upload, it generates a stack overflow in the text region. Full text of the error:
Arduino: 1.6.9 (Windows XP), Board: "Sanguino, ATmega1284 or ATmega1284P (16 MHz)"

c:/program files/arduino/hardware/tools/avr/bin/../lib/gcc/avr/4.8.1/../../../../avr/bin/ld.exe: C:\DOCUME~1\John\LOCALS~1\Temp\build1d76ff8a31b0f78df26120a58e13e379.tmp/Repetier.ino.elf section `.text' will not fit in region `text'

c:/program files/arduino/hardware/tools/avr/bin/../lib/gcc/avr/4.8.1/../../../../avr/bin/ld.exe: region `text' overflowed by 7708 bytes

collect2.exe: error: ld returned 1 exit status

exit status 1
Error compiling for board Sanguino.

Any ideas on how I can get around this?
Re: `.text' will not fit in region `text' during compile of firmware
June 17, 2016 12:12PM
Too many languages selected in the Configuration tool by default. Removed excess languages and it compiles fine except on WinXP.
Need to use the ArduinoIDE V1.0.6 ld.exe to compile.
Sorry, only registered users may post in this forum.

Click here to login