Welcome! Log In Create A New Profile

Advanced

Melzi lost USB connection

Posted by MCcarman 
Melzi lost USB connection
March 07, 2016 08:47AM
Hi all.
During printing the other day I had my Prusa clone jamb to the extent that it tripped the house mains supply.
On powering up again every thing works except there is no communication via USB. My Laptop doesn't respond (no comport recognition). I have changed the cable. Checked the Laptop is OK by using my other machine.
I have control of the printer via the LCD controls and can print from SD.
Its a Melzi V2.0 board running repetier firmware. Any ideas where it is broken? and how to fix?
I can't find any reference to this failure on the web. I think there is only the connector, TTL (is that the protocol ?) chip and a couple of capacitors before it goes into the processor.
If its the chip can I buy a USB to TTL lead and solder it in place of the on board chip?
Tonight i will check if the processor powers up when the jumper is set to USB 5V to see if the 5V is there. My probes on my MM are a bit to big to measure it off the connector and board.
Re: Melzi lost USB connection
September 14, 2016 05:26AM
Yeah, my suggestion would've been to try setting the jumper to USB power and see if there's any response. The fact that the LCD menus work is encouraging, it means that the 1284p is working as it should. Try buzzing out the USB connector with a multimeter to see if there are any broken connections. If everything checks out fine, you could try bypassing the FTDI Serial->USB chip and connecting directly to serial.
Sorry, only registered users may post in this forum.

Click here to login