Ploblem uploading sprinter firmware to sanguinololu (ATmege644P)
March 11, 2012 12:48PM
I’m a first time Prusa Mendel builder and would be grateful is someone could let me know what am I doing wrong? I’ve read through the posts in this forum, including the post from codec 02/23/2012, but this doesn’t solve my problem.

I’m using a windows XP environment and the sanguinololu 1.3a electronics with the ATmega 664P PCB with Sanguino-0023r3 software. The bootloader was installed prior to delivery.

Compiling in Arduino 0023 works fine but after uploading the sprinter firmware (Sprinter-6d5a329) with Arduino 0023, I receive the following message

Done uploading.
Binary sketch size 2486 bytes (of a63488 byte maximum)
avrdude: verification error, first mismatch at byte 0x0000
0x0c != 0x00
avrdude: verification error, content mismatch.


Tx/Rx test on USB-COM port with Putty is OK.
Baudrate for USB port and in Sprinter firmware is set at 115200.

I’m pretty sure I’ve followed all the instructions correctly from Arduino, including the sanguino program plug-in and have also downloaded Sprinter and made the necessary Changes to sprinter.pde:
In Configuration.h change:
#define MOTHERBOARD 62
float axis_steps_per_unit[] = {91.42857, 91.42857, 3200/1.25,700};
const bool ENDSTOPS_INVERTING = true

There are two things I’m not really 100% sure about:
1. The Arduino Tool/board setting. Is the sanguinololu the same as the sanguino W/ ATmege 664P?
2. In the sprinter.pde I’ve set float axis_steps_per_unit[]. to {91.42857, 91.42857, 3200/1.25,700}; although I can’t see this having any effect on anything at this stage

I would welcome any suggestions that would put me on the right track.
Re: Ploblem uploading sprinter firmware to sanguinololu (ATmege644P)
March 13, 2012 09:22AM
Hello, to anybody out there,

PROBLEM SOVLED. The original sanguinololu wasn’t working. Probably because I messed about with it a bit too often.

Bought a new sanguinololu and after a number of unsuccessful attempts, I changed to a different USB port, loaded new port driver and set port to 9600 Bits per sec.
Uploaded Sprinter firmware without any problems. At least no more weird text.
Of course I’ll need to reset the port baud rate to 115200 when I start using Printrun.

One step further and now onto the next problem (hope not).

Greetings from Robert
Re: Ploblem uploading sprinter firmware to sanguinololu (ATmege644P)
April 06, 2012 02:15PM
How can you test that the bootloader is working?

I have just built my Sanguinololu 1.3a, and downloaded the Sanguino-0023r3.zip software.

I have an Atmel stk500 and used it to load ATmegaBOOT_644P.hex file using AVR Studio 4 with the ATmega644P installed on the stk500 dev board.
AVR Studio recognized the device ID as being correct, and the download went without any error report.

I then set fuses same as for the Arduino bootloader. (BODLEVEL 2.7V, Disable JTAG, Disable CKDIV8, BOOT Flash size 4k, and SUT_CKSEL Crystal Osc 8.0- MHz; Start-up time 258CK + 65MHz

I also didi the lock as per the Arduino Bootloader; LPM and SPM prohibited in Boot Section, No lock in Aplication section

I then moved the ATmega644P to my Sanguinololu board and tried to load the Sprinter Software using Arduino 0022

I got the Comm port right, 9600bd, and Set RTS On Close.

The board type is Sanguino W/Atmega644P

The Sprinter software compiles using Verify, but every time I use Upload I get:

Binary sketch size: 29966 bytes (of a 63488 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

I have the 'Autoreset Enable' jumper installed on my board

I've tried the 'Hold Reset' work-around and a straight Upload, but always the same result.

Any suggestions would be welcome

John
Sorry, only registered users may post in this forum.

Click here to login