Welcome! Log In Create A New Profile

Advanced

windows 10

Posted by johnmbasic 
windows 10
August 04, 2015 07:25AM
hi I am new to 3d printing and just upgraded my backup pc to windows 10 , anybody upgrade yet with a prusa i3 mendel printer..if you did , did you have any issues with the programs for the printer.
any ideas suggestions would be of get help..no I haven't printed any thing yet with it just got it .
thanks have fun enjoy life..if ya get caught blame the dog

johnmbasic
Re: windows 10
December 21, 2015 09:45AM
I am glad you started the thread. I was just about to do the same for Windows 10.

I have a Replikeo Prusa i3 since November. My previous laptop was Win7 Pro. The printer and computer worked beautifully together.
The laptop died and I bought a new laptop with Windows 10. Pronterface saw the aurdino mega 2560 based printer in one session to print a test.
Now the device manager shows nothing at all.
I have searched the net and found some serious digital signature issues.
Alot of fixes stated to change the cable. Really? I ask.
What have you found that worked.
Thanks.

We two are at the forefront of this issue.
The masses will soon chime in.
Re: windows 10
December 21, 2015 11:03AM
Here is what looks like start...
Administrator
Re: windows 10
December 21, 2015 08:23PM
It gets worse:
Windows hoser
Re: windows 10
December 22, 2015 12:25AM
Try updating your Arduino installation. You probably need more recent versions of the drivers.


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet [www.duet3d.com].
Re: windows 10
December 22, 2015 08:50AM
Quote
dc42
Try updating your Arduino installation. You probably need more recent versions of the drivers.

Did this last night to no avail. The problem is deep in Microsoft. I did a print test prior to some updates.
They are moving towards digitally signed devices which Arduino is/was or wont be part of. Who knows.
The post in MS was directed exactly towards 3d printing since most of the cpus are arduino.
The printees have to sdcard their stls. I had removed my LCD interface to debug multiple problems before my previous laptop crashed.
So now I have a printer that can not get a connection to the MothershipDotZero to transport goods.
There is a good Microsoft joke there for the old heads...

Microsoft's connection to their printer. Hmmm no usb cable.
Wireless: Print over WiFi with the Cubify app for Mac OS X and Windows
Wired: Transfer print files with the USB stick (supplied with the Cube)
Mobile devices: Print direct with the Cubify app for iOS and Android (free download)

May the farce with us.

Edited 1 time(s). Last edit at 12/22/2015 09:00AM by Giantkiller.
Re: windows 10
December 22, 2015 01:11PM
Even though I mostly connect to my two 3D printers over Ethernet, for debugging and firmware updating I still use USB. The only issue I have noticed with Windows 10 is that when I switch my Duet controllers from normal mode into programming mode, Windows 10 takes several seconds to make the Bossa programming port available for firmware upload. Otherwise it works just as well with my printers as Windows 7 did. Sadly, the Edge browser doesn't work with DuetWebControl so I use Chrome or Firefox.

The drivers I am using are the ArduinoDue drivers from the latest version (1.6.6) of Arduino. I am also able to access and program my Arduino Uno and Arduino Leonardo boards from Windows 10.

PS - one thing I did find after "upgrading" to Windows 10 is that some of my USB devices no longer worked, for example my webcam. I resolved it by selecting "Update driver" for the USB controllers that were shown as using ULI drivers, and selecting the "Standard" drivers for them instead of the Uli ones.

Edited 2 time(s). Last edit at 12/22/2015 01:16PM by dc42.

Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet [www.duet3d.com].
Re: windows 10
December 22, 2015 02:07PM
I find out that I have 4 - 3.0 and 1 - 3.1 usb ports.
I will look into the ULI vs STD selection.
I am usb cabled to pc, arduino ide 1.6.7
Pronterface also doesnt show usb/com ports.
When I plug the usb cable in from the Arduino mega 2560 there is no registration beep. The driver / hardware shows no acknowledgement.

This should be interesting.
Re: windows 10
December 22, 2015 02:22PM
My laptop has 4 real ports. The left side doesn't work with my microsoft 2008 wireless /usb'd mouse but the wireless mouse works when I plug the wireless button on the right side ports.

The three sub hub drivers are ndigitally signed. All 3 are Microsoft.

I gotta get home to try mass port switching of devces.
Never thought of doing that.
Luckily I now have really short options to try.
If I can print I can solve the port issue later when I am ready for the elongated headache.

The random mystery is coalescing into a semi managable night mare.

And I have gone down this route before addressing USB manuf IDs to usb chips at the desgin and implementation layer.
When one learns a skillset, reality never really lets go of you and your abilities.

Edited 4 time(s). Last edit at 12/22/2015 02:58PM by Giantkiller.
Re: windows 10
December 22, 2015 06:25PM
My problem is solved. I tried the right side 3.0 usb ports and they work!

I am ahead of the game now while the world screams in pain for comfort.
Re: windows 10
April 18, 2016 08:13PM
Quote
Giantkiller
My problem is solved. I tried the right side 3.0 usb ports and they work!

I am ahead of the game now while the world screams in pain for comfort.

BRO, MY SAVIOR!!! LOL
I was not able to connect to my printer, but yet when MatterControl tried, it reset the printer - so obviously there was some communication. I saw your post and tried it. At first it didn't connect, but I tried setting com speed to 115k and it worked! WOOT! I'm BACK baby!
Re: windows 10
April 19, 2016 04:25PM
I have two threads working the same issue.

Glad it worked. I loathe machine headaches.

Edited 1 time(s). Last edit at 04/19/2016 04:26PM by Giantkiller.

Replikeo Prusa I3 Rework, Ramps 1.4, Marlin, Pronterface, Tinkercad.
Plan B is always to be somebody else.
Sorry, only registered users may post in this forum.

Click here to login