Welcome! Log In Create A New Profile

Advanced

uneven temperature, 19°C therm. disconnected

Posted by davidmonten 
uneven temperature, 19°C therm. disconnected
July 10, 2017 08:16AM
Hi everyone
I'm mounting two E3D extruders but when I read the temp it's not the same: it reads 24°C on the #2 (actual room temp) and 41°C on the #1 (both cool)
...and 19°C if I disconnect the #1confused smiley

I tried to connect another thermistor and it reads 41°c too.

note:
Before to achieve this the temp on the #1 was 0°C and I've found that one of the small PTFE sleeves protecting the wires near the sensor is broken, exposing the whire and short circuiting with the screw, and so with the gnd. I've fixed putting some ptfe tape to isolate it.

Someone may help me to figure out why it reads 19°C when disconnected?

Thank you very much winking smiley

Edited 1 time(s). Last edit at 07/10/2017 08:17AM by davidmonten.
Re: uneven temperature, 19°C therm. disconnected
July 10, 2017 06:37PM
I'm going to say it might be firmware related, maybe you selected the wrong resistance for #1.

A simple test would be to swap the two resisters on the control board, if the problem stays with extruder 1 then its firmware (or maybe a short on the control board), if the problem moves to extruder 2 then it might be with the thermister its self, but given you have already tried plugging in another thermister and its given the same results, my money is on it being a firmware issue.
Re: uneven temperature, 19°C therm. disconnected
July 10, 2017 07:18PM
I suspect the controller pin is dead. use a different pin (eg if ramps move to t2) or get a new controller.
Re: uneven temperature, 19°C therm. disconnected
July 11, 2017 02:09AM
Quote
scottybfg
I'm going to say it might be firmware related, maybe you selected the wrong resistance for #1.

Here is my fw, some weeks ago it was working
Marlin of course

#define TEMP_SENSOR_0 1
#define TEMP_SENSOR_1 1
#define TEMP_SENSOR_2 -1
#define TEMP_SENSOR_3 0
#define TEMP_SENSOR_BED 1

The firmware should be fine... (it's a standard _chinese_ Volcano with an NTC thermistor).

__


Quote
Dust
I suspect the controller pin is dead. use a different pin (eg if ramps move to t2) or get a new controller.

Damn...you're not the firts who suggest this.
Sensors pins should be robust, what could damage them? some tension going in? what should I avoid in order to not kill another pin?.
The fact thet the MCU reads a temp means that somewhere there's a resistance, a tiny one that it reads as 19° instead of 5° (#define HEATER_0_MINTEMP 5).

Fortunately i'm using a Megatronics v3 and I have some other temp sensor connection to use:
#1 thermistor: hot end Dx
#2 thermistor: heated bed
#3 thermistor: hot end Sx
#4 thermistor: idle
#1 thermocouple: idle (maybe the chamber temp...in the future)
#2 thermocouple: idle

Tests that I'll likey do:

- connect the thermistor on the #1 and see if it reads some variation and how it varies (it could be a fix value ti add to the thermistor resistance)
- connect on the #4 and see if it reads the same temp (modify the fw first)
- ...any other sugestion is welcomed grinning smiley

Thank you for your answers winking smiley
Re: uneven temperature, 19°C therm. disconnected
July 11, 2017 04:25AM
Background.

The thermistor is part of a 5v voltage divider.
This Voltage is feed into a ADC (analog to digital converter) pin on the main controller.
This provides a number to the cpu that represents the voltage.
This voltage is then looked up in the thermistor tables to display the correct temperature for the type of thermistor you have attached.

If this pin gets over 5v, it will die, (ie if you short it to a 12v heater cartage)
If you build up a static charge and then touch this wire going to the pin, it will die
If it came from china, and you look at it to closely, it will die.

Now there is a second resistor for each thermistor... the other part of the voltage divider... its possible that is damaged. If you can find it
Normally a 4.7k. But this is very unlikely

Edited 1 time(s). Last edit at 07/11/2017 04:25AM by Dust.
Re: uneven temperature, 19°C therm. disconnected
July 11, 2017 08:44AM
Quote

standard _chinese_ Volcano with an NTC thermistor
the volcano clones, v6 for that matter commonly come with NTC 3950 Thermistor 100K in marlin that be 13 or 11 but it aint 1 in thermistor selection
Sorry, only registered users may post in this forum.

Click here to login