Welcome! Log In Create A New Profile

Advanced

Z-axis not moving in relative mode?

Posted by Naesstrom 
Z-axis not moving in relative mode?
December 19, 2016 02:16PM
Im just finishing up my reprappro mendel build and I'm having some problems... When I'm not printing I can move the Z-axis just fine but when I'm printing it's not moving at all. so far I've narrowed it down to that it doesn't move when it uses relative coordinates, if it is then I can issue a G1 Z10 for example and all it does is move down to the endstop again. if I switch to Absolute mode it works as expected.
The axis is as in the image (ignore the mess)


Negative Y is towards the back where the endstop is, Negative X is towards the right and Negative Z is down, endstops are marked with white circles.

I have another mono mendel running at work but that doesn't use a ramps board so can't really compare the settings, would be grateful if anyone have time to check my configuration.h and see what might be wrong!

Edited 1 time(s). Last edit at 12/20/2016 12:27AM by Naesstrom.
Attachments:
open | download - Configuration.h (35.2 KB)
Re: Z-axis not moving in relative mode?
December 19, 2016 02:58PM
Quote
Naesstrom
Negative Y is towards the back where the endstop is, Negative X is towards the right and Negative Z is down, endstops are marked with white circles.

That's going to give you mirrored print.
With the physical location of your endstops

Y placement is fine, it's a min endstop, should be connected to the min endstop pins on your ramps
Z placement is fine, it's a min endstop, should be connected to the min endstop pins on your ramps
X placement is wrong, in Configuration.h, it's set as a min endstop, it should be connected to min endstop pins on ramps (but you have it placed physically on the printer as if it were a max endstop)

I'd change the X endstop to the other side

Also this appears wierd.

// Travel limits after homing
#define X_MIN_POS -60

#define Y_MIN_POS 0

#define Z_MIN_POS 14


Usually when you home it, it's at 0,0,0
I'd set all those to 0

If when you home the nozzle is off the bed, you should adjust by moving the endstops so they trigger at the place you want to be 0,0,0

Manually move the carriage and bed away from the endstops. Check your endstops by sending M119, they should report OPEN.

If not, try holding one with your finger and sending M119 again
It should go to TRIGGERED

Then you know your endstop is working

Another scenario could be that when you run M119, they report TRIGGERED
That usually indicates that they're not connected, or something's wrong wiring wise

Before you check the wiring though, try holding down and sending M119
IF it switches to OPEN while you're holding the switch
Then all you have to do is invert the logic in the Configuration.h

By setting the values for
const bool X_MIN_ENDSTOP_INVERTING
const bool Y_MIN_ENDSTOP_INVERTING
const bool Z_MIN_ENDSTOP_INVERTING

to false

Edited 1 time(s). Last edit at 12/19/2016 03:18PM by FA-MAS.
Re: Z-axis not moving in relative mode?
December 19, 2016 10:00PM
Quote
FA-MAS
Quote
Naesstrom
Negative Y is towards the back where the endstop is, Negative X is towards the right and Negative Z is down, endstops are marked with white circles.

That's going to give you mirrored print.
With the physical location of your endstops

Y placement is fine, it's a min endstop, should be connected to the min endstop pins on your ramps
Z placement is fine, it's a min endstop, should be connected to the min endstop pins on your ramps
X placement is wrong, in Configuration.h, it's set as a min endstop, it should be connected to min endstop pins on ramps (but you have it placed physically on the printer as if it were a max endstop)

I'd change the X endstop to the other side

Also this appears wierd.

// Travel limits after homing
#define X_MIN_POS -60

#define Y_MIN_POS 0

#define Z_MIN_POS 14


Usually when you home it, it's at 0,0,0
I'd set all those to 0

If when you home the nozzle is off the bed, you should adjust by moving the endstops so they trigger at the place you want to be 0,0,0

Manually move the carriage and bed away from the endstops. Check your endstops by sending M119, they should report OPEN.

If not, try holding one with your finger and sending M119 again
It should go to TRIGGERED

Then you know your endstop is working

Another scenario could be that when you run M119, they report TRIGGERED
That usually indicates that they're not connected, or something's wrong wiring wise

Before you check the wiring though, try holding down and sending M119
IF it switches to OPEN while you're holding the switch
Then all you have to do is invert the logic in the Configuration.h

By setting the values for
const bool X_MIN_ENDSTOP_INVERTING
const bool Y_MIN_ENDSTOP_INVERTING
const bool Z_MIN_ENDSTOP_INVERTING

to false

Ah crap, you're right... when I looked at the image on the website I noticed I need to turn the X axis 180°

And it also seems that the Y endstop is on the wrong side, it should be on the opposite side of the Y-engine confused smiley Guess I have to pick it apart and redo it again!

The part:
// Travel limits after homing
#define X_MIN_POS -60
#define Y_MIN_POS 0
#define Z_MIN_POS 14

Was to set the offset from the endstop to the start of the buildplate, the X_MIN_POS works as it should but maybe the problem lies in the Z_MIN_POS... I'll remove that one tonight when I get home before ripping it apart again!

I ran the M119 command earlier before starting printing and all endstops are working as they should btw so probably not that!

Thanks for all the help.
Re: Z-axis not moving in relative mode?
December 20, 2016 08:32AM
Your Y enstop is Ok where it's at,

Regardless of where the motor is at:

If you have the endstop at the back, it's a min endstop
You just may have to invert the direction of the motor to get it to move right

I'd say power the printer down, move the bed to the middle of it's movable range,
Power it back on, don't home it or anything

The printer should assume it's at 0,0,0
Hit Y+, it should move away from the endstop
Then hit Home Y, it should move towards the endstop

Those should both be the case
With how you have the firmware setup, they'll either both work that way or neither will

If it's moving the wrong direction
Power it down and flip the connector for the Y motor around on your RAMPS

Also remove those X Y Z_MIN_POS

In that version of Marlin, the XYZ_MIN_POS aren't offsets the way you think
It's more for when you're using Max endstops and your zero point is on the bed, and you can still mechanically (and want to for some reason) move below that zero point

Test it
When you get it moving/homing correctly
After you home it, send M114
It should tell you it's at 0,0,0

Now, the newer versions of Marlin DO have that ability, I use it
It's in a different section
For example, when I home my printer, the nozzle is 40 mm away from the bed, I told it that it's at -40 when homed
It makes it easier than having start gcode to move it to where you want the print to begin

You'll have to update to newer Marlin for it to work the way you're thinking
Otherwise, you have to move the endstop switches so that when homed, the nozzle is at what you'd like the 0,0,0 point to be on the bed

Edited 1 time(s). Last edit at 12/20/2016 08:47AM by FA-MAS.
Re: Z-axis not moving in relative mode?
December 28, 2016 07:36PM
My Geeetech Prusa I3 Pro A printer looks great assembled and everything seems to be well adjusted and operating smoothly.

EXCEPT:

System tries to start printing at the Z-axis height of Z:000.35 instead of at the Z:000.00 position.

- installed stop switch on the min z-axis position
- Bed leveled to the Z-axis min (home) position at the 0.0 height.

Before printing I auto home and then press the “set home offsets” selection.

The other problem I have is the bed temperature is not automatically set when I start a print from the SD card.

I am fairly comfortable editing the configuration.h and refreshing Marlin. I’ve included my configuration.h and a g-code from a recent test print.

I’m lost, any help is greatly appreciated. Thank you all!

Bill T
Indian Head, MD, 20640
Attachments:
open | download - Configuration.h (39.2 KB)
open | download - test2.gcode (422.9 KB)
Re: Z-axis not moving in relative mode?
December 29, 2016 12:20AM
Of course it does.. you cant print at z0, as the nozzle is hard against the build platform and thus blocked.

Bed temperature is set in your slicer, nothing to do with the firmware.
Sorry, only registered users may post in this forum.

Click here to login