Welcome! Log In Create A New Profile

Advanced

Teacup: M101, G162 and M92 commands (bugs?)

Posted by hariseldon78 
Teacup: M101, G162 and M92 commands (bugs?)
June 01, 2011 07:46PM
Hello. I'm trying to print something from my gen3 mendel with teacup firmware. I'm using skeinforge to generate the g-code, and then i'm sending each command individually from the terminal to debug better.

M101 problem:

when i insert this sequence of commands (produced by skeinforge)

M101
G1 X-16.24 Y15.05 Z1.04 F288.0
G1 X-13.92 Y15.05 Z1.04 F288.0
G1 X-13.92 Y-15.05 Z1.04 F288.0
G1 X-11.6 Y-15.05 Z1.04 F288.0


The printer move but don't print anything because the extruder motor is not moving. The only way to make it print is giving the E parameter in the G1 commands like this:

G1 X100 E100


G162 and M92 problems:

skeinforge has produced this gcode:

(**** begin homing ****)
G162 Z F500 (home Z axis maximum)
G161 X Y F2500 (home XY axes minimum)
G92 Z80 ( ---=== Set Z axis maximum ===--- )
G92 X-57.5 Y-57 (set zero for X and Y)
(**** end homing ****)


The first G92 command wants to set the max position on the Z axis, but the g162 command is implemented with "go back to home" and this cause a G1 Z0 command to push down into the bed (because no min stopper is checked).

The second G92 command has no effect. For some reason it accept only positive values, and all subsequent negative positions for x result in the motor pushing into the min stopper (because no min stopper is checked)

Could it be possible to have an optional
#define CHECK_OPTO_STOPPERS_AN_ALL_MOVES

for people who don't experience noise on the stoppers? or just to help in the debugging phase?

Edited 1 time(s). Last edit at 06/01/2011 07:48PM by hariseldon78.
Re: Teacup: M101, G162 and M92 commands (bugs?)
June 01, 2011 08:06PM
hariseldon78 Wrote:
-------------------------------------------------------
> Hello. I'm trying to print something from my gen3
> mendel with teacup firmware. I'm using skeinforge
> to generate the g-code, and then i'm sending each
> command individually from the terminal to debug
> better.
>
> M101 problem:
>
> when i insert this sequence of commands (produced
> by skeinforge)
>
> M101
> G1 X-16.24 Y15.05 Z1.04 F288.0
> G1 X-13.92 Y15.05 Z1.04 F288.0
> G1 X-13.92 Y-15.05 Z1.04 F288.0
> G1 X-11.6 Y-15.05 Z1.04 F288.0
>
> The printer move but don't print anything because
> the extruder motor is not moving. The only way to
> make it print is giving the E parameter in the G1
> commands like this:
>
> G1 X100 E100
>

This is exactly how its supposed to work. E is the length of extrusion, No E = no extrusion. You need to activate the dimension tab in skeinforge and set it to relative extrusion distance. Set the retraction distances to 0. Teacup has retraction built in.

>
> G162 and M92 problems:
>
> skeinforge has produced this gcode:
>
>
> (**** begin homing ****)
> G162 Z F500 (home Z axis maximum)
> G161 X Y F2500 (home XY axes minimum)
> G92 Z80 ( ---=== Set Z axis maximum ===--- )
> G92 X-57.5 Y-57 (set zero for X and Y)
> (**** end homing ****)
>
>

This is what is in your homing.gcode file in your alterations folder of skeinforge and you will have to edit it to work with your machine or turn it off in skeinforge. I assume this is one for a makerbot cupcake.


FFF Settings Calculator Gcode post processors Geometric Object Deposition Tool Blog
Tantillus.org Mini Printable Lathe How NOT to install a Pololu driver
Re: Teacup: M101, G162 and M92 commands (bugs?)
June 02, 2011 04:56AM
Thanks for the quick answer, i'll try immediatly.
Sorry, only registered users may post in this forum.

Click here to login