Welcome! Log In Create A New Profile

Advanced

LCD works, but encoder is not working, help?

Posted by aar510 
LCD works, but encoder is not working, help?
January 18, 2017 02:24PM
I'm using the REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER and the LCD works, but the encoder wheel doesn't work at all.
Did I miss something? Do I need to enable the encoder?

Thanks guys
Re: LCD works, but encoder is not working, help?
January 25, 2017 10:37AM
I'm having exactly the same problem with REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER running Marlin 1.1.0 RC6 on a Sanguinololu 1.2a board.
the 128x64 LCD is working nicely but turning and pressing the encoder doesn't do anything (remains on the home screen showing temperatures + xyz positions etc).
STOP button resets the micro-controller, which i believe is correct.

I've tried running sparkfun's second example project from [www.sparkfun.com] using the pins I've got in my pins_SANGUINOLOLU_11.h and it works! So looks like the hardware is okay, and I've found the right pin numbers.

For reference:
#define BTN_ENC 16
#define BTN_EN1 11
#define BTN_EN2 10

Configuration.h - [pastebin.com]

I read somewhere that these are important, but alas, no success yet.
#define ULTIPANEL
#define NEWPANEL

Any tips for the non-responsive encoder would be much appreciated!

Thanks
Chris
Re: LCD works, but encoder is not working, help?
January 25, 2017 12:27PM
If you are getting a MINTEMP error at the bottom of the LCD, connect your thermistors and check their setup.

The bottom line should then say 3D printer ready.

In my case on Marlin 1.1.0 RC6, THE MENU WILL NOT OPEN WITH UNLESS THE PRINTER IS "READY".

Easy solution smiling smiley Shame it took 2 days of head bashing to get there.
Sorry, only registered users may post in this forum.

Click here to login