Welcome! Log In Create A New Profile

Advanced

Dual Z drivers MARLIN/RAMPS (MKS Base 1.5)

Posted by RickRap 
Dual Z drivers MARLIN/RAMPS (MKS Base 1.5)
July 29, 2017 10:36AM
I have dual Z-axes that I want to have discreet drivers for. I have wired up the second Z axis to E1. I have enabled all the options in Marlin. This is able to drive the second Z axis with the E1 driver, but the steps per unit is way out of whack. It seems as though it's 10x the speed of the Z axis running off the Z driver.

Where do I set the steps for this second axis? I have tried doing so by defining a second E within Marlin, but the firmware recognizes that I've defined a second extruder and tries to use the next in line that's not in use (E2). It does not seem like the firmware is honoring the steps per unit of the Z driver.

Please do not suggest that I run both z-axes from a single driver. I have been doing this (both parallel and serial) and the performance is not what I need.

Marlin has the capability of setting this and I want to take advantage of it.


I design every day. You should too.
Re: Dual Z drivers MARLIN/RAMPS (MKS Base 1.5)
September 06, 2017 10:38AM
I have not heard of wiring the second Z motor to the E-1 driver, I am sure you could but I believe the accepted way to run dual Z motors is with one driver output.

I know you don't want to, but turning up your drivers output and running dual driver as you said you tried is what I would expect is what you need....


good luck smiling smiley

Edited 1 time(s). Last edit at 09/06/2017 10:40AM by JustSumGuy.
Re: Dual Z drivers MARLIN/RAMPS (MKS Base 1.5)
September 06, 2017 05:26PM
set steps/mm as e1

in configuration.h find something like

/**
* Default Axis Steps Per Unit (steps/mm)
* Override with M92
* X, Y, Z, E0 [, E1[, E2[, E3[, E4]]]]
*/
#define DEFAULT_AXIS_STEPS_PER_UNIT { 80, 80, 4000, 500 }

so you want to add a column and make it the same as Z value

eg #define DEFAULT_AXIS_STEPS_PER_UNIT { 80, 80, 4000, 500, 4000 }
Re: Dual Z drivers MARLIN/RAMPS (MKS Base 1.5)
September 06, 2017 06:53PM
Quote
JustSumGuy
I have not heard of wiring the second Z motor to the E-1 driver, I am sure you could but I believe the accepted way to run dual Z motors is with one driver output.

I know you don't want to, but turning up your drivers output and running dual driver as you said you tried is what I would expect is what you need....


good luck smiling smiley

The only reason it was 'accepted' is because older firmware did not support using the 5th driver (common on RAMPS, Smoothie, Duet, etc) that is commonly reserved for a second extruder. Latest version of Marlin has all the code needed to use E1 to drive a second stepper for any axis (most commonly Z)
This is preferred over driving two motors with one stepper.

Quote
Dust
set steps/mm as e1

in configuration.h find something like

/**
* Default Axis Steps Per Unit (steps/mm)
* Override with M92
* X, Y, Z, E0 [, E1[, E2[, E3[, E4]]]]
*/
#define DEFAULT_AXIS_STEPS_PER_UNIT { 80, 80, 4000, 500 }

so you want to add a column and make it the same as Z value

eg #define DEFAULT_AXIS_STEPS_PER_UNIT { 80, 80, 4000, 500, 4000 }

Yeah, tried that. No effect. You and I are thinking the same, however. Ultimately I think the driver on the board I was using (MKS 1.5) did not have the proper microstepping configured for it. That's the only conclusion I could come to. Otherwise, there may be a setting/bug buried somewhere within the firmware. I brought this same topic up on the Marlin GitHub board and we seem to agree that hardware microstepping is the problem.

It's a moot point, however. I went ahead and wired to a single driver. In the past, I did this in parallel as I was concerned about low voltage. Turns out, low current is more of a concern. Steppers need to be wired in series. I must have screwed this up in the past because I could never get it to work. I must be much smarter now because I had no problem wiring things up in series and it's working great. No problems.
Sorry, only registered users may post in this forum.

Click here to login