Welcome! Log In Create A New Profile

Advanced

pololu driver understanding?

Posted by bassman 
pololu driver understanding?
November 11, 2011 03:39AM
Hi, I have just changed the motors on my Z axis (Prusa Mendel) from the weedy disk drive motors I started with to a couple of the Pololu motors from Proto-Pic - 4v 1200ma/coil. The Pololu driver board with the 2 motors in parallel is getting very hot and tripping out. Obviously, running at full belt, the motors would draw more current than the driver could tolerate but I thought that the potentiometer on the Pololu driver board was supposed to limit the current delivered..... I currently have the pot set to about half travel. Is this not the case? I don't currently have any additional heat sinking on the driver board which is plugged into a RAMPS 1.2 board. So, should I fit a heatsink to the chip ( will epoxy be a suitable adhesive?), should I find a way to fit a fan blowing on the board or should I have connected the motor coils in series or something? Thanks..
Re: pololu driver understanding?
November 11, 2011 06:35AM
With no heatsink or fan you need to limit the current to about 1A. I don't know where that is on the pot, but it corresponds to 0.4V on the wiper.

If that is not enough torque you can increase the current by using a heatsink, or a fan or both. You can also get twice the torque for the same current by wiring them in series but your top speed may be less.

There are special thermally conductive glues and sticky pads for attaching heatsinks.

On my Prusa I wired two motors in series and use 1A with no heatsinks or fan but YMMV.


[www.hydraraptor.blogspot.com]
Re: pololu driver understanding?
November 11, 2011 06:51AM
Thanks Nophead, I think I will give them a try in serial. I assume you connect the start of one winding to the end of the other. i.e. on my motors the windings are red/blue and green/black so I assume it will need red of one motor to blue of the other etc. and that there's no devious trickery involved...?


Thanks, Ian
Re: pololu driver understanding?
November 11, 2011 07:35AM
Ok, now wired in series and working fine. I now have a small problem with Marlin not homing as I expect but I'll put that on another forum..


Thanks, Ian
Sorry, only registered users may post in this forum.

Click here to login